10 Replies Latest reply: Jul 17, 2007 4:06 PM by Peggy
ballred51 Level 1 Level 1 (5 points)
I recently had to force quit after my computer locked up during the optomizing phase of a software update. I just realized that AppleWorks 6 won't open. I've tried several of the suggestions found in this forum: restart, dump the preferences, run repair disk, and repair disk permissions. I've tried to reinstall from my original AppleWorks disk, but am not able to launch the install application on the disk. Any other suggestions?

MacBook Pro   Mac OS X (10.4.10)  
  • Peggy Level 8 Level 8 (38,585 points)
    Welcome to Apple Discussions

    It appears you have done the correct steps in trying to recover from a crash of AppleWorks, but I wonder if you got all of the necessary preference files when you deleted the AppleWorks preferences.

    Another thing to try is to see if AppleWorks will run for another user on your Mac. If it does, it's a sure sign the problem is in your account.

  • ballred51 Level 1 Level 1 (5 points)
    I tried creating a new user and logged in, but still couldn't open AppleWorks. I also checked the preferences and I think I dumped everything you said.
    the most puzzling part to me is that I can't even open the AppleWorks install disk. Is there a way to uninstall without the disk?
  • Barry Level 7 Level 7 (29,465 points)
    How old is your AppleWorks install disk? On earlier versions the installer requires Mac OS 9.x.x to run (although it will install both Mac OS 9 and OS X versions of AppleWorks). Mac OS 9 is not supported on the intel based Macs.

    Using that install disk, you should be able to install AppleWorks onto a machine that does support Mac OS 9 either directly or through the Classic environment.

    Once it's installed, download and run the updater if the installed version is not either AW 6.2.4 or AW 6.2.9 (See note below). Then burn the whole AppleWorks 6 folder and its contents onto a CD, transfer the CD to your MacBook and copy the folder to the Applications folder on the MacBook. AppleWorks will create new preference files as it needs them.

    To stay within the terms of the User agreement, you should delete the AppleWorks 6 folder from the Mac OS 9 machine used as an interim step in the process.

    UNINSTALLATION

    The basic uninstallation is pretty simple—drag the AppleWorks 6 folder from Applications to the Trash.

    Because you also want to reinstall, you should also delete the preferences files described in Peggy's post.

    If you were NOT reinstalling, you might also want to delete the AppleWorks User Data folder in your Documents folder.

    Regards,
    Barry

    *AW 6.2.4 is the earliest version that is stable in OS X. It is also able to open some older AppleWorks and ClarisWorks files that cannot be opened using AW 6.2.9. AW 6.2.9 is the most recent, and apparently the last, version of AppleWorks for Macintosh. It contains a number of bug fixes, many of them removing bugs introduced in the 6.2.7 update, and adds support for scrollwheel mice. AW 6.2.7 is quite buggy and should be avoided. See also Peggy's first post in this thread.
  • ballred51 Level 1 Level 1 (5 points)
    My version of AppleWorks is 6.2.4. I've dumped my AppleWorks in the trash, but still can't get the install application to launch from the disk. The icon flashes for a second and disappears.
  • Peggy Level 8 Level 8 (38,585 points)
    Dump question, but did you empty the Trash? You'll need to hold down the Option key to empty it of some locked files.

    This is beginning to sound more like an OS issue than an AppleWorks one. So, the first thing I suggest is repairing permissions using Disk Utility even though you've done it before. Then, unless you leave your Mac on 24/7 & not asleep, run a utility to run the UNIX cron routines & clean caches. I prefer YASU because you can’t delete something you shouldn’t as you can with OnyX. The only thing not checked by default that I would check are the three cron scripts at the top left of the newest version.

    Also, make sure your hard drive isn't too full. It depends on how you use your computer, but for most normal users a minimum of 5 gigs free space at all times after installation is recommended. Power users may need more.

    If this still doesn't work, repairing your hard drive with Disk Utility may help. Start up your Mac from the first Panther (10.3.x) install disk. Then, instead of running the installer, go to the Installer menu & choose Disk Utility. Select your hard drive in the left-hand panel & click Repair Disk. When it is done, quit Disk Utility then quit Installer & restart your Mac.

  • ballred51 Level 1 Level 1 (5 points)
    I had completely emptied the trash. Now I have run the repair permissions utility again with no luck. Where do I find the UNIX thing to clean caches and cron routines?
  • ballred51 Level 1 Level 1 (5 points)
    I have now tried running the disk repair from the software that came with my computer. Still no luck. What else could I try?
  • ballred51 Level 1 Level 1 (5 points)
    I have discovered another program that won't launch and won't launch from the original disc. It is my HP photo gallery program. Can someone please point me in the right direction towards what kind of problem I may have. No sure about which forum to try next.
  • ballred51 Level 1 Level 1 (5 points)
    Thank you Peggy for all the suggestions. I finally found the Onyx program, downloaded it, and ran the optomizing and cleaning utilities. Not sure which one worked, but problem solved. You're a genious!!
  • Peggy Level 8 Level 8 (38,585 points)
    You're welcome.

    I'm sorry I couldn't post a link earlier today but I was doing a quick read of the forums before I left for work.