6 Replies Latest reply: Oct 2, 2007 12:15 AM by gfguthrie
barnsey Level 1 Level 1 (0 points)
Since I upgraded to 7.3.1 I've been getting an error -54 when trying to sync all ipods, (tried a mini and an older shuffle, get the same problem). Itunes syncs about 27 or 28 tracks and then gives the error message, "attempting to copy to the disc failed, an unknown error ocurred, (-54)"

I've tried deleting and reinstalling itunes, but i'm still getting the same error.

Can anybody help?

Mac mini, Mac OS X (10.4.10)
  • Laarni_RN Level 1 Level 1 (0 points)
    I'm getting this same error. So far, no REAL replies or solutions. However, I'm thinking about downgrading back to 7.2. It seems alot of people are having problems with the update to 7.3. The threads that I have seen, people just go back to the older version and it fixes things. Good luck!
  • Laarni_RN Level 1 Level 1 (0 points)
    I just trashed 7.3.1 and downloaded 7.2 again and all is well with my iPod again. Thank God! I was going to get a whole new one! Try that and it should fix this error issue until they come out with a better update. Good Luck!
  • sveinur Level 1 Level 1 (0 points)
    Copy/paste this to your Apple Script editor and then press Play!

    tell application "Finder"
    set locked of every item of entire contents of folder "your folder" to false
    end tell
  • roderz Level 1 Level 1 (0 points)
    I've tried this tip but applescript editor cannot run it, I've replaced @my folder with the name of my home folder, but no go. What/how does this applescript fix this issue, and how do I make it work?
  • barnsey Level 1 Level 1 (0 points)
    so it seems to me that this error occurs if you happen to have tracks encoded with V4.7.0.42. If you look at the info for the tracks that are causing you a problem I bet they show that version of the encoder. all other encoding versions are fine. Come on Apple what the bleedin ell is going on! I've 60 or so albums that I cant put on my ipod now! Having to re-rip where I still have the CD's and they arent buried in the loft, or convert to MP3 using a program called switch. It works but it takes a while.

    Any body else got the same problem or knows of a better solution.

    Cheers ears
  • gfguthrie Level 1 Level 1 (0 points)
    You have to modify it to be something like this, so that it travels the heirarchy correctly (I had another folder in my Music folder that I wanted to import to iTunes):

    tell application "Finder"
    set locked of every item of entire contents of folder "audio" of folder "Music" of folder "username" of folder "Users" of startup disk to false
    end tell

    After I ran this I got it to import just fine.