9 Replies Latest reply: Aug 29, 2007 1:28 PM by Rvtifer
pmonks Level 1 Level 1 (0 points)
I recently purchased a MacBook and have been unable to get it to mount Samba shares on my home server (an Ubuntu Linux machine). I've tried mounting via both the Finder (Go > Connect to Server) and the terminal (mount_smbfs) and neither works. What's interesting is that smbclient IS able to connect and works flawlessly. Other OSes (including various flavours of Windows - 2000, XP and Vista as well as Linux) also connect to the server and work flawlessly, leading me to suspect a misconfiguration of mount_smbfs on the MacBook.

I've spent several hours googling on this issue and have tried numerous fixes that appear to work for others (including using IP address instead of server names, configuring the MacBook to use Samba on the Linux machine as a WINS server, using a wired connection instead of wireless, creating an /etc/nsmb.conf file with a minauth=none setting etc. etc.). None of them have changed the behaviour at all - even the error codes and messages remain the same.

I'm not sure which of the following information is relevant, but with any luck it might ring some bells for someone:
* Samba (Ubuntu): v3.0.24
* Samba (MacBook): v3.0.10
* smbclient: v3.0.10
* mount_smbfs: v1.3.7
* output from kextstat com.apple.filesystems.smbfs: 1.3.7
* Error code from finder: -36
* Error message from mount_smbfs: mount_smbfs: negotiate phase failed: syserr = Operation timed out
* Error messages from Finder (as seen in the console log): mount_smbfs: 2 failures to open smb device: syserr = Resource busy [seems a bit suspicious that mount_smbfs and the failure report different errors]
* Same behaviour both wired and wireless

MacBook, Mac OS X (10.4.10), Server is Ubuntu 7.10 with standard Samba installation (3.0.24)
  • pmonks Level 1 Level 1 (0 points)
    More information: I'm seeing the same behaviour when attempting to mount a share on a Windows Vista box, which lends evidence to the theory that it's a problem with the SMB client on the MacBook, and not something to do with the server (since the same things happens for two quite different servers).

    Anyone care to comment on their success (or otherwise) getting Mac OSX 10.4.10 to connect to an SMB/CIFS based file server?
  • Rick Van Vliet Level 5 Level 5 (6,385 points)
    Does this mac have the same workgroup name that the other machines have?
    Configure it in Directory Access>SMB/CIFS...

    Check to be sure that stealth is OFF on this mac firewall. Heck, turn off firewall during troubleshooting.
  • pmonks Level 1 Level 1 (0 points)
    Thanks for responding Rick.

    I do have the workgroup name configured in Directory Access > SMB/CIFS, but hadn't thought to look at the firewall settings (which, in hindsight, should have been an obvious thing to check). I'll try that and report back with what I find.
  • Rick Van Vliet Level 5 Level 5 (6,385 points)
    If smb_client in Terminal does work, then you're probably going to find a Keychain entry that needs to be nuked.
    The firewall might be blocking certain port traffic, too. 'Specially if you've got stealth turned 'on'

    That's the way I see it from here, FWIW.
  • pmonks Level 1 Level 1 (0 points)
    Turns out the firewall was already turned off. Just for laughs I turned it on (with logging turned on and stealth turned off) but there was no change in behaviour, nor were there any entries in the firewall log.

    Some interesting progress is that when I tried it just now I could see my Windows machine in Finder > Network > WORKGROUP and was able to mount a share on it. Over the weekend I renamed the MacBook to have a shorter name (it was previously "FirstName LastName's Computer", which violates a number of NetBIOS naming rules) - perhaps that helped? I doubt turning on the firewall would have done it!

    Still no joy mounting the Samba shares however - smbclient is still working flawlessly but mount_smbfs and Finder > Go > Connect to server are both continuing to fail.
  • Rick Van Vliet Level 5 Level 5 (6,385 points)
    Short name good.
    Toggling firewall might have done something.
    Have you restarted Mac?

    Workgroup name can be a significant thing with Samba....
    restart all machines, just for good sport.?

    Message was edited by: Rick Van Vliet
  • pmonks Level 1 Level 1 (0 points)
    I just restarted everything (except the Windows PC, which isn't really part of the picture anyway) but no joy - it's still not able to connect to the Samba machine using mount_smbfs or Finder > Go > Connect to Server.

    smbclient continues to function merrily however. I almost wish it didn't work - at least then I'd be facing a more fundamental problem. I'm beginning to feel like the MacBook is taunting me - "now I work, now I don't, nyer nyer!"
  • Rick Van Vliet Level 5 Level 5 (6,385 points)
    repair Permissions
    KeychainAccess First Aid.
    remove keychains that refer to this server.

    I'm running out of ideas
  • Rvtifer Level 1 Level 1 (0 points)
    For whatever it is worth, I have th esame problem which is still nto resolved and when changing the computer name I, too, saw "workgroup" and "my network" appear under the finder network but no computers visible inside ... Switched to Mac three weeks ago and thi sis the first wall that I hit ... any ideas. Thanks, Herve