12 Replies Latest reply: Jul 31, 2007 5:36 PM by Phil Oye
Phil Oye Level 1 Level 1 (85 points)
I need some help here people, thanks in advance...

My copy has all of the sudden begun to crash on startup. It bounces a couple of times in the dock and then disappears.

I started while holding "shift" when starting Aperture to no avail. I trashed the preferences with no effect. I removed ~/Library/Application Support/Aperture/ with no change. My computer is up to date, including OS (10.4.10), Pro Application Runtime (v4.0), latest version of Aperture (1.5.3), all security updates, etc. I don't think I have anything crazy going on my machine otherwise.

Getting frustrated, I went to reinstall the app and the installer (from Aperture 1.1 I believe) crashes as well! I've also run disk utility and everything checks out, and I've rebooted a few times, etc. I tried logging in as another user and I get the same behaviour.

My computer is otherwise fine, everything else works--except Aperture. Any ideas?

Abbreviated crash logs for Aperture and Installer are below, let me know if you need me to paste the entire log (and why don't these forums accepts links?)

Thanks in advance,
p.

Aperture

===== Thursday, July 26, 2007 10:02:11 PM Australia/Sydney =====
********

Host Name: philoye-G5
Date/Time: 2007-07-26 22:02:16.077 +1000
OS Version: 10.4.10 (Build 8R218)
Report Version: 4

Command: Aperture
Path: /Applications/Aperture.app/Contents/MacOS/Aperture
Parent: WindowServer [74]

Version: 1.5.3 (1.5.3)

PID: 399
Thread: 0

Exception: EXCBADACCESS (0x0001)
Codes: KERNPROTECTIONFAILURE (0x0002) at 0x00000006

Thread 0 Crashed:
0 com.apple.CoreFoundation 0x907bddf8 CFRelease + 92
1 com.apple.Aperture 0x00417d34 0x1000 + 4287796
2 com.apple.Aperture 0x0041959c 0x1000 + 4294044
3 com.apple.Aperture 0x004119e0 0x1000 + 4262368
4 com.apple.Aperture 0x00412480 0x1000 + 4265088
5 com.apple.Aperture 0x0041327c 0x1000 + 4268668
6 com.apple.Aperture 0x00019e10 0x1000 + 101904
7 com.apple.prokit 0x96e8aa28 _DoProSplashWithPath + 152
8 com.apple.prokit 0x96e8ab60 DoProSplash + 160
9 dyld 0x8fe15608 ImageLoaderMachO::doInitialization(ImageLoader::LinkContext const&) + 816
10 dyld 0x8fe0ba68 ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&) + 212
11 dyld 0x8fe0b9f8 ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&) + 100
12 dyld 0x8fe0d5ec ImageLoader::runInitializers(ImageLoader::LinkContext const&) + 92
13 dyld 0x8fe02cb4 dyld::initializeMainExecutable() + 84
14 com.apple.Aperture 0x00002b04 0x1000 + 6916
15 com.apple.Aperture 0x000029d0 0x1000 + 6608

Installer

Date/Time: 2007-07-26 22:01:45.775 +1000
OS Version: 10.4.10 (Build 8R218)
Report Version: 4

Command: Installer
Path: /Applications/Utilities/Installer.app/Contents/MacOS/Installer
Parent: WindowServer [74]

Version: 2.1.7 (95)
Build Version: 92
Project Name: Installer
Source Version: 950000

PID: 388
Thread: 0

Exception: EXCBADACCESS (0x0001)
Codes: KERNPROTECTIONFAILURE (0x0002) at 0x00000006

Thread 0 Crashed:
0 com.apple.CoreFoundation 0x907bddf8 CFRelease + 92
1 ...ECoretech.AELicensingPlugin 0x016ea91c GetMACAddressCFStringRef + 360
2 ...ECoretech.AELicensingPlugin 0x016ea08c aelCryptoRawKeyCreate + 72
3 ...ECoretech.AELicensingPlugin 0x016e5fd4 aelUsesEncryptedSerialNumber + 668
4 ...ECoretech.AELicensingPlugin 0x016e6a4c aelReadCurrentLicenseFile + 524
5 ...ECoretech.AELicensingPlugin 0x016e1d84 AELCheckLicenseFile + 72
6 ...ECoretech.AELicensingPlugin 0x016e1ee8 AELCheckLicenseFiles + 164
7 ...ECoretech.AELicensingPlugin 0x016dfe44 0x16de000 + 7748
8 ...ECoretech.AELicensingPlugin 0x016e1d0c 0x16de000 + 15628
9 ...ECoretech.AELicensingPlugin 0x016e1ca4 0x16de000 + 15524
10 com.apple.installer 0x0001b130 -[PageController(PluginLoading) loadSections] + 1160
11 com.apple.installer 0x00004ef0 -[PageController awakeFromNib] + 1528
12 com.apple.AppKit 0x937b7ab0 -[NSIBObjectData nibInstantiateWithOwner:topLevelObjects:] + 928
13 com.apple.AppKit 0x937a3c9c loadNib + 240
14 com.apple.AppKit 0x937a36f4 +[NSBundle(NSNibLoading) _loadNibFile:nameTable:withZone:ownerBundle:] + 716
15 com.apple.AppKit 0x937fabc4 +[NSBundle(NSNibLoading) loadNibFile:externalNameTable:withZone:] + 156
16 com.apple.AppKit 0x9388aa70 +[NSBundle(NSNibLoading) loadNibNamed:owner:] + 344
17 com.apple.installer 0x00004510 -[PageController openWithDistribution:withError:] + 1256
18 com.apple.installer 0x00004014 -[PageController openDistributionWithPath:withError:] + 288
19 com.apple.installer 0x00003e48 +[PageController newControllerForDistributionAtPath:withError:] + 84
20 com.apple.installer 0x00003b18 -[InstallerController openFile:withOptions:] + 240
21 com.apple.installer 0x00003a14 -[InstallerController application:openFile:] + 76
22 com.apple.AppKit 0x9379b070 -[NSApplication _doOpenFile:ok:tryTemp:] + 388
23 com.apple.AppKit 0x939d304c -[NSApplication _doOpenFiles:] + 224
24 com.apple.AppKit 0x939d2f44 -[NSApplication(NSAppleEventHandling) _handleAEOpenDocuments:] + 88
25 com.apple.AppKit 0x9379f640 -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] + 296
26 com.apple.Foundation 0x92be0af0 -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] + 380
27 com.apple.Foundation 0x92be0950 _NSAppleEventManagerGenericHandler + 92
28 com.apple.AE 0x914fe960 aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned long, unsigned char*) + 208
29 com.apple.AE 0x914fe7fc dispatchEventAndSendReply(AEDesc const*, AEDesc*) + 44
30 com.apple.AE 0x914fe654 aeProcessAppleEvent + 284
31 com.apple.HIToolbox 0x9329a2e0 AEProcessAppleEvent + 60
32 com.apple.AppKit 0x9379dcbc _DPSNextEvent + 856
33 com.apple.AppKit 0x9379d7a8 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 116
34 com.apple.AppKit 0x93799cec -[NSApplication run] + 472
35 com.apple.AppKit 0x9388a87c NSApplicationMain + 452
36 com.apple.installer 0x00002ba4 main + 284
37 com.apple.installer 0x000026ec _start + 340
38 com.apple.installer 0x00019360 start + 60

Thread 1:
0 libSystem.B.dylib 0x90023c60 recvfrom + 12
1 com.apple.installframework 0x993b1f3c dolog_udplisten + 252
2 libSystem.B.dylib 0x9002bd08 pthreadbody + 96

Thread 2:
0 libSystem.B.dylib 0x9002c3c8 semaphorewait_signaltrap + 8
1 libSystem.B.dylib 0x90030eac pthreadcondwait + 480
2 com.apple.Foundation 0x92be730c -[NSConditionLock lockWhenCondition:] + 68
3 com.apple.installframework 0x99400dec +[IFDTargetController(WorkerThread) _handleTargetRequests] + 852
4 com.apple.Foundation 0x92be01a0 forkThreadForFunction + 108
5 libSystem.B.dylib 0x9002bd08 pthreadbody + 96

Thread 3:
0 libSystem.B.dylib 0x900411f8 machwaituntil + 8
1 libSystem.B.dylib 0x90040fc4 nanosleep + 388
2 libSystem.B.dylib 0x90044798 usleep + 88
3 com.apple.DiskManagement 0x95761e0c -[NSRunLoop(DMRunLoopAdditions) runUntilDateAndBlock:] + 100
4 com.apple.DiskManagement 0x95761c08 -[DMManager waitForAppearanceOfDiskNodes] + 148
5 com.apple.installframework 0x993bbbf0 -[IFDiskManager enableDiskArb] + 304
6 com.apple.installframework 0x993bb254 -[IFDTargetController(DiskProcessing) _processInitialDisks] + 124
7 com.apple.Foundation 0x92be01a0 forkThreadForFunction + 108
8 libSystem.B.dylib 0x9002bd08 pthreadbody + 96

Thread 4:
0 libSystem.B.dylib 0x9004a6e8 syscallthreadswitch + 8
1 com.apple.Foundation 0x92bf85dc +[NSThread sleepUntilDate:] + 152
2 com.apple.AppKit 0x9383aa10 -[NSUIHeartBeat _heartBeatThread:] + 1100
3 com.apple.Foundation 0x92be01a0 forkThreadForFunction + 108
4 libSystem.B.dylib 0x9002bd08 pthreadbody + 96

Thread 5:
0 libSystem.B.dylib 0x9003288c wait4 + 12
1 com.apple.Foundation 0x92bce454 _waitForTermination + 40
2 libSystem.B.dylib 0x9002bd08 pthreadbody + 96

PowerMac G5/Dual 2.5, Mac OS X (10.4.10), 4 gigs of ram
  • Tincho Level 1 Level 1 (5 points)
    I have a similar problem that I traced to corrupted file crashing Aperture while trying to create a preview. In my case, holding SHIFT while opening and keeping it pressed until the application was fully loaded works fine.

    How and where did you access the aperture crash log? I want to try to find out which image is causing this.

    Thanks.
  • Phil Oye Level 1 Level 1 (85 points)
    As I said, holding SHIFT on startup does nothing for me...

    You can find crash log using Console.app in Applications/Utilities/. Open "Logs" (top left icon), expand ~/Library/Logs, expand "CrashReporter", then select the app you want, in this case "Aperture.crash.log".

    Cheers,
    p.
  • Tincho Level 1 Level 1 (5 points)
    Thanks so much.
  • Phil Oye Level 1 Level 1 (85 points)
    No one has any suggestions?
  • Xorge Level 1 Level 1 (0 points)
    If you hold down option/command while starting Aperture it will give you the option to rebuild your library. I don't know if this will solve your problem but it's worth a try.

    BTW, What is the purpose of holding down the shift key while starting this app?

    Good Luck...
  • Phil Oye Level 1 Level 1 (85 points)
    Actually, I'm not sure what "Shift" is supposed to do, but one of the pages I found during my Google-searching suggested it, so I tried it.

    At any rate, I've tried Command/Option but no joy. Keep those suggestions coming!
  • Phil Oye Level 1 Level 1 (85 points)
    I tried something else, just to mix things up. I removed my aperture library out of the ~/Pictures directory hoping it would startup and recreate the database. But no joy there either. It still crashes on startup...

    Does anyone have any thoughts on next steps? What kind of "official support" is available? I bought Aperture more than a year ago...
  • dsystems Level 1 Level 1 (0 points)
    I hope this helps. I found that Automatically generating previews was causing my system to take a very long time to open or worse (52,000+ photos, 95 gig database). The previews added more than 30 gigs to my database. Also, *Aperture dose not respond to the operating system when doing previews*. *This causes a crash if you try using anything while Aperture is “not responding”*. It may corrupt the data base (loose pictures and not let know it after the crash). The Disk utility did NOT catch the missing pictures or corrupt files. Only booting up with DISKWARRIOR found the corrupted files and missing pictures. I LOST many pictures before figuring this out. Each time it hung required 6+hours of DISKWARRIOR rebuilding of all mounted disks (external and internal). More than 1.5 terabytes in my case. My first fix was do nothing and let the previews finish generating (it took 72 HOURS), Aperture worked great afterwards until the newest release 1.5.3. I figured out the background preview problem appeared again. Fewer crashes this time but very very SLOW. It also crashed if ITUNEs was used during preview update. After a couple of months of intense monitoring, reading and so on. I figured out how to TURN OFF BOTH preview generating processes. The most important being the main Library preview update. This is the one that starts when you open Aperture and will crash your system if you try and doing anything while it is running in background. Attempting to to cancel this task was very difficult (it keeps restarting over and over...). Turning it OFF is a simple fix but no one stated that way (i e forums).
    The ”preview generating” turning OFF fixes;
    #1. In the Aperture BASIC screen (with no projects highlighted), open the gear icon to the right of the “All Projects” text (top of first column before tool bar). UNCHECK the update previews. Hooray it will not do it anymore and stops crashing. That is all, unless you need to recover about a third of your space by deleting the already generated previews, but first see the PS1 below.

    #2. In the Aperture preferences, UNCHECK the “gernerate previews ...”. Your done and enjoy.
    My system performance was restored.
    P.S.1 After deleting all the previews (recovering 30+gigs of wasted space in my case) Aperture will update your database with NO icon or anyway to let you know it is running in background, unless you go to QUIT. Then it states “updating database” for about 30+ minutes, before it will Quit. Also trying to work while it is “updating database” will likely hang your system and corrupt more files as I experienced several times. Not even the Activity monitor will show it updating. Each time it hung required 6+hours of DISKWARRIOR rebuilding all mounted disks. More than 1.5 terabytes in my case. But I lost no more pictures.

    P.S.2 Regarding crashes with the first version of Aperture, the USB system on my G5 NEVER worked correctly for hard drives, my modem and other data devices, I found it causes its own crashes with any program using USB mounted disks. I would not use the USB in anyway for data drives (it is another long story). The best response I found was to use my 2nd internal SATA drive for the database. I first used firewire 800 with good response and never a problem. The Aperture database should not be put on the Operating System drive. I compared USB 2.0, Fw400, Fw800, Net 1000 and SATA internal drives work with the Aperture database. I found the internal 2nd SATA drive best followed by firewire 800 or firewire 400. USB was worst (causes crashes) followed by the slow net 1000.
  • Phil Oye Level 1 Level 1 (85 points)
    SOLVED

    It turns that something seemingly unrelated solved it. I was having a problem with extraneous Ethernet Adaptors showing up in my Network system preferences, which I couldn't delete.

    Anyway, I found a fix for that here (short answer, unplug my Bluetooth dongle and restart)
    http://discussions.apple.com/thread.jspa?messageID=5034635&

    That in turn fixes my problem with Aperture. Bizarre. Maybe Aperture phones home on startup and since my networking was a bit wonky it couldn't do that so it crashed.
  • jrg_uk Level 3 Level 3 (720 points)
    Maybe Aperture phones home on startup


    It doesn't quite do that, but you may not be far off the mark. What it does do is register itself with Bonjour (actually, the multicast responder). iTunes does something similar, so that would probably have suffered the same fate on startup.
  • Phil Oye Level 1 Level 1 (85 points)
    Interesting... actually I am running into some iTunes problems but no crashes.

    Instead, I can't play any of my purchased music, it prompts me to authenticate, then it aborts with an unknown error (type 50). On the other thread where I found this ethernet ((null)) issue, other people were reporting iTMS issues as well. I was hoping it would fix mine, but it doesn't appear to.

    I'm wondering if it is the same issue, but mine isn't fully resolved. Oh, and I'm having problems with OmniFocus, but I think that is coincidental...
  • Phil Oye Level 1 Level 1 (85 points)
    Turns out that the ethernet interface issue described above was causing my problems with iTunes after all. Read my post over there for my details.
    http://discussions.apple.com/thread.jspa?messageID=5040107&#5040107