10 Replies Latest reply: Jul 31, 2007 4:18 PM by goshack
goshack Level 1 Level 1 (10 points)
As someone who typically returns the iPhone to its dock after calls, etc., the perpetual window-opening of iTunes anytime the iPhone is docked can be bothersome. Yes, I could elect to only dock the phone at night for recharging, but the dock's convenience as a stand, and the ever-readiness of a full charge, would be lost.

Anyone know if the iTunes window-opening upon iPhone-docking can be disabled? Simply leaving the window open and minimized is no help, since then the window will maximize upon iPhone docking.

Thanks in advance for any assistance.

Intel iMac, Mac OS X (10.4.10)
  • 1. Re: Disable iTunes window pop up?
    Robert LaRocca Level 1 Level 1 (85 points)
    You can Turn off automatically sync when your iPhone is connected. This will stop itunes from opening ever time you connect the iPhone to you dock.

    1. Open iTunes
    2. Click on the iPhone icon is the Devices List
    3. Click Summery Tab
    4. Turn off automatically sync when this iPhone is connected (Remove the check mark)

    You will have to manually sync you iphone after this. Hope this helps.
  • 2. Re: Disable iTunes window pop up?
    goshack Level 1 Level 1 (10 points)
    Thanks for the advice, but actually I already have "automatically sync" unchecked, and iTunes still opens up with every dock connection. The iPhone does not automatically sync (I've been doing so manually), but its dock connection still triggers the opening (and/or maximizing) of the iTunes window.

    Is this behavior unique to my system? Should disabling "automatic sync" prevent iTunes from opening up, and it's simply not working for me?
  • 3. Re: Disable iTunes window pop up?
    Robert LaRocca Level 1 Level 1 (85 points)
    Yes seems to be. My iMac running Mac OS X v 10.4.10 does not launch iTunes when auto sync is turned off. Try deleting the iTunes preference file.

    1. Quit iTunes
    2. Delete Home > Library > Preference > com.apple.iTunes.plist
    3. Repair Disk Permissions with Disk Utility
    4. Launch iTunes, and try again.

    If that still does not work, launch terminal and type: sudo periodic daily weekly monthly

    You will be prompted for your password. This will run the built is cron maintenance scripts provided by Apple. Good Luck
  • 4. Re: Disable iTunes window pop up?
    goshack Level 1 Level 1 (10 points)
    Thanks so much for the additional help. Unfortunately, even after going through all your suggested steps (and the old preferences file definitely was deleted; I had to re-set up all my prefs in iTunes and re-set up the iPhone to sync by replacing the old "user" with the new "user"), the behavior on my system is the same. The iTunes window still opens up on every dock connect, even though automatic sync is definitely disabled.

    Thanks, anyway, though. I definitely appreciate your time attempting to help.
  • 5. Re: Disable iTunes window pop up?
    Chas Hulme Level 4 Level 4 (1,130 points)
    This behavior is odd, and definitely should not be. Strange as it might seem, you might try checking prefs in 'Image Capture'. Perhaps it was inadvertently set to open iTunes on camera connect. Beyond that, it's a mystery...
  • 6. Re: Disable iTunes window pop up?
    goshack Level 1 Level 1 (10 points)
    Thanks for adding your suggestion. I just doublechecked the prefs in Image Capture, and it's set, as it should be, to open iPhoto upon camera connection (and luckily, this is working correctly, launching iPhoto upon dock connection if and only if there are photos in the camera roll).

    Further evidence to how resistant my iPhone is to disabling the opening of the iTunes window: a little while ago, I used the iFuntastic method of adding ringtones to my phone, a process that some have said prevents the iPhone from opening iTunes upon dock connection, even when automatic sync is enabled. Well, with my iPhone, the iTunes window still opens up with dock connection even after the iFuntastic-izing. (Note: my window-opening problem pre-dates adding ringtones by weeks, so the problem could not be on account of this hack.)

    As a further piece of information, let me point out that my iPhone is not syncing upon connection (the disable automatic sync is working to that degree), but merely always opening up the iTunes window (or maximizing the window, if it's already open and merely minimized) in the same way that docking my manually managed (not automatically synced) iPod causes the iTunes window to appear -- but of course, in this case, the settings in the iPod management window are checked so that iTunes will open.

    Question: I don't suppose there's a similar "open iTunes when this iPhone is connected" preference anywhere, is there? I mean, in the iPhone management tab, the "automatically sync when this iPhone is connected" option takes the place of the iPod's "automatically open" option.

    Again, thank you both for trying to help, but it looks like I may be stuck closing unwanted iTunes windows throughout the day (there are worse things in life, to be sure).
  • 7. Re: Disable iTunes window pop up?
    GColeman Level 1 Level 1 (0 points)
    Before you give up, check your Activity Monitor for a process called iTunes Helper (with your iPhone undocked). If you find it, select it and click Quit Process.

    Now try docking your iPhone, and see if iTunes launches. If not, you will want to remove iTunes Helper from the Login Items under Accounts in your System Preferences. (This will also mean that iTunes will not automatically launch when you connect and iPod or insert a CD, but this doesn't sound like something that's a problem for you).
  • 8. Re: Disable iTunes window pop up?
    Damon M. Level 4 Level 4 (3,695 points)
    Something else to check, even though you have pulled the ~/library/preferences/com.apple.itunes.plist, is to open the itunes preferences > iphone and check the box to disable auto sync for all iphones.

    Also, just like the ipod, some of the preferences you choose in the summery, info, and music tabs, is stored on the iphone itself and not on the computer.

    So, pulling the plist on the computer will not effect the preferences on the iphone. If the computer is not writing to the iphone preferences file correctly, you might want to think about restoring the iphone. This is quite intrusive to the iphone and you will have to set everything on the iphone back up.

    If you decide to restore the iphone, here is a link to a knowledge base article on the apple website that will help.
    http://docs.info.apple.com/article.html?artnum=305744
  • 9. Re: Disable iTunes window pop up?
    goshack Level 1 Level 1 (10 points)
    Thanks for the suggestion, but Activity Monitor does not list iTunes Helper, either before or after docking. I actually checked Activity Monitor for this once before, with the same result.

    I appreciate your help.
  • 10. Re: Disable iTunes window pop up?
    goshack Level 1 Level 1 (10 points)
    Thanks. I actually already found and disabled the "disable auto sync for all iPhones" preference early in my attempts to solve the problem, to no avail. And while I didn't have your insight into why pulling the plist on the Mac would not affect the iPhone's prefs, I did try restoring the iPhone since I last posted here. As you say, I had to set everything back up, but found that my iTunes window opening behavior remained unchanged. Thanks so much, though, for trying to help.