10 Replies Latest reply: Apr 13, 2008 11:04 PM by Stephen Kay
mrpetey Level 4 Level 4 (1,240 points)
So here is my problem

I have a dual-G4 (1.25) mdd and a new(er) iMac G5. I want to transfer my info from the G4 to the G5. Easy enough right - just put the G4 into target disk mode and transfer it over.

Well, I reboot the G4, hold down the 'T' key - the Mac boots, fans kick into turbo mode and after a few seconds the G4 just shutdown. So, I boot the G4 into Open Firmware and reset nvram/reset all - still nothing.

It does have the org boot disk - an older maxtor 160GB. I am using as my main drives two Hitachi 250GB that are mirrored. the old maxtor is just a scratch disk for my many media apps.

has anyone else seen this issue/problem? any work arounds or fixes? I would really like to just transfer the data over and not have to start from ground zero as there is years of info on the old drives.

TIA
-Peter

AlBook 12 / Dual2.0G5 / iMac 20" IntelDuoCore, Mac OS X (10.4.9)
  • 1. Re: Instead of target disk mode - just shuts off
    pm7300 Level 1 Level 1 (80 points)
    Hi Has your Mac other PCI adapter (eg combo usb 2 + fw)?
    If you go to system preferences then startup disk and choose target mode from there does anything change? Does your system profiler "see" FW ports?
    Rob
  • 2. Re: Instead of target disk mode - just shuts off
    mrpetey Level 4 Level 4 (1,240 points)
    Even if I go to the Startup Disk control panel and select Target Disk Mode, the Mac will reboot - chime - fans fire on full - shutdown. Nothing more or nothing less.

    Does anyone know if there is something concering the boot drive? I am not using the org boot disk or the org boot ATA bus. As stated I have two 250GB drives I am using as the primaries now.

    Really POs me as this is the first Mac in 20 years that has given me grief since day one!
  • 3. Re: Instead of target disk mode Mac just shuts off
    Niel Level 10 Level 10 (242,130 points)
    See this article for information.

    (23303)
  • 4. Re: Instead of target disk mode - just shuts off
    Thomas Bryant Level 6 Level 6 (13,865 points)
    Hello! As Neil's link states FTDM will only work with the master device on the onboard controller. It will not work with a slave nor with 3rd party controllers. Tom

    Message was edited by: Thomas Bryant
  • 5. Re: Instead of target disk mode - just shuts off
    mrpetey Level 4 Level 4 (1,240 points)
    Thank You! Was just the ticket I needed.
  • 6. Re: Instead of target disk mode - just shuts off
    Hassi Norlen3 Level 1 Level 1 (40 points)
    Hi.

    I just ran into the same problem. My drive seems to be connected to ATA 4, not 0. Is there anything I can do to reassign the drive to ATA 0?

    Thanks,

    Hassi
  • 7. Re: Instead of target disk mode - just shuts off
    kaset Level 1 Level 1 (0 points)
    I have the same problem with my G4 power mac. I want to transfer its files to my new MacBook Pro, but it won't enter target disk mode.

    I have a SCSI ultra 2 wide (or something like that) hard drive. It looks like I have an internal ATA 0 but only the DVD-RAM drive, and ZIP 100 drive are listed on it. Looks like the hard drive is on the SCSI Bus 1. Is there any way the target disk mode could work for me, or does the SCSI set up preclude me from using it....

    thanks a lot!
  • 8. Re: Instead of target disk mode - just shuts off
    Thomas Bryant Level 6 Level 6 (13,865 points)
    Hi! You'll always get more help by posting your own question but to answer your question, no scsi won't work with FWTDM. The only way to do that would probably be to install an ide drive in the Mac and then clone the scsi drive to it and then FWTDM would work. I'm not sure what all you are trying to move but I usually just export my picts, bookmarks, and address book and start fresh with everything else. Tom
  • 9. Re: Instead of target disk mode - just shuts off
    Jeff Hanlon Level 1 Level 1 (5 points)
    I ran into this problem today with a G4 (FW 800) machine. I removed a 3rd party PCI video card and that didn't work. Then I looked at the ATA cable and tried plugging in the other (secondary) connector into the seagate OEM 80GB drive. That didn't work either. I read something in the service manual about being careful not to swap the ATA 66 and ATA 100 cables, but that didn't seem to make a difference either.

    I did notice that the drive was not showing up in ASP or Disk Utility as Disk0, which according the the apple kbb article (42737) is required for FTDM to work. It was showing up as Disk1

    Luckily I had another G4 (FW 800) lying around that I could compare with and discovered that it had a jumper on the HD in cable select mode. I looked at my G4 that wasn't FTDM booting and realized that the hard drive didn't have ANY jumpers on it. Doh! So I grabbed a spare jumper and put it on the HD (to match my other G4) and then it worked perfectly! Without the jumper it was not in the correct mode to make it Disk0.

    Here is the link to the seagate ATA jumper settings:
    http://www.seagate.com/images/support/en/us/u5family1.gif

    Message was edited by: Jeff Hanlon
  • 10. Re: Instead of target disk mode - just shuts off
    Stephen Kay Level 1 Level 1 (95 points)
    I have been having the same problem with a G4 MDD, OS X 10.4.11, with a Seagate Barracuda drive, and I have tried the jumper in the master position, the slave position, the cable select position, nothing works. System Profiler tells me that the drive is an ATA and is on the first ATA bus listed, and is Device 0. I don't know what else I can do. I made sure that Open Firmware Password is not active, as well. I disconnected everything internal (DVD, CDR) so that only the hard drive is connected, it's at location 0, still the computer just shuts off when telling it to go to TDM.