1 2 3 Previous Next 30 Replies Latest reply: Sep 22, 2007 1:37 AM by Weiq Go to original post
  • 15. Re: FAT32 Size Limitations?
    oldsoul_42 Level 1 Level 1 (0 points)
    Just to add my twopenneth, I seem to have exactly the same problem. I have:

    Powerbook G4, OS X 10.4.10, Attached via USB2 to Western Digital MyBook Essential 500GB. This exhibited the Error -36 problem straight out of the box. (I have 3 of these, bought at the samer time. They all do exactly the same thing - brand new, out the box).

    Same PB G4, Attached by FW800 to WD MyBook Pro 500GB, Just started doing this today. (I have 3 of these too, and I daren't even look at the other two).

    The Essential has had just about everything done to it - Partitioned at all levels as FAT32; Partitioned as Mac OS Extended (Journaled and not); Sub-partitioned into smaller units, you name it. Nothing makes any difference. Drive hits a wall. Not necessarily at 128GB, and not with any particular file (although a lot of my files are similar - DV, and Photoshop/RAW images), but there's a definite wall in there somewhere. After which, I get error -36 a few times, followed by Finder Hangs if I'm persistent.

    I'm going to do a "fill with Zeros" reformat tonight (it estimates 6 hours). We'll see what happens.

    FWIW, I thought it might be a 10.4.10 thing, seeing as I'm on my 11th outboard, and this is the first time I've seen anything like this. BIG coincidence after the recent 10.4.10 update (with reported issues on the USB interface) but we've attached the Essential drive to my Partner's G4 (10.4.9) and it fails there too. Could be something, could be nothing.

    The weird thing is the MyBook Pro's - I've had them all for a number of months, and they have had varying amounts of data on them, but since I bought the Essential's they've started failing too. By comparison, I have some older Maxtors, and they are 250GB, 300GB and 500GB - all running up to the max and been healthy for 2 years plus.

    Like everyone here, I'm scouring every source for a solution, and new "sightings" are popping up daily, so I'll post what I find.

    Keep posting, folks.

    P.S. Sorry for the long post, but I hope I've used enough description here that people searching for this specific problem will find it more easily - I've read more than my share of unrelated iTunes and Windows SMB posts over the past couple of days.
  • 16. Re: FAT32 Size Limitations?
    tantin Level 1 Level 1 (0 points)
    @ oldsoul_42:

    i have the exact same problem with my 500GB essential edition. tried everything (every partition scheme/ format type) - also the overwriting with zeros. same problem again. so don't bother to spend 6 hours waiting - . have you tried contacting WD directly? what about the firewire edition -same problem there too??
  • 17. Re: FAT32 Size Limitations?
    oldsoul_42 Level 1 Level 1 (0 points)
    @ tantin:

    Thanks for the head's up on the Zeroing, but I thought I'd be thorough and test the Zero theory in a controlled env. for a second time, just to prove the validity (and so we both know it's not us!!).

    12 hours later (yes, twelve, plus 4 more for the data transfer), you will be pleased (?) to know that the drive still fails with Error -36 at 127.46GB even after setting the drive to zeroes and partitioning as Mac across the board (default Partition scheme is Master boot Record, even if you then partition/erase as Mac Extended - so I also tried setting this to Apple Partition Map).

    Meanwhile, WD are apparently "currently experiencing higher than average email volume" (NSS!), and will be getting back to me.

    Oh, and the MyBook Pro's (running FW800) are all still going strong (thankfully) at 300GB+ of data each (with various forms of partition map and base format). The Write Error I got yesterday was from an Essential.
  • 18. Re: FAT32 Size Limitations?
    Malcolm Rayfield Level 7 Level 7 (28,070 points)
    What does it show for capacity if you select the drive and use Get Info (Command-I)? What total capacity does Disk Utility show? If they show about 128 GB, it means the external enclosure has an old chip-set that does not support large drives.
  • 19. Re: FAT32 Size Limitations?
    tantin Level 1 Level 1 (0 points)
    it shows 465GB (500 GiB, respectively). but only writes up to 128GB (137 GiB).
  • 20. Re: FAT32 Size Limitations?
    Peter Witham Level 1 Level 1 (20 points)
    I brought one of these drives yesterday, the usb 2 only version and am having the same problem with the error code -36 when hitting 128(ish)gb of files. It is driving me nuts since I have other My Book drives that are 320gb and have never had this problem with any partition type.

    I do not want to have to use a Windows machine just to add files to the drive, that is beyond acceptable to an end user. Can anyone confirm that partitioning the drive to partitions below 120gb works just fine? I hate to have to work with it that way, but if it works then that will have to do I guess.

    Regards,
    Peter Witham
  • 21. Re: FAT32 Size Limitations?
    Peter Witham Level 1 Level 1 (20 points)
    To follow up on this after hours of copying files using a Windows machine this time it still fails around the 133gb mark. Clearly at this point it does not appear to be OS or partition format specific based on the fact that I've tried lots of partition types on both platforms.
  • 22. Re: FAT32 Size Limitations?
    tantin Level 1 Level 1 (0 points)
    I contacted WD directly over the phone, and they said, it's a hardware problem with the controller of the external drive, occuring on some models, but not on the entire 500Gb essential series... . he told me to get a new one, as there's no software solution to that. **** you WD!! >:(
  • 23. Re: FAT32 Size Limitations?
    osker Level 1 Level 1 (0 points)
    I just bought a 500 gb Western Digital MyBook Premium and I got this note saying something like "Mac OSX 10.2.8 is not compatible with FAT32 partitions greater than 128 GB" .. "Please refer to Knoledge Base Answer ID 287 on support.wdc.com"

    I testing right now to see if I can put 170 GB of files on my drive. Donno yet if it will work...
  • 24. Re: FAT32 Size Limitations?
    osker Level 1 Level 1 (0 points)
    Ok I have now tried and managed to copy 170GB to my drive. No problems. I have a "Western Digital MyBook WDG1C5000E 500GB 7200RPM Premium 3.5" USB 2.0/Firewire" and a MacBook Core Duo.
  • 25. Re: FAT32 Size Limitations?
    Pe Bakk Level 2 Level 2 (440 points)
    Wade Peeler wrote:
    According to this Wikipedia article, though the theoretical max FAT32 volume size is 8TB, Windows 95/98 could only create up to 127.53GB volumes, while Windows 2000/XP can only create up to 32GB volumes, without third-party software. One could surmise from this that OS X also places a limitation on FAT32 volumes of around 128GB, though I don't think that's true.


    You'd be right, it's not true. I can use my iBook running 10.4.10 to copy my full 250GB external to my empty 320GB external hard drive with a single, simple drag and drop. The only real limitation that you need to worry about with FAT32 is the that any individual file can not exceed 4GB (technically 1 KB less than 4 GB).
  • 26. Re: FAT32 Size Limitations?
    I-Bought-a-Mac Level 1 Level 1 (0 points)
    I just bought a Mac and I am in full transition/compatibility mode with what you guys call derogatively "PC". So here my 2 cents of field experience on this subject.
    Cheers, IBM (aka I - finally - bought a Mac)

    THEORY:
    the most concise way to describe the FAT32 volume limit follows:
    credits to cait-sith on http://forums.macrumors.com/archive/index.php/t-194736.html

    FAT32 = 2**32 - 1 sectors * 512 bytes / sector = 2 TB MAXIMUM VOLUME SIZE
    but Windows 98 can format up to 127.53 GB while Windows 2000/XP up to 32GB

    PRACTICE:
    I reformatted a LACIE 500GB from NTFS to FAT32 and I am happily using it on both Mac 10.4 and Windows XP

    NOTE#1: I had to use Maxblast to format it as Powerquest 8.01 was limiting the size to less than 200GB...why Symantec ?

    NOTE#2: before reformatting from NTFS I tried MacFuse+NTFS-3G
    see http://www.daniel-johnson.org/
    but with very unstable results (why Apple you don't release support for NTFS ?)

    NOTE#3: the aim for a self-contained 500GB disk to be used on both Mac/PC was for iTunes library AND songs/video portability.
    There I stumbled in .ITL and .XML incompatibilities across the 2 platforms partially solved as in
    http://lifehacker.com/software/itunes/geek-to-live--how-to-move-an-itunes-librar y-from-a-pc-to-mac-and-back-242468.php

    well... enough for a novice
  • 27. Re: FAT32 Size Limitations?
    oldsoul_42 Level 1 Level 1 (0 points)
    In the case of the WD MyBook Essential 500GBs, I think this is a spot-case of a genuine fault, and the FAT32 limit is a red-herring (although the FAT32 limits ARE real).

    For my part in the saga, I got an automated response from WD on after submitting an online support request, citing "an unusually high volume of cases". After waiting a week for a response from WD on the topic, I got a lame email saying if I still had a problem, drop them a line.

    Needless to say, the 3 drives I bought have been returned as faulty. Thankfully, Dabs (in the uk) have just refunded the full amount with no quibbles.

    As for FAT32 and Macs - if you're going to work with big files like video projects (standard DV is 12GB an hour), the considered wisdom is you'd better pick another format (on an outboard used for video data, Mac Extended will be fine - Journaled is more for OS drives). For reference - Even iMovie projects - which aren't really single files, they just look that way - have problems copying to/from FAT32 drives once they get above a certain size.

    Of course, if you're not going to touch a PC with the drive, then there's no issue of format anyway.
  • 28. Re: FAT32 Size Limitations? Using XP + mac panther
    chibafl Level 1 Level 1 (0 points)
    Having just spend a ton of time dealing with issues the Western Digital-My Book Pro 500GB External Hard Drive, I figured I would add my experience. Any advice would be appreciated, as I took a lot from this thread.
    ps- I am using a iMac g5 w/ panther OSX 10.3.9 with FCP 4.5 HD.

    The WD My Book Pro is advertised as being both Mac and PC compatible. I wanted to use this for my iMac as storage and scratch disks for Final Cut Pro(FCP). My girl friend wanted to use the external as storage for Windows XP.

    So using the FAT32 format is really the only option to be able to use both. With my mac, there were originally no problems transferring information until the process would stop with an error code -0036 or -36. At this point all the files would disappear that I transferred. Then plugging it into XP, all the files were still there. So I plugged it back into mac and the files would be there but were corrupted (some of which did not look corrupted but did not work).

    I found this thread and did the research - not transferring +4GB of files at one time, but also tried to create a larger drive than 32GB with FAT32. I first copied the external hd startup files to my xp pc then partitioned with partition magic 8.0. I created a few drives with FAT32. When trying to do this XP would not let me create a drive that was +95GB. So I made them about 90GB, put the external files back on, then tried transferring files under 4GB files/folders on my mac. The files would work until I got the -36 error code again, which then blanked out my external hd. After unplugging the external and plugging in again, the files were all corrupted (these files were mostly FCP scratch disk files).

    Using the Mac disk utility I created partitions and formatted the mac side with OSX extended (journaled) and left the rest as free space. In XP partition magic, the entire drive was seen as Unallocated Space.

    So with Partition Magic on my XP I created 3 drives with FAT32, each about 30GB in size for mac, and the 4th drive as NTFS for XP. The restriction is 4 partitions per Hard Drive, but I was told it is not good to partition a hd too many times anyway.

    With this setup and abiding by the 4GB transfer limit on my mac, I tested the drive under many conditions. Putting FCP files on, unplugging, using on XP, restarting mac - plugging the external back in... and all the files were good. From time to time I would have a problem transferring a file from the mac, error code -36 and/or file name was too long, and again the entire external hd folder would blank out. Unplugging the external and then connecting would then refresh and show my files, but the important thing was the files were still good. But once this error occurred, I needed to restart the external hd.

    Sometimes all the partitioned drives didn't show up on my mac, so i would restart the external again and the drives would show up on my desktop. The NTFS drive also shows up on mac - but you cannot access this, obviously.

    So this was a huge pain but to use both XP and Mac panther, this is what I had to do. At this point everything works, I reformatted my mac and reinstalled all the programs, including FCP, and all the files from the external hd are still good. It’s lame to have such a restriction on disk space when using both mac and PC - as I am only able to use 90 GB of space, I could use 120 but then the rest of the space will be unusable. If I was using this drive just for mac I would format it with Disk Utility and make it all mac OSX extended (journaled).

    Please let me know if there is a better way to do this.
  • 29. Re: FAT32 Size Limitations?
    genoko Level 1 Level 1 (0 points)
    I also have strange problems with Mac OS X, MS-FAT32 and a 500 GB hard disk:
    In short: Copying files from my Mac to that hard disk destroys the disk's directory!
    The details: The disk is from Seagate (not Western Digital!) and is installed into a standalone media player to be connected to TV sets. It must be formated with FAT32 and the player will only find the first partition. It uses USB-2.0 to be connected to a computer to be filled with media files, because it can not record but just replay.
    Writing files and creating directories using MS-Windows XP works.
    But when I create directories using the Mac and copy some files one after another to the disk, some files disapear and sometimes reapear in one or even multiple directories! No error message appears!
    Conclusion: The Mac OS X destroys the MS-FAT32 directory structure. After moving files to the Mac's trashcan from that disk, the Finder even crashes when emptying the trashcan...
    There are less than 128 GB data on that disk and no file is larger than 4 GB (of course).

    I strongly hope that someone at Apple reads this and is able to help us...

    PS: That is one reason why I like ISO, clearly designed and completely documented standards very much and why I hate the computer industry...