11 Replies Latest reply: Dec 3, 2007 9:17 PM by Sweetsu
Xandis Level 1 (0 points)
This appeared, possibly due to the update, perhaps not.

After buying my iPhone I went on a road trip and took severa hundered pictures using my iPhone, and they turned out great!

About a week later, which is about two days ago, I turned my camera on on the iPhone and my camera appears to be disabled.

The screen is black and the camera button doesn't work to take a picture. If I rotate the camera, the button icon rotates, but thats about all I can do.

I really hope I accidentally disabled the camera, somehow, and the iPhone is ok. I really love it (WTG Apple!) and I hope my iPhone isn't broken

Any ideas before I try the Restore in iTunes?

Dell XPS, Choose
  • WS6 Level 2 (190 points)
    Have you tried a reset? Top and bottom button for about 10 seconds. This seem to help with a lot of issues. If not you will need to preform a restore.
  • Janet May Level 1 (0 points)
    I've had the same problem, and only after the update. Which also errored my phone and I had to restore it.

    I've reset the phone and it worked for one photo. I reset it again and took several photos. 2 days later, the camera is disabled again and have reset it numerous times and still nothing.

    Any suggestions before I visit the Apple store or restore again?
  • WS6 Level 2 (190 points)
    Sounds like you need to perform a restore. From your thread you have done multiply resets not restores right.
  • Janet May Level 1 (0 points)
    Just did a restore and still nothing. Looks like I'll have to take the phone in. Thanks for helping!!
  • Xandis Level 1 (0 points)
    Wow, thanks for your replies.

    I have tried reset a few times also, and am now in the midst of my 1st Restore. Was hoping it would help, but from what I'm reading here I won't keep my hopes up.

    It's a strange state the camera has got in, when you go to camera, you still see the shutter open, but just to a black screen, and the photo button is disabled, so the iPhone software must know it's not getting anything from the hardware.

    Update: the Restore didn't work, though it did restore it to version 1.01, the version that I had the issue with afterwards, and not 1.00. Guess I will be heading to the Apple store tomorrow also.

    Thanks for your help!

    Message was edited by: Xandis
  • Brian Brueck Level 1 (15 points)
    I am now having this same issue. What were the results when you took the iPhone back to Apple? Is there a DIY fix or did Apple have to fix/replace the phone?

    An update would be greatly appreciated. Hope it all worked out okay, I know it's frustrating...

    Message was edited by: Brian Brueck
  • Janet May Level 1 (0 points)
    I have no clue what went wrong, Apple just fixed the phone and sent it back to me. I wish there was a DIY fix. I'm just glad they fixed it so quickly.

    Apple was really great about returning the temp phone they supplied when I dropped off my phone. They provided everything needed to do the return, even down to the packaging tape.

    Hope this helps!
  • giligoulu Level 1 (0 points)
    Man, my iphone's camera is in the same state as what you guys have described. Called apple support last night. Did the hard reset like he asked, no luck. He then said nothing can be done remotely and asked me to bring it in. Since I'm from Ontario, I have to drive across the border to an apple store to do a refund/exchange. If anyone knows a fix that can be done in the iphone's system files through ibrickr, some pointers would be greatly appreciated.

    Message was edited by: giligoulu

    Message was edited by: giligoulu
  • Gilles Baulard Level 1 (0 points)
    Same problem on Mine and I'm even further (Other side of the pond) therefore very difficult to bring it back.

    I really would like why thiscamera doesn't work...

  • wwsd3 Level 1 (0 points)
    my camera and photos both crash now as soon as i open them. i tried several hard resets, no luck.

    i tried doing a restore, and it fixed the problem for about an hour or 2, but we're back to square one again.

    i'll bring it in to an apple store tomorrow (luckily there's one just down the street) and let you all know what they say
  • Sweetsu Level 1 (0 points)
    After the most recent update (which ended up with having to restore the phone) the camera didn't work anymore. If I touch the icon (same thing with photo icon too) it goes to the camera but then immediately returns to the home screen. I took it to the Apple store today and they said it was a hardware issue and gave me a new iPhone. In the store the camera worked on the new phone Tonight I synced all my info onto the new phone and afterwards, no camera again - now what?