0 Replies Latest reply: Aug 7, 2007 6:37 PM by KevCheng
KevCheng Level 1 Level 1 (0 points)
I do a bit of photo work with Aperture and have came up with what I thought was a pretty cool solution for storage. An Internal + External RAID 0+1.

4 Identical Drives, 2 inside the Mac Pro, 2 sitting outside in a Mercury Elite Pro Dual Drive enclosure set up as a RAID Stripe. The two internal drives are also set up as a striped set. And then I've managed to use Disk Utility to set those two striped sets to mirror.

It worked for months, until this week. When the Pro Application Support 4.0.1 update was done, my Aperture would launch and halt. I've replaced the Framework with an older version and now Aperture launches but only when I point it to an older library on another internal drive.

For a day or two there, the RAID still mounted and I was able to read from it, but not write to it, until yesterday, when it completely disappeared. When I try to get Disk Utility to repair any of the disks, an error message would return "Can't open /dev/rdisk3:resource busy. Error: The underlying tast reported failure on exit."

I've moved the external drives to another computer and have received the same error.

My guess is that the RAID somehow got corrupted during my trying to fix aperture, that some critical data on how things are organized on the striped sets got corrupted and resulted in these disks becoming unmountable.

Would anyone have any idea how I might be able to recover data from these disks? or some way to mount them to recover the data? I'm sure the data's there, it's probably just some corruption that's preventing the drives from being mounted. There's 15,000 photos I'd like to get back, any advice is much appreciated.

Los Angeles.

Mac Pro Quad 2.66Ghz Xeon, Mac OS X (10.4.10)