Skip navigation
This discussion is archived

My Mac doesn't recognize my Ipod

1759 Views 7 Replies Latest reply: Oct 20, 2007 9:52 AM by StudioGrafix RSS
willbrackman Calculating status...
Currently Being Moderated
Aug 8, 2007 11:41 PM
I recently bought a 30gb Ipod video. Plugged it into my Imac and everything worked great. Then Itunes upgraded to version 7.2 and my Ipod would no longer show up in Itunes or Finder, nor would the Ipod recharge from the USB port.

Called the Ipod vendor and got things working again by starting over.

Now, my computer just upgraded Itunes again (7.3.2 ?) and, once again, my Ipod doesn't show up in Finder or Itunes. Doesn't charge either.

What's happening here? I've reset, restarted, rebooted, reinstalled, and re-everything else that I can think of.

Help please!
imac, Mac OS X (10.4.10)
  • PhillyPhan Level 5 Level 5 (5,440 points)
    Currently Being Moderated
    Aug 9, 2007 2:23 PM (in response to willbrackman)
    Doesn't charge either.

    That's key information. Charging will take place even if you don't have iTunes loaded on the computer. Can you try with a different cable and/or USB port?
    1.25G eMac, Mac OS X (10.4.10), 10MP, iPod Gen-5
  • Ed Parigian Calculating status...
    Currently Being Moderated
    Oct 8, 2007 12:44 PM (in response to PhillyPhan)
    I am having the same problem, but with a twist. My Mac Powerbook G4 recognizes, charges and syncs my 4gb Nano (not the new model), but won't recognize, charge or sync my 30gb 5th Gen Ipod. Go figure. I haven't synced it for a few months, so it might be the iTunes update issue going on here. Anybody have these issues AND solutions? thanks
    12" G4 Powerbook 1.5gHZ, Mac OS X (10.4.3), iPod Video 30gb
  • Robert Leigh Calculating status...
    Currently Being Moderated
    Oct 10, 2007 5:23 PM (in response to Ed Parigian)
    Having same problem, ever since updated to iTunes 7.4.2 my 5th gen iPod has not been recognized, it charges but does not show as a drive, in iTunes, nor in my USB device tree, have tried the 5 R's, have reinstalled OS 10.3.9, reinstalled iTunes, ran all the updates and still does not show, have tried a different USB cable and different USB ports all to no avail. Appears others are having issues as well with there 5th gen iPods, are the 5th gen now obsolete? Other than not connecting to my eMac my iPod works fine, I just can not connect. Battery charges fine both by USB to eMac and by other sources (wall plug and car charger). This is very frustrating and making me loose my love of the easy to use Mac.
    eMac, 5th Gen 60 gig iPod
  • jettyboy Calculating status...
    Currently Being Moderated
    Oct 15, 2007 7:42 AM (in response to Robert Leigh)
    Count me in also. All the same issues, although I'm running 10.4.10. Have done the "R's", in fact have done them twice just to make sure I didn't miss something. I'm thinking it's the iTunes update. Hope some one comes up with a fix soon.
    G5 2.3 4G SuperDrive 15PB 1.33 GHz SuperDrive, Mac OS X (10.4.10)
  • benjokazooie Calculating status...
    Currently Being Moderated
    Oct 18, 2007 1:42 PM (in response to willbrackman)
    so eased im not the only one having this problem. no offence. i was having this on my emac and ive just bought a brand new macbook and its still the same. i plug it in and nothing happens. bizarrely however when i turn my emac off at night and connect my ipod again in the morning it picks it up, but then if i disconnect it again it wont, annoying as ****. the census f opinion seems to be hat its an itunes problem, does anyoe know whether or not theres a new itunes out soon. PLEASE SOMEBODY FROM APPLE HELP US
    emac - macbook, Mac OS X (10.4.10)
  • benjokazooie Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 19, 2007 4:27 AM (in response to benjokazooie)
    seriuously can anyone help. windows users have had the same problem and apple have put a troubleshooting guide up telling them how to solve it why isnt there one for mac users.
    emac - macbook, Mac OS X (10.4.10)
  • StudioGrafix Calculating status...
    Currently Being Moderated
    Oct 20, 2007 9:52 AM (in response to benjokazooie)
    The mac guide doesn't help either. http://docs.info.apple.com/article.html?artnum=60950 I think there's something in the code to force you to go to Tiger and/or upgrade your iPod. The iPod works on EVERY computer except the one running 10.3.9 and iTunes 7.4.2

    I'm running a G5 desktop with 10.3.9 and all was fine with my 60GB iPod Photo until I upgraded iTunes to 7.4.2. It was connected and on my desktop. After I updated iTunes it was removed from my desktop and I could not connect the iPod via firewire anymore. I also cannot connect it via USB with a regular USB cable ONLY with my dock cable which is USB and powered from a wall outlet. I could NOT use my firewire to connect the iPod to the G5 anymore but it works on my Intel MacBook and my other G4 desktop both running 10.4.10 in addition to countless customer sites I visit. I know it has to be a problem with 10.3.9 and iTunes 7.4.2.

    I know what your going to say, upgrade my G5 to 10.4.10, problem with that is another topic, but I cannot install Tiger on the drive without getting an error that cancels the install and I cannot get Tiger to boot off of my secondary internal HD where it is installed. I will post this as well in another area.

    I think that the iTunes installer installed a new driver and/or firmware on my G5 that makes mounting my iPod not work. When I have the iPod connected via firewire, it does not mount on the desktop but in iTunes I get the following error: "An iPod has been detected, but it could not be identified properly. Please disconnect and reconnect the iPod, then try again."

    Any ideas? Thanks!
    Dual 2GHz PowerPC G5 Desktop - 1.5 GB SDRAM, Mac OS X (10.3.9), Also G4 Desktop (10.4.10), G4 Laptop (10.4.10), Intel MacBook (10.4.10)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.