Previous 1 2 3 Next 35 Replies Latest reply: Feb 10, 2008 9:24 PM by jlbame Go to original post
  • Patfitz Level 1 Level 1 (0 points)
    I was able to get this to work.
    What I was trying to do was move my iphoto library to users/shared so my wife and I could both work off the same library. I moved it to shared and set the access permissions for wife and my account to read/write. I then deleted the iphoto libraries out of the home/pictures of both our accounts. After starting iPhoto in both user accounts I redirected the library to the shared folder..library. The above error dialog appeared after a few seconds of use. I looked at the library permissions and besides the two if us there are 2 other permission users, Everyone and wheel (anyone know what wheel is?). Those had permissions set to read only. After I set the everyone permissions to read/write the error went away. This is a temporary solution in my book as I want to protect the kids from deleting photos.
    Hope this helps others ....
  • Patfitz Level 1 Level 1 (0 points)
    Well I was able to get more or less what I wanted. For some reason the iPhoto library was part of the wheel group. I started from scratch again, creating a new iPhoto Library in shared area. I then changed the group (chgrp admin *) for the folder and its contents. As my wife and I are both in the admin group this appeared to work fine. The permissions for everyone else is read only.

    Hope this helps...
  • Bart Van Bragt Level 2 Level 2 (230 points)
    I can concur. Haven't been able to play with iPhoto much in the last couple of weeks but this is the same solution that I've ended up with. By default files are owned by the users that creates them, because of that other users can't change those files which doesn't work in the iPhoto case.

    In our case we have a group on the samba server that we both share, I've done 'chgrp' on all of them and set the 'setguid' bit on all files and directories in that directory (chmod -R g+s .) IIRC that fixed the problem but haven't had time to really test this solution.

    BTW the 'wheel' group contains users that are allowed to use 'su' and 'sudo' on BSD systems.
  • damonallison Level 1 Level 1 (0 points)
    Using advice on this thread, I was able to avoid the iPhoto error - "An error occurred while trying to save your photo library".

    My iPhoto library is on a Western Digital "MyBook" external usb drive connected to a mac mini. It was formatted as FAT. I backed up my iPhoto library, reformatted the drive as Mac OS Extended (Journaled) and copied my library back onto the new partition. Reopened iPhoto and have not received the error since (1 month).

    This is probably unrelated, but the drive seems to be running a lot quieter than before. Perhaps the previous partition was heavily fragmented and caused a lot of disk movement.

    I just thought I'd share this with others having this problem. This error was really frustrating. It doesn't tell the user much, iPhoto continues to function, you have no idea if data is being lost/corrupted, its periodic, and so on.

    Best of luck to others having this error.
  • Axelfoo Level 1 Level 1 (5 points)
    I get the same error! My setup is a new iMac running Leopard. My iPhoto library is on the local drive, in the shared folder - the library is shared between two admin users. This used to be running fine until I performed a "repair permission".

    It seems the ACL list I set up worked great, but then a repair permission, seems to undo something and now renders iPhoto unusable.

    I think what we need is simpler ACL control - at least regarding the shared folder or drives.

    Apple, what is the proper way to share an iPhoto library? Sheesh.
    At the moment this "terrific" machine/OS is not very useful to me without iPhoto capability. What's the fix?

    Message was edited by: Axelfoo
  • jlbame Level 1 Level 1 (0 points)
    Hello everybody,
    I believe I solved this issue, at least on my own mac, thanks to the information you provided and to iPhoto Library Manager.
    I have a very similar setup as described : in Tiger, a photo library located in the Shared folder, so that several accounts from the same Mac can access it. The library was not born in Shared, though, it was moved there from my personal account. It lived a long time like that, with photos added from at least 3 accounts.
    Permissions-wise, you can guess : this was a mess that even the iPLM permissions setting options could not fix. I had tried many times to set Read&Write for Owner/Groups/Others from the Options command in iPLM from the 3 accounts, but always got a long list of files that did not belong to the then-current account and so could not be reset properly.

    After an Erase & Install Leopard, I got a kernel panic within a week, and then the infamous iPhoto message (in French, but the meaning was the same : no more iPhoto database updates!).

    I tried rebuilding the database within iPhoto using alt-cmd launching, with no luck.

    Then on advice from Adam Engst's iPhoto 08 Visual Quickstart Guide (p 173), I took a big breath and rebuilt the iPhoto database from scratch. Several hours later, I had brand new package in the Shared folder (minus 2Go out of 11) , which loaded nicely without the usual error message, so back to the business of importing photos!
    It was then easy to reset permissions as described above since while rebuilding, iPLM sets the current account as the Owner of all files -- I did not go into trying to prevent the children's account from erasing photos since I consider the garbage can mechanism to provide enough protection.

    Only thing I noticed missing are smart albums, which apparently don't get through. I do not know how to transfert them except by writing down the defining rules beforehand, and recreating them. Any suggestions guys?

    Keywords seem OK, albums too.

    Hope this helps.
Previous 1 2 3 Next