Previous 1 2 3 4 Next 48 Replies Latest reply: Oct 22, 2007 5:05 PM by Louis J. Sheehan, Esquire
Paul53 Level 1 Level 1 (0 points)
Hi all
Just received the new usb keyboard. No software comes with this and it states you have to download Apple Keyboard Software from apple.com/support/downloads. Well I cant find this software which makes the fn keys unusable. Anyone have a link to this software?
Excellent keyboard by the way, love the usb ports at the side.

imac 24, Mac OS X (10.4.10)
  • Dah•veed Level 7 Level 7 (32,045 points)
    Keyboard Software Update 1.1
    Install this software to use your aluminum Apple Keyboard and take advantage of the special features.
  • ibloch Level 1 Level 1 (0 points)
    Hi,

    I have actually installed the Software Update on a MacPro running OS X 10.4.10, but still the new keyboard is not recognized an the new function keys don't work....

    Seems that something is still not in order...

    Immanuel
  • Dah•veed Level 7 Level 7 (32,045 points)
    Have you checked in System Preferences/Keyboard & Mouse to see if there is something you need to do to the configuration?
  • Paul53 Level 1 Level 1 (0 points)
    Thanks for the url. The download worked perfectly
  • arkitect Level 1 Level 1 (0 points)
    Well now the link to the keyboard update 1.1 gets me this:

    *Looking for something at Apple.com?*

    The page you tried was not found. You may have used an outdated link or may have typed the address (URL) incorrectly. You might find what you’re looking for in one of these areas:

    So I am unable to install any update and that leaves my keyboard crippled! None of the function keys work…

    Any ideas? Thanks!
  • Will : Hi ! Level 5 Level 5 (4,305 points)
    The link still works for me. And here's another link :

    Keyboard Software Update 1.1
  • Matt Hoult Level 1 Level 1 (80 points)
    I downloaded the software around 4PM GMT and had an issue where some of the keys still wouldn't function on my eMac. When I tried it on my MacBook however everything was fine. I am sure the download was around 35MB then.

    Later I went to download the file on another machine and the links were broken as you described. No sign of it anywhere in the downloads list.

    Now when I check it's there, as it originally was. The only difference is that the download now appears to be 32.1MB in size... I wonder if a bug was fixed? I guess I will have to take a look at the new download on the eMac tomorrow.
  • philopaemon Level 1 Level 1 (5 points)
    Using Power PC iMac, but didn't find post for new aluminum keyboard in that forum.

    Received new aluminum keyboard today. Using with iMac G5,Power PC, no iSight. Downloaded and installed keyboard software update 1.1. Everything works as expected, except F3 and F4 keys. Expose and Dashboard only come up when I assign the shortcuts to F3 and F4 in System Preferences, then I have to press fn key at same time I press the respective keys. This is with option to use function keys as standard function keys turned off. All of the other special function keys work fine. F17, F18, and F19 work fine when assigned functions.

    Anyone else experience this problem? Suggestions?

    Message was edited by: philopaemon
  • philopaemon Level 1 Level 1 (5 points)
    Hadn't update my profile in awhile. I am running OS X 10.4.10.
  • i Joel Level 1 Level 1 (145 points)
    Hi philopaemon ,
    Yes I have the same problem. F3 and F4 have the Expose and Dashboard symbols on them, but don't work- even after manually setting them. It's totally counter-intuitive in that all the other "newly symboled" F keys work fine without pressing the "fn" key. I don't want to have to hold the "fn" key and "F4" key at the same time just to get dashboard to open. This must be a mistake. I'm sure it's simple, but I have had no luck so far finding the answer.

    Please anyone - let us know how to fix this.
  • Joseph Kriz Level 5 Level 5 (5,045 points)
    I received my new keyboard today and the F3 and F4 keys work like they should.
    I didn't have to do anything.

    I'm using it connected to my MacBook and 23" HD Monitor.
  • philopaemon Level 1 Level 1 (5 points)
    I thought my problem might be that I was trying the new keyboard with Power PC iMac, but guess that's not it. Only work around I've found is using the fn key in combo with F3 and F4 with the appropriate system preferences settings.

    This one may require another firmware fix from Apple?
  • Louis J. Sheehan, Esquire Level 1 Level 1 (0 points)
    When will Apple produce a larger keyboard for us older users?


    Louis J. Sheehan, Esquire
  • Bongoman Level 1 Level 1 (40 points)
    I just plugged mine into my MacBook, installed the Keyboard Update but F3 & F4 aren't working. Annoying huh?
Previous 1 2 3 4 Next