6 Replies Latest reply: Aug 16, 2007 9:56 AM by Marc Dumouchel1
lambertd Level 1 Level 1 (25 points)
Hi,

Setting the exact line height to 12 pt (6 lines per inch) doesn’t work when an Opentype (OT) font is used.

Here’s the correct behaviour with a Truetype font (Palatino):
http://farm2.static.flickr.com/1111/107578028252513291cfo.jpg

Here’s the same paragraph, but an OT font was specified:
http://farm2.static.flickr.com/1081/10757813866cf12c9806o.jpg

Can somebody confirm this or is it peculiar to my machine?

Lambert

Message was edited by: lambertd

Message was edited by: lambertd

iMac 24" (2006), Mac OS X (10.4.10)
  • splsm Level 1 Level 1 (45 points)
    I think this may be peculiar to your machine (or the particular OTF font you're using). I tried the same kind of thing using a pair of OTF fonts (ArnePro and ACaslonPro) and the "exact spacing" worked as it should with no bending lines.

    (And for me, this is a big deal--the lack of fixed leading in earlier versions of Pages caused me to dump the application from my machine.)

    You might try quitting Pages, flushing your font cache and restarting your computer and see if the behavior continues; I've found that solves a variety of odd problems on my machines.

    Good luck.

    SP
  • lambertd Level 1 Level 1 (25 points)
    Thank you SP,

    but that didn’t work. I’ve tried cleaning the font caches with FontNuke, deep cleaning user and system caches with Tiger Cache Cleaner, repairing permissions, and logging in as a fresh user.

    Still, setting the line height exactly (eg 12 pt, 18 pt) only works as long as no Opentype font is specified.

    I’ve tried this with Junicode, Charis SIL, Constantia, Courier Std, Hiragino, Osaka, Palatino Linotype, and the ones you mentioned.
  • Magnus Lewan Level 4 Level 4 (3,655 points)
    I do not have Palatino Linotype. Could you reproduce it with another Opentype font, which I or someone else may have?

    On my machine at least Batang and Bauhaus 93 seem to behave strange.
  • lambertd Level 1 Level 1 (25 points)
    Magnus,

    I’ve reproduced this with every Opentype font I tried. Additionally, I found that the problem also occurs with Geneva, Monaco and Osaka Regular (but not Osaka Regular-Mono).

    Opentype fonts included with a basic Mac OS X install include Hiragino Kaku Gothic, Hiragino Mincho, and Aqua Kana. There are also some decent OT fonts available for free online:

    Junicode
    http://sourceforge.net/project/showfiles.php?group_id=158636

    Charis SIL
    <http://scripts.sil.org/cms/scripts/page.php?siteid=nrsi&id=CharisSILdownload>

    Gentium
    <http://scripts.sil.org/cms/scripts/page.php?siteid=nrsi&item_id=Gentiumdownload>

    And there’s the Microsoft Office 2007 compatibility pack for users of previous Office versions, which contains a couple of nice OTFs: Constantia, Corbel Calibri etc. Unfortunately, they’re hidden several CAB files deep in an EXE, so one needs File Juicer and a little patience to get them. If someone would like to try anyway, here’s a direct link:

    http://snipurl.com/1pg2e
  • Magnus Lewan Level 4 Level 4 (3,655 points)
    OK. Yes, the problem occurs for me too - apparently on all OpenType fonts and in addition on a few others.
  • Marc Dumouchel1 Level 1 Level 1 (5 points)
    I have had a similar problem for the previous and current version of Pages. Line spacing is messed up for OT fonts, which forces me to use Word, as we use Myriad Pro for a number of purposes.

    I do not set an 'exact line height'; I'm just using the defaults.

    I'd be interested to hear anyone else's experiences or suggestions.

    Marc