9 Replies Latest reply: Jan 9, 2008 9:37 PM by Nicolas diPierro
Nicolas diPierro Level 1 Level 1 (100 points)
ok so i used dmg files to back up my data from years past.

i'm now unable to open these multi-gigabyte files at all. disk image mounter, disk utility say "unable to attach "mybackup.dmg" - not recognized.

how can i get my data out of these backups?

i think i may have encrypted them with a password... i know the password but these dmg files no longer display the padlock icon.

PowerBook G4 Aluminum, Mac OS X (10.4.10)
  • Carolyn Samit Level 10 Level 10 (95,985 points)
    Hi Nicolas,

    Since these are "multi-gigabyte" files, the first thing that comes to mind is how much available drive space you have ???

    To locate this information, open any Finder window. Free space will be noted at the bottom of the pane. Rule of thumb... never allow the available drive space to fall below 15%.

    That "could" be why your .dmg files won't open... Also, to get information on those .dmg files, select a file then click Command + I. A window will open. Where it says: Open with: click the Pop Up menu button. Make sure it says:
    DiskImageMounter or Disk Utility. That window will also indicate the size/date created and when it may have been modified.

    Hope this helps...

    Carolyn
  • Jelle586 Level 1 Level 1 (0 points)
    Hey,

    I'm having the same problem but I didn't encrypt the file.
    When I try to mount the file it keeps saying "Backup.dmg - Not recognized".
    Having not enough free space can't be the problem, out of 400GB I have 280GB free, the file is only 6.6GB.
    Trying to restore using DiskUtility doens't work, the program won't run a check or repair.

    What can I try to get back my files?
  • PretaxBump Level 1 Level 1 (0 points)
    Hey there i have this exact same proble. im using a brang new macbook 2ghz. this is with more than just one file. i have backups of many different things and none of them work.
    please help with this
  • mrperipheral Level 1 Level 1 (0 points)
    Hello. When I try to open my disk utility I get "the application disk utility has unexpectedly quit". I've tried fsck, repair permissions from terminal, booting in safe mode but nothing seems to work. I couldn't even upgrade from panther to tiger because the install disk wont open. Since everything else seems unaffected I still suspect its a local problem. Can anyone help me, please? Below is the full crash log report. Thanks.

    Date/Time: 2007-10-24 03:57:12 +1000
    OS Version: 10.3.9 (Build 7W98)
    Report Version: 2

    Command: Disk Utility
    Path: /Applications/Utilities/Disk Utility.app/Contents/MacOS/Disk Utility
    Version: 10.4.4 (145.7)
    PID: 367
    Thread: 0

    Exception: EXCBADACCESS (0x0001)
    Codes: KERNPROTECTIONFAILURE (0x0002) at 0x00000018

    Thread 0 Crashed:
    0 com.apple.CoreFoundation 0x901fcba4 _CFBundleGetLanguageSearchList + 0x18
    1 com.apple.CoreFoundation 0x901ea8d8 CFBundleCopyResourceURL + 0x2c
    2 DiskImages 0x942752c8 DIHLGetDefaultsDictionary + 0x50
    3 DiskImages 0x94276414 DIHLCopyPreference + 0x34
    4 DiskImages 0x9427295c DIInitialize + 0x8c
    5 com.apple.DiskUtility 0x0000c5d8 0x1000 + 0xb5d8
    6 com.apple.AppKit 0x92f6b820 -[NSCustomObject nibInstantiate] + 0x10c
    7 com.apple.AppKit 0x92e9a9c0 -[NSIBObjectData instantiateObject:] + 0xbc
    8 com.apple.AppKit 0x92ea19ec -[NSIBObjectData nibInstantiateWithOwner:topLevelObjects:] + 0x88
    9 com.apple.AppKit 0x92f937b0 loadNib + 0xfc
    10 com.apple.AppKit 0x92eea990 +[NSBundle(NSNibLoading) _loadNibFile:nameTable:withZone:ownerBundle:] + 0x2e8
    11 com.apple.AppKit 0x92f698a0 +[NSBundle(NSNibLoading) loadNibFile:externalNameTable:withZone:] + 0x9c
    12 com.apple.AppKit 0x92f7b0a0 +[NSBundle(NSNibLoading) loadNibNamed:owner:] + 0x174
    13 com.apple.AppKit 0x92f69708 NSApplicationMain + 0x174
    14 com.apple.DiskUtility 0x0000c420 0x1000 + 0xb420
    15 com.apple.DiskUtility 0x000143f4 0x1000 + 0x133f4

    PPC Thread State:
    srr0: 0x901fcba4 srr1: 0x0200f030 vrsave: 0x00000000
    cr: 0x44000422 xer: 0x00000007 lr: 0x901fcb9c ctr: 0x901ea8ac
    r0: 0x901ea8d8 r1: 0xbffff780 r2: 0xa00016b4 r3: 0x00000000
    r4: 0xa427afe0 r5: 0xa427aff0 r6: 0x00000000 r7: 0x0000001f
    r8: 0xa01c0dcc r9: 0x497f0f9f r10: 0x0000001d r11: 0xa4270820
    r12: 0x901ea8ac r13: 0x00000000 r14: 0x00000000 r15: 0x00000000
    r16: 0x00334b50 r17: 0xa2eaa6a8 r18: 0xa2e9a6a8 r19: 0xa2eaa6a8
    r20: 0xa2eaa6a8 r21: 0x00000000 r22: 0xa2ea1964 r23: 0xa2eacda0
    r24: 0xa2eab7e0 r25: 0xa427afe0 r26: 0x00000000 r27: 0xa427aff0
    r28: 0x00000000 r29: 0xa4274810 r30: 0x00000000 r31: 0x901fcb9c

    Binary Images Description:
    0x1000 - 0x3dfff com.apple.DiskUtility 10.4.4 (145.7) /Applications/Utilities/Disk Utility.app/Contents/MacOS/Disk Utility
    0x80830000 - 0x8090efff libxml2.2.dylib /usr/lib/libxml2.2.dylib
    0x8a520000 - 0x8a53bfff com.apple.DiscRecordingUI 2.1.17 /System/Library/Frameworks/DiscRecordingUI.framework/Versions/A/DiscRecordingUI
    0x8a570000 - 0x8a583fff com.apple.framework.DUSupport 10.4.4 (33.2) /Applications/Utilities/Disk Utility.app/Contents/MacOS/../Frameworks/DUSupport.framework/Versions/A/DUSuppo rt
    0x8fe00000 - 0x8fe4ffff dyld /usr/lib/dyld
    0x90000000 - 0x9014ffff libSystem.B.dylib /usr/lib/libSystem.B.dylib
    0x901c0000 - 0x9026efff com.apple.CoreFoundation 6.3.9 (299.37) /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
    0x902b0000 - 0x90529fff com.apple.CoreServices.CarbonCore 10.3.7 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonC ore.framework/Versions/A/CarbonCore
    0x905a0000 - 0x90610fff com.apple.framework.IOKit 1.3.6 (???) /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
    0x90640000 - 0x906c8fff com.apple.CoreServices.OSServices 3.0.1 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServi ces.framework/Versions/A/OSServices
    0x9071d000 - 0x9072cfff libPSRIP.A.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ CoreGraphics.framework/Versions/A/Resources/libPSRIP.A.dylib
    0x90733000 - 0x90740fff com.apple.CommonPanels 1.2.1 (1.0) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/CommonPanels. framework/Versions/A/CommonPanels
    0x90810000 - 0x90810fff com.apple.ApplicationServices 1.0 (???) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Application Services
    0x90860000 - 0x908cffff libobjc.A.dylib /usr/lib/libobjc.A.dylib
    0x90940000 - 0x909b3fff com.apple.DesktopServices 1.2.6 /System/Library/PrivateFrameworks/DesktopServicesPriv.framework/Versions/A/Desk topServicesPriv
    0x90a02000 - 0x90a0dfff com.apple.securityhi 1.2 (90) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/SecurityHI.fr amework/Versions/A/SecurityHI
    0x90a20000 - 0x90b7bfff com.apple.Foundation 6.3.8 (500.61) /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
    0x90c32000 - 0x90c4cfff libresolv.9.dylib /usr/lib/libresolv.9.dylib
    0x90d40000 - 0x90d40fff com.apple.Carbon 10.3 (???) /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon
    0x90d50000 - 0x90d6bfff com.apple.SystemConfiguration 1.7.1 (???) /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfi guration
    0x90d7c000 - 0x90d8cfff com.apple.speech.recognition.framework 3.3 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/SpeechRecogni tion.framework/Versions/A/SpeechRecognition
    0x90e80000 - 0x90e9ffff com.apple.MediaKit 2.6 (232.3) /System/Library/PrivateFrameworks/MediaKit.framework/Versions/A/MediaKit
    0x90ec0000 - 0x90ec0fff com.apple.Cocoa 6.3 (???) /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa
    0x9102d000 - 0x91045fff com.apple.WebServices 1.1.1 (1.1.0) /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/WebServ icesCore.framework/Versions/A/WebServicesCore
    0x910e0000 - 0x91134fff com.apple.bom 1.2.8 (64.2) /System/Library/PrivateFrameworks/Bom.framework/Versions/A/Bom
    0x91141000 - 0x91141fff com.apple.CoreServices 10.3 (???) /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices
    0x91242000 - 0x9124bfff com.apple.DiskArbitration 2.0.5 /System/Library/PrivateFrameworks/DiskArbitration.framework/Versions/A/DiskArbi tration
    0x912e0000 - 0x912f7fff com.apple.LangAnalysis 1.5.4 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ LangAnalysis.framework/Versions/A/LangAnalysis
    0x913a0000 - 0x9145ffff ColorSync /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ ColorSync.framework/Versions/A/ColorSync
    0x915e0000 - 0x91699fff com.apple.QD 3.4.72 (???) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ QD.framework/Versions/A/QD
    0x916f0000 - 0x91728fff com.apple.AE 1.4 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ AE.framework/Versions/A/AE
    0x91760000 - 0x917f3fff com.apple.print.framework.PrintCore 3.3 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ PrintCore.framework/Versions/A/PrintCore
    0x91836000 - 0x91853fff com.apple.audio.SoundManager 3.9 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/CarbonSound.f ramework/Versions/A/CarbonSound
    0x9194f000 - 0x9194ffff com.apple.audio.units.AudioUnit 1.3.3 /System/Library/Frameworks/AudioUnit.framework/Versions/A/AudioUnit
    0x91970000 - 0x919befff com.apple.print.framework.Print 3.3 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Print.framewo rk/Versions/A/Print
    0x91a1d000 - 0x91a1dfff com.apple.DiscRecording 2.1.17 (???) /System/Library/Frameworks/DiscRecording.framework/Versions/A/DiscRecording
    0x91a40000 - 0x91ab3fff com.apple.NavigationServices 3.3.3 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/NavigationSer vices.framework/Versions/A/NavigationServices
    0x91afb000 - 0x91b0bfff com.apple.ImageCapture 2.1.5 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/ImageCapture. framework/Versions/A/ImageCapture
    0x91b30000 - 0x91b44fff libCGATS.A.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ CoreGraphics.framework/Versions/A/Resources/libCGATS.A.dylib
    0x91b60000 - 0x91b6bfff libCSync.A.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ CoreGraphics.framework/Versions/A/Resources/libCSync.A.dylib
    0x91b71000 - 0x91b87fff com.apple.DiskManagement 1.1.3 (46.9.1) /System/Library/PrivateFrameworks/DiskManagement.framework/Versions/A/DiskManag ement
    0x92032000 - 0x9204dfff libcurl.2.dylib /usr/lib/libcurl.2.dylib
    0x92070000 - 0x92096fff com.apple.FindByContent 1.4 (1.2) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ FindByContent.framework/Versions/A/FindByContent
    0x920a9000 - 0x920e1fff com.apple.LaunchServices 10.3.5 (98.4) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ LaunchServices.framework/Versions/A/LaunchServices
    0x92170000 - 0x92358fff com.apple.security 2.5 (29780) /System/Library/Frameworks/Security.framework/Versions/A/Security
    0x927f0000 - 0x92827fff com.apple.CFNetwork 1.2.5 (71.12) /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwo rk.framework/Versions/A/CFNetwork
    0x92880000 - 0x92c05fff com.apple.HIToolbox 1.3.7 (???) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.fra mework/Versions/A/HIToolbox
    0x92de0000 - 0x92e30fff com.apple.HIServices 1.4.1 (0.0.1d1) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ HIServices.framework/Versions/A/HIServices
    0x92e70000 - 0x9336ffff com.apple.AppKit 6.3.11 (743.43) /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit
    0x93680000 - 0x93958fff com.apple.CoreGraphics 1.203.30 (???) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ CoreGraphics.framework/Versions/A/CoreGraphics
    0x939d0000 - 0x939d4fff libmathCommon.A.dylib /usr/lib/system/libmathCommon.A.dylib
    0x93a50000 - 0x93a64fff libcups.2.dylib /usr/lib/libcups.2.dylib
    0x93a6a000 - 0x93a7dfff com.apple.speech.synthesis.framework 3.2 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ SpeechSynthesis.framework/Versions/A/SpeechSynthesis
    0x941cd000 - 0x94259fff com.apple.ink.framework 101.1.4 (55.12) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Ink.framework /Versions/A/Ink
    0x94270000 - 0x94333fff DiskImages /System/Library/PrivateFrameworks/DiskImages.framework/Versions/A/DiskImages
    0x9438a000 - 0x943a4fff com.apple.openscripting 1.2.1 (???) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/OpenScripting .framework/Versions/A/OpenScripting
    0x94594000 - 0x945a0fff com.apple.help 1.0.1 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Help.framewor k/Versions/A/Help
    0x945b0000 - 0x945b9fff libz.1.dylib /usr/lib/libz.1.dylib
    0x94610000 - 0x9462afff libPDFRIP.A.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ CoreGraphics.framework/Versions/A/Resources/libPDFRIP.A.dylib
    0x94650000 - 0x946affff com.apple.SearchKit 1.0.2 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/SearchK it.framework/Versions/A/SearchKit
    0x946ed000 - 0x94700fff libRIP.A.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ CoreGraphics.framework/Versions/A/Resources/libRIP.A.dylib
    0x94b0e000 - 0x94bc6fff com.apple.audio.toolbox.AudioToolbox 1.3.4 /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox
    0x950f0000 - 0x95123fff com.apple.DiscRecordingContent 2.1.17 /System/Library/Frameworks/DiscRecording.framework/Versions/A/Frameworks/DiscRe cordingContent.framework/Versions/A/DiscRecordingContent
    0x95140000 - 0x951b5fff com.apple.DiscRecordingEngine 2.1.17 /System/Library/Frameworks/DiscRecording.framework/Versions/A/Frameworks/DiscRe cordingEngine.framework/Versions/A/DiscRecordingEngine
    0x951ce000 - 0x95295fff libcrypto.0.9.7.dylib /usr/lib/libcrypto.0.9.7.dylib
    0x954c0000 - 0x95ac6fff libBLAS.dylib /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.fr amework/Versions/A/libBLAS.dylib
    0x95b20000 - 0x95df0fff libLAPACK.dylib /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.fr amework/Versions/A/libLAPACK.dylib
    0x95f00000 - 0x95f20fff libvMisc.dylib /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.fr amework/Versions/A/libvMisc.dylib
    0x968d0000 - 0x969b2fff libicucore.A.dylib /usr/lib/libicucore.A.dylib
    0x96a04000 - 0x96a6dfff com.apple.htmlrendering 1.1.2 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HTMLRendering .framework/Versions/A/HTMLRendering
    0x96aa0000 - 0x96acefff libssl.0.9.7.dylib /usr/lib/libssl.0.9.7.dylib
    0x96b50000 - 0x96bdffff ATS /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ ATS.framework/Versions/A/ATS
    0x96c00000 - 0x96c67fff com.apple.audio.CoreAudio 2.1.3 /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio
    0x96cb0000 - 0x96d9efff libiconv.2.dylib /usr/lib/libiconv.2.dylib
    0x96de0000 - 0x96df0fff com.apple.vecLib 3.0.3 (vecLib 3.0.3) /System/Library/Frameworks/vecLib.framework/Versions/A/vecLib
    0x96ee0000 - 0x96ee8fff libbsm.dylib /usr/lib/libbsm.dylib
    0x97345000 - 0x973b2fff libvDSP.dylib /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.fr amework/Versions/A/libvDSP.dylib
  • Kreative Level 1 Level 1 (0 points)
    Hello. Has anyone found a solution to the same problem I'm facing? The system doesn't recognize downloaded dmg files when double-clicking them. I tried to repair them in Disk Utilities, even verification doesn't work.
  • Kreative Level 1 Level 1 (0 points)
    Hello. Has anyone found a solution to the same problem I'm facing? The system doesn't recognize downloaded dmg files when double-clicking them. I tried to repair them in Disk Utilities, even verification doesn't work.
  • Kreative Level 1 Level 1 (0 points)
    I was using Firefox to download the dmg files. The problem got solved as I used Safari, the files got open easily. The following note helped me out.

    StuffIt Expander & the .dmg File Type
    The file type we use to deliver StuffIt Expander for Mac is Apple's Macintosh OS X Disk Copy Disk Image File (.dmg).
    If you see binary code in the browser window instead of the file downloading to your system, you are most likely using a browser that doesn't recognize this file format and it's trying to show you the file as a web page.
    You can use Safari or Internet Explorer to attempt the download again or teach the browser you do use about the .dmg file type.
    Here is how to tell Firefox to mount a .dmg file on a Mac
    1) Click here to go to Mozilla and click on the green Download Firefox button. This may sound odd, but it's a must. This set of instructions will only work on this dmg for reasons that are probably hard to explain. Trust me here.
    2) A window will pop up asking you what you want to do with this DMG. Click the 'Choose...' button.
    3) Navigate to your-harddrive/system/library/CoreServices/ and choose DiskImageMounter
    4) Click the 'Do this automatically...' check box to save the setting.
    5) Hit OK. If you don't actually want to download Firefox again, just cancel the download.
    That's it. All .dmg files should now open automatically.
    Troubleshooting
    If that doesn't seem to work right, then go to Firefox -> Preferences -> Downloads and click on the 'View & Edit Actions' button. Look for DMG, click on it, click 'Change Action...' and choose 'Open them with this application' and browse to DiskImageMounter again. This will clear up any confusion within Firefox but you must perform the steps above first or else you can't even get DMG into the list
  • Tim Kline1 Level 1 Level 1 (10 points)
    Thanks, Kreative. I had the same issue, and your posting fixed it for me. Thanks!
  • Nicolas diPierro Level 1 Level 1 (100 points)
    still have no answer to this. i have a hunch that storing them on an airport disk somehow corrupted them, but i hope not. if anyone knows how to rescue DMG files that won't open or won't appear as corrupt, please help!