Previous 1 2 3 4 Next 50 Replies Latest reply: Apr 2, 2009 7:38 AM by nimbus396
rrjj Level 1 (0 points)
I just tried to use quick time to open mp4 on my PC (taken from my dopod/HTC pda phone), but NOW get "error -2041: an invalid sample description was found in the movie". I used to be able to watch the vids, but no longer......

lenovo T60, Windows XP Pro
  • rasmikey Level 1 (0 points)
    I have the exact same problem with videos coming from my HTC TyTN PDA Phone. I was shooting and sharing video of my daughter from this phone just fine, then the new Mac Quicktime updates and I can't watch any of them....very disappointing and frustrating!
  • usernamealreadytaken Level 1 (0 points)
    Exact same problem with .mp4's taken across from my iMate JASJAM. Will not play in iTunes or Quicktime at all when using the mp4 file extension. If I change the file extension to m4v, they will play with no error message AND NO AUDIO!!! Very frustrating.
  • fello Level 1 (0 points)
    I have the exact same problem. I have a PPC 6700, and now I can't view movies I created with it in mp4. If change extension file to 3GP video works just fine.
    Also, when I try to see a webpage with a Quicktime video clip, I only get a Quicktime logo with a big question mark in it, but no play.
    I tried uninstalling and reinstalling, but nothing seems to work.
    I have Windows XP, and it worked fine until a couple weeks ago. Not sure if when upgrading to Quicktime 7.2, though.
  • bmaca05 Level 1 (0 points)
    The standard solution seems to be to change the ext to 3gp, but that does not work for me either, possibly because I have Vista? Anyone?
  • Nikkolus Level 1 (0 points)
    I can't change the extension either, I have windows xp.

    Any help would be appreciated.
  • zhopastinky Level 1 (0 points)
    I have had the same problem. Clicking on an mp4 file, an error in Quicktime regarding the invalid sample description (however, the same file opens in VLC and other applications, but not iTunes or Quicktime). Is it correct to understand this problem has not been solved yet?
  • wisejman Level 1 (0 points)
    has anyone figured this out yet?
  • nsc7561 Level 1 (0 points)
    I have the same problem. I get the -2041 error when trying to open in Quicktime on a PC and a "an invalid sample description was found in the movie" on my MacBook. With the K-lite codec pack, I can play the video in VLC or media player classic but no audio. Help!
  • RomieYO Level 1 (0 points)
    I'm having the same problem - error -2041: an invalid sample description was found in the movie.. when I try to play videos taken by my HTC smartphone.. please help, anyone?
  • wisejman Level 1 (0 points)
    I'm taking video with my Cingular 3225 smartphone. Does anyone have any advice maybe for that since noone seems to have a solution to this?
  • friedfishribs Level 1 (0 points)
    I'm having the same problem here. I tried changing the extension to a .3GP instead of a .mp4 but it still gives me the same error: an invalid sample description was found in the movie.
  • m1a1driver2006 Level 1 (0 points)
    I am also having the same problem. At one time, i was able to play this video. Now all i get is error -2041 when i try to access the file.
  • CobraX Level 1 (0 points)
    I could view mp4 movies from my fiancée's NEC mobile fine before, but since upgrading to Leopard I can no longer view them and also get the error: An invalid sample description was found in the movie.

    I hope someone can figure this out, or someone was able to contact Apple directly regarding this.
  • CobraX Level 1 (0 points)
    Tried the renaming mp4 to 3gp and it did work for me so thanks for that tip... kinda silly how it use to be able to play the files despite the filename before, and now you have to rename them. Hopefully it'll be addressed in the next QuickTime update.
Previous 1 2 3 4 Next