7 Replies Latest reply: Aug 20, 2007 4:54 PM by Brian Tesoro
Brian Tesoro Level 2 Level 2 (400 points)
I'm having issues with the time and date stamp. All of my email, text messages, the time is off by one hour, an hour advanced to be exact. Under the Date & Time preferences, I have the Time Zone Support on and my time zone set at Baltimore, Maryland.

My settings on my computer are correct. Any ideas why this is happening? Thanks in advance.

Mac Plus, PM 7100/80, PM 500MP, PB G4, iMac G5, MBP 17" C2D 2.4 GHz, iPhone 8GB, Mac OS X (10.4.10), iPods: 1/3/5G, mini 1G, shuffle 1/2 G, nano 1/2G; Westone UM2, PIXMA iP6600D
  • Jose M Level 4 Level 4 (1,010 points)
    Brian

    Not sure why that is happening, but have you tried to go into the date and time preferences and turning off Set Automatically. Then set your time and date and see if that might correct the hour off time?
  • Brian Tesoro Level 2 Level 2 (400 points)
    I tried that no luck. And the reason why I had that set on was that when it was turned off before, the appointments that I made on iCal were 4 hours off.
  • Jose M Level 4 Level 4 (1,010 points)
    On your computer go into date and time Properties and click on the Time Zone Tab. At the bottom of the screen make sure that the this option, (Automatically Adjust Clock for Daylight Saving Changes.) is checked.

    If this option was not checked, make the change reboot computer and then re-sync phone.

    Lets see how that works for you?
  • Brian Tesoro Level 2 Level 2 (400 points)
    Hey Jose,

    On OS 10.4.10, there is no checkbox for "Automatically Adjust Clock for Daylight Saving Changes." My Time Zone: EDT, Closest City: Washington, D.C.
  • Brian Tesoro Level 2 Level 2 (400 points)
    I figured it out myself. In the iPhone's Date & Time settings, Set Automatically should be turned off and I manually set up the time zone, date and time.
  • k2tha-izzo Level 1 Level 1 (0 points)
    But don't you want the date/time to change automatically? I mean, if you were to take a trip to a different time zone, don't you want the clock to automatically tell you what the correct time is in the current time zone rather than what time it is at home?

    What would the point of having "Set Automatically" available be if we have to keep it turned off?

    Sounds like a bug to me...

    Now that I see this post, I think it's directly related to my calendar appointment time problem that I just posted. I saw the time stamp on something (don't remember if it was email or something else) was messed up on my iPhone after traveling and rebooting the iPhone fixed it. However, yesterday I found that all my appointments in the calendar were off by 5 hours. And here you post that yours were off by 4 hours too.

    Everybody who's been traveling should check your calendar and see if your appointments are still correct.

    Message was edited by: k2tha-izzo
  • Brian Tesoro Level 2 Level 2 (400 points)
    Technically yes you do. So I see your point that it could be a bug. The weird thing is that when I set the Date & Time to Automatic, it does display the correct date and time. It just messes up when it time stamps.

    The calendar issue can be solved by setting the Time Zone Support "On" and finding the closest city in your time zone under Date & Time>Calendar.

    I've submitted a bug report to Apple. Hopefully they have a fix for this.