Skip navigation
This discussion is archived

Quicksilver Dual 1GHz won't power up with the monitor connected.

13520 Views 2 Replies Latest reply: Oct 29, 2010 11:27 AM by HighStrungLoner RSS
HighStrungLoner Calculating status...
Currently Being Moderated
Oct 29, 2010 11:26 AM
My Quicksilver with 17" LCD Studio display won't start up. The power button blinks on, the fans make a turn or two and the red LED on the motherboard blinks once. If I hold the power button down it blinks once but the fans and red LED repeat once a second. After this began I started it up in FireWire target mode with the monitor disconnected and it worked fine for a few hours. Then it seemed to start up ok without the monitor attached but would immediately shut off when I connected the monitor. Now just the behavior I described at the beginning. I've reset the SMU (PMU??), zapped the PRAM. left it unplugged and taken out the battery. Nothing changes. This has all been in the past 24 hours after I shipped the CPU and monitor back to my home. What's next??

Frank
PowerMac G4 Quicksilver, Mac OS X (10.4.10), 1GB RAM, 17" Apple Studio Display
  • Thomas Bryant Level 6 Level 6 (13,865 points)
    Hello! Read THIS article about the POST test and see if the blinking corresponds to a particular symptom. Also have you tried the monitor with another computer to rule out monitor problems? Have you reseated the video card? Tom
    G-4/Sawtooth/1.2ghz Sonnet/10.3.9/2gig ram-G-4 1.8ghz Sawtooth 9.2.2 & 10.3.9, 4-320gig Satas

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.