4 Replies Latest reply: Nov 12, 2007 7:46 PM by Derek Hoffer
tragicallyhip Level 1 Level 1 (80 points)
In iTunes 7.3.2 running Mac OS X 10.4.10, I'm successfully syncing everything, except that events created on iPhone Calendar are being added to the wrong calendar in iCal. They are actually being added to a read-only calendar, which means I can't change them on iCal. I have to delete and create a new one. I've reset which calendar new events are supposed to sync to, but no luck. Any ideas?

MacBook Pro, Mac OS X (10.4.10)
  • Errk! Level 1 Level 1 (20 points)
    This worked for me - in iCal, choose which Calendar you want the new app'ts to be added to, and drag it to the bottom of the list of Calendars.
  • davidgibson Level 1 Level 1 (15 points)
    I am having a similar problem as tragicallyhip. my new appointment keep being added to my calendar 'Home' instead of the one I want. I tried moving my work calendar, which is the one I typically want to sync to, to the bottom of the list and deleting the Home calendar. When I sync, the system recreates the Home calendar and puts the new event on that calendar.
  • elkay_brooklyn Level 1 Level 1 (0 points)
    I'm wondering if anyone has found a solution to this. I'm encountering the same problem.

    Right now, on my iBook, I only use one calendar in iCal ("Work") and I have deleted all other calendars in iCal. When I add a calendar event into my iPhone, though, it automatically seems to be adding that event to the "Home" calendar on my iPhone. Then, when I sync with my iBook, the "Home" calendar is re-created on my iCal, and the new event from my iPhone gets put there, instead of into the "Work" calendar.

    When I set iPhone sync preferences set in iTunes so that I'm only syncing the "Work" calendar, the new events that I've added into my iPhone calendar don't get added into my iCal at all.

    What I would like to do is either set the default calendar selection on my iPhone to "Work" so that any new events that I add on the iPhone get automatically put into the "Work" calendar instead of the "Home" calendar. Or, even better, I would like to completely delete the "Home" calendar option from my iPhone, so that it matches my iCal, and that all events can only be added into "Work" on my iphone (I want "Work" to be the sole calendar on my iPhone).

    All suggestions would be appreciated.
  • Derek Hoffer Level 1 Level 1 (0 points)
    I think I finally solved my problem two ways:

    try Damon's tips in this thread: http://discussions.apple.com/thread.jspa?threadID=1218972

    Also, in Itunes, on the info tab, scroll all the way down, you can choose which calendar new events created on the phone go into. This seems to have done the trick for me. The sync to Ical into my "entourage" calendar which then sync to Entourage for me. I don't use ical.

    Hope this gets you somewhere