2 Replies Latest reply: Aug 29, 2007 3:23 AM by PHL07
PHL07 Level 1 Level 1
I have exported a share on OS X 10.4 by creating the directory in the NetInfo utility, starting nfsd and mountd, and then verifying it was shared with 'showmount -e'.

Then I went to my Solaris host and tried to mount <machost>:/<export> /<local mount>

I get error:
server not responding: RPC: Authentication error; why=Client credential too weak.

On the OS X, at the console I was root and made the exported directory 777 rights. On the Solaris host, I am also root when I try to mount.

What else am I missing?

Macbook 2.16Ghz, Mac OS X (10.4.10)
  • Gary Kerbaugh Level 6 Level 6
    Hi PHL07,
       It's my guess that the Sun box is trying to mount from an unprivileged port. (one with port number greater than 1024) Either allow this on the server with an "insecure" option in the exports entry or force the use of of a privileged port on the client by using the -P or resvport option in the mount command. (or fstab)
    --
    Gary
    ~~~~
       I used to work in a fire hydrant factory. You couldn't park anywhere near
       the place.
             -- Steven Wright
  • PHL07 Level 1 Level 1
    Thanks for the tips. I don't see the export option for insecure when I do a 'man export' in the Mac shell. Do you know what I would put in the opts parameter (aside from ro)?