Skip navigation
This discussion is archived

Airport Extreme - Airdisk dissappearing act

3498 Views 21 Replies Latest reply: Sep 19, 2007 9:01 AM by sivil. RSS
1 2 Previous Next
danielcarrier Level 1 Level 1 (0 points)
Currently Being Moderated
Aug 29, 2007 8:18 AM
I recently bought an AE for the gigabit and "n" connectivity potential in conjunction with its ability to provide a network-based storage solution. However I have not been able to get anything close to reliable airdisk functionality.

Initial setup was flawless for wired and wireless networking, DHCP and internet access. I have a wired imac G5 and wireless MBP. The AE is firmware 7.2 out of the box. I then added a 250GB USB/FW acomdata enclosed hard disk (not sure of brand) HFS (journalled) formatted and was able to access from both computers without a problem. I did run into the "missing directory" issue temporarily but solved that by using a disk password (not account or base station password) which I discovered reading this very helpfull space. Then began the more difficult obstacles to overcome ... which I'll cover here in sequence trying to "capture" what I learned along the way in order to hopefully bring this to a systematic elimination of causes and solution.

Day 1

To increase bandwidth while I copied over a high volume of data after the initially successfull setup mentionned above, I switched the MBP to ethernet (shut down MBP airport, plugged in cable). Airdisk dissappeared and reappeared in the disk utility during this process, but in trying to connect I got a variety of errors from "the operation cannot be completed because one or more required items cannot be found (Error code -35)" to the one claiming an incorrect password, to one related to a corrupt alias (with question to delete or repair, either to no avail). Connecting directly from Finder "Go" menu also did not work. Sorry if I forget the exact wording of the errors but they are the sames ones everyone has been reporting and if memory serves they all occur after being presented with the password screen and then "seeing" the airdisk in a dialog box right before finally mounting it. The AE/HD restart "solution" did not work for me at this point. I connected the drive directly to the MBP and it was fine. I ran disk utility verify disk (no errors) and repair disk (nothing repaired). Plugged it back into AE after power-cycling both .. and then was able to access it again. I was also able to switch between ethernet and wireless successfully, but this time by carefully ejecting the Airdisk before making the switch.

CONCLUSION: I had been careless in switching modes ... always use eject in the future.

I then set the MBP off on a file copy mission which was to last through the night and went to bed.

Day 2

Woke up with no Airdisk in the Finder. And again, could not connect using all the possible methods. Same errors. After a day of searching the net I came up with a long list of potential causal factors. Took no chance and implemented all of them.

1a. turn off IPv6
1b. ensure DHCP lease was as long as possible (365 days ... was previously set to 4 hours .. had I lost the connection over night ?)
1c. replaced the hard drive with a different 250GB in a generic USB-only enclosure (previous one was USB/FW)
1d. reformatted to HFS (no journalling) ... (previously Journalling was enabled ... and btw I kept the same volume name as the previous one - this to ensure I don't "loose" my itunes library)
1e. repaired permissions on MBP
1f. verified/repaired USB disk with disk utility
1g. and it's worth noting that both these disks have been operating flawlessly when connected directly to either the MBP or iMac for 6 months.

After much file shuffling the new drive was ready and running fine on the MBP. So I proceeded to eject, powerdown AE, plug HD into AE, powerup drive, then AE and tried to connect to the Airdisk with MBP. Again, errors as above with a new twist this time. Beachball during mounting leading to Finder "not responding / crash" (is that possible on a mac?) requiring a hard reboot. No candy. I plugged the HD back into MBP, ran verify. At this point the disk utility reported not being able to unmount the disk. A few HD power-cycles later I was able to successfully run the verify/repair sequence. Plugged back into AE. This time I was able to connect first time using the "Go" menu approach (I had at this point given up even tring through the disk utility .. and no, it actually never auto-mounted for me). I tested ejecting / remounting a number of times and switching between wireless and ethernet connection on MBP. Success every time. Now although I felt I was about at the same point as the night before I had higher confidence that I had fixed "something" in the process of changing settings, reformatting, etc... So again I set the MBP off on an overnight file copy mission.

CONCLUSION: Must have been the USB/FW interface wreaking havoc or the DHCP lease timing out the night before.

Day 3

Woke up this morning with Airdisk gone from finder. Can see it in disk utility. Can call it up through "Go" ... I get the password screen, the list of drives where it appears but I cannot mount it. I get the (Error -35) message. Again.

Extreme frustration to say the least. And from what appears to be erratic behavior totally out of character for an apple product (I am ... or was ... a Mac convert). But surely something is triggering this behavior and I can't give up yet. If I was never able to see the drive in the first place I would have less hope. That said, I'm quickly running out of ideas and the only next steps I could come up with based on more googling are:

2a. Enable share disks over WAN (I don't need to but somebody on this space reports this setup change works for him)
2b. Change the volume name and disk sharing password(same name bringing back memories of failure, inspiring the AE to fail again ... ?? sounds a bit voodoo but ...)
2c. Try with a USB "stick" to isolate the problem to the drive/AE combination

I also tried to determine if the HD was powering down overnight, possibly causing this. I wasn't there so I can affirm it, but previous behavior from both these drives when connected to the macs was that they never powerdown. Also, drive was not in powered down state both mornings I woke up to the problem.

My appologies if this is long-winded but I wanted to avoid going back and forth on first order solutions, many of which I've already tried. I also wanted to try and narrow this down as much as possible and maybe with all our heads together we can crack this thing ('cause I know I'm not alone .. Apple, pay attention, a bunch of people here are doing your job while you're being awfully quiet about that wart on your nose !).

So in hope that somebody out there has a lead onto something I haven't tried. I'll add it to my list of "fixes" for tonight and will report back tomorrow.

Thanks in advance
macbook pro core duo 15", Mac OS X (10.4.10), also own a 1st gen imac G5
  • Rajesh Sharma Level 4 Level 4 (3,730 points)
    Currently Being Moderated
    Aug 30, 2007 9:50 AM (in response to danielcarrier)
    Thanks for the detailed post. Really helpful.

    I have the same issue, had it in 7.2 and 7.2.1

    Hopefully we'll work something out soon. It's driving me up the wall!
    Arctic PowerMacBook (Pro) C2D 17" 2.33 160gb 5400rpm, Mac OS X (10.4.10)
  • Rajesh Sharma Level 4 Level 4 (3,730 points)
    Currently Being Moderated
    Aug 30, 2007 10:04 AM (in response to Rajesh Sharma)
    The best method I've found from here, is to;

    a) Unplug the drive from the AEBS,
    b) Plug it into your mac - using whatever cable, I use FW800.
    c) Restart the drive so that it mounts on the desktop.
    d) Eject the drive and reattach to the AEBS.

    Then it can be reopened as an AirDisk.
    Arctic PowerMacBook (Pro) C2D 17" 2.33 160gb 5400rpm, Mac OS X (10.4.10)
  • Rajesh Sharma Level 4 Level 4 (3,730 points)
    Currently Being Moderated
    Aug 30, 2007 7:02 PM (in response to danielcarrier)
    I'm still getting it in 7.2.1

    Restarting the router from the menu isn't making any difference for me unfortunately.
    Arctic PowerMacBook (Pro) C2D 17" 2.33 160gb 5400rpm, Mac OS X (10.4.10)
  • Rajesh Sharma Level 4 Level 4 (3,730 points)
    Currently Being Moderated
    Aug 30, 2007 7:28 PM (in response to danielcarrier)
    Seems to have installed properly. It says it did anyway Is there some way of knowing?

    Thanks for the reply.
    Arctic PowerMacBook (Pro) C2D 17" 2.33 160gb 5400rpm, Mac OS X (10.4.10)
  • David Stempnakowski Level 2 Level 2 (320 points)
    Currently Being Moderated
    Aug 30, 2007 8:31 PM (in response to Rajesh Sharma)
    This is the exact procedure I have been using for the past few weeks and the only one that works. I had several 250GB HD's connected and this has been a real pain in the butt. I've updated to 7.2.1 in hopes that it might resolve the problem, but so far no such luck.

    I discovered another thing this morning. One of my AEBS attached HD's died over night. Seems that it crashed the base station as well when it did. I had no light on the AEBS at all this morning, even though it had power and the ports were working. When I unplugged and then re-plugged the power cord, the flashing amber light came on and eventually it came back up. But then I couldn't connect to any attached drives.

    Then I have to go through the process of mounting those drives directly on a Mac, eject, then plug back into the AEBS, then they become available again.
    PowerMac G5 2GHz (x2) 6GB 2x500GB HD; 15 PB G4 1.5GB; 1GHz G4 AGP 1.5GB, Mac OS X (10.4.10), Sun Ultra 10 Solaris 10, AppleTV, Airport Extreme N Gig E
  • mrjabbski Calculating status...
    Currently Being Moderated
    Aug 31, 2007 2:47 AM (in response to danielcarrier)
    *HERES SOMETHING I POSTED IN ANOTHER THREAD, THIS SEEMS TO BE GOING DOWN WELL AS A SOLUTION!*


    Hi,

    I've been trying to work out the Hard Drive problems with the Airport Extreme for a few days and have had some success, so I'll share the info if its any use!

    First of all, your printer and both hard drives all run off their own power supply, therefore, you don't need to have a powered usb hub, or just take the plug out and keep using the hub, save yourself a plug!

    More importantly, I have had the same thing with the hard drive appearing in the Airport Utility yet whenever I try to connect, it comes up with an error and can't mount, although when I go to network and connect it appears but then goes wrong at the last part mounting, this is what I found...

    the first time I plugged hard drive in all worked nicely, however, any time I have unplugged the power to the Aiport Extreme and connected again it'll show but never connect. When I went to make a few partitions I realised that if you unplug the router and repower, whatever HD name its seen before doesn't work until the HD name was changed again. For example....

    I called my first HD to connect 'wifiHD', was working fine, next time i unplugged router was still showing in network but I couldn't mount it, I then plugged it to the mac and renamed it 'wifiDISK' for example and plugged it back into the router and it worked fine! Its very strange cos when I needed to unplug it last time I then had the same trouble and just renamed it back to 'wifiHD' it worked fine! Its a little flaw which is a right bugger to find so the bottom line is...

    RENAME THE HARD DRIVE EVERY TIME YOU UNPLUG THE ROUTER AND YOU CAN MOUNT IT AGAIN

    Another tip is format your HD in 'Mas OSX Extended' as it can be read by both mac and PC over the network. Then as windows isn't the best when you go to 'My Network Places' and 'Add Network Place' if you can't find the HD or even the router then enter

    \\routername\\hardrivename\

    in this format into the box, it'll take a mo but it'll then ask for the password! I personally have my hard drive guest access read + write so I entered

    user: guest
    password: base station password (or disk password as selected in airport utility)

    and it all worked!


    Sorry for the long explanation, hope this has helped! Let me know how you get on!
    Macbook Pro, Mac OS X (10.4.10)
  • L NutterButter Calculating status...
    Currently Being Moderated
    Aug 31, 2007 5:37 AM (in response to danielcarrier)
    I recently purchased the Gigabit Airport Extreme, and began experiencing the Airdisk problems described in numerous posts.

    In my own experience, and reading through the various posts online, I thought this problem only occurred when both Macs an pcs were accessing the Airdisk.

    After numerous tests (mounting Airdisk on Mac, then XP, then dismount from Mac and try to mount it again - only to receive the "invalid password" error) - it seemed that the problem occurred with the disk formatted as HFS with both Macs and PCs accessing it.

    I have temporarily solved the problem by formatting the Airdisk as FAT32 (not an optimum solution as this format has the 4GB file size limitation) but I have not experienced a problem from a Mac or PC since doing so.

    Has anyone had the same problems with the disk formatted as FAT32?

    I had hopes that the new firmware (7.2.1) would fix this - but after reading a few posts today I am a bit more skeptical. But of course I will test it out and let everyone know.

    L
    MBP 2.4, Mac OS X (10.4.10)
  • Rajesh Sharma Level 4 Level 4 (3,730 points)
    Currently Being Moderated
    Aug 31, 2007 9:18 AM (in response to mrjabbski)
    Thanks for the reply.

    I'm not sure that you need to rename it. I'm finding that just attaching the drive to the mac and restarting it, ejecting it and then re-attaching to the Airport is enough. It seems that the mounting and unmounting is what fixes it.

    Best of luck.
    Arctic PowerMacBook (Pro) C2D 17" 2.33 160gb 5400rpm, Mac OS X (10.4.10)
  • Rajesh Sharma Level 4 Level 4 (3,730 points)
    Currently Being Moderated
    Sep 1, 2007 10:08 AM (in response to Rajesh Sharma)
    I decided to turn on journaling on mine and I stopped using the Airport Disk Utility.

    Last night, the AEBS conked out. Rather than reboot it I went to sleep. I was told External HD2 had disconnected

    I woke up this morning, rebooted the AEBS and the Mac, and the went to the Finder/Network to reattach the HD.

    To my amazement it did. This is the first time it's reattached without me needing to mount it on my computer first.

    Just thought you all might like to know.
    Arctic PowerMacBook (Pro) C2D 17" 2.33 160gb 5400rpm, Mac OS X (10.4.10)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.