3 Replies Latest reply: Sep 27, 2007 12:26 PM by Horror in Oklahoma
Jeanieo8 Level 1 Level 1 (0 points)
I upgraded to Quicktime 7.2 a couple of days ago from 7.15, and now I can not play mpeg-2 files in quicktime or in mpeg streamclip. Both applications quit when I try to open an mpeg-2 file. I can open and play the files fine in VLC. Also, if I am in column view in finder, and I click once on an mpeg2 file to get the preview window to show up, my whole finder screen will temporarily blank out, and then return to normal with the finder window closing on me.

If I am in list view, and I try to pull up info on am mpeg2 file, the info will pop up for one second and then the info and the finder window will close.

I can still play .avi (divx, 3ivx, etc), .dv and .mp4s just fine on Quicktime. I could play mpeg2 files prior to this update. I have the mpeg2 playback component, and I downloaded it again today to make sure I had the latest one, but that didn't fix the issue.

2 GHz PowerPC G5 iMac, Mac OS X (10.4.10), 2 GB SDRAM
  • Jon Walker Level 6 Level 6 (18,045 points)
    Can't really help with your problem but wanted to let you know that I am still able to play MPEG2 in both QT v7.2 and MPEG StreamClip v1.9b3. Only problem noted with QT Player 7.2 is the habit of unexpectedly quitting when a movie is opened by double clicking on its icon and then attempting to open the new "Inspector" window. (Works fine, however, if I open QT Player first, open "Inspector" if not already open, and then load the movie.) So I don't think your problem is QT, QT Player, MPEG2 component, or MPEG Streamclip in combination per se. Doubt this makes you feel any better though. Lets us know if you figure it out.



  • DickGrayson Level 1 Level 1 (0 points)
    I have been having the exact same problem. I cannot play MPEG-2 files using QuickTime, even though I have purchased and installed the MPEG-2 component. (I sure felt silly after dropping $20 to NOT solve my problem).

    Basically, when I open an MPG file in QT, I get a blank white screen (no video) and I can hear the audio only.

    I have also found that the same files play fine in VLC, so I know that the file isn't "audio only"

    I've tried the "Force Rosetta" workaround, but this only makes the blank white screen turn black (still no video, only audio).

    I felt the need to post after reading the first response. I wanted to also say that even though someone ISN'T having the same problem...someone else IS.
  • Horror in Oklahoma Level 2 Level 2 (275 points)
    What is your MPEG-2 Playback component version? In other words, do you have the latest version? Mine is 6.4.1 (Universal) and works fine with QT 7.2.