Previous 1 2 Next 24 Replies Latest reply: Jan 6, 2008 5:42 PM by jetspeedz
Denny009 Level 1 Level 1 (70 points)
I spent a lot of time searching through the forum to find the solution for my problem but I could not seem to find the concrete solution for it. Hence, I'm asking for help.

Problem description:
I can't access my USB drives connected to the Airport Extreme over the WAN from Windows XP. However, it's working fine with my Mac.

My Configuration:
+ Airport Extreme firmware version 7.2
+ 3 USB drives connected to the Airport Extreme via the USB hub
Using the AirPort Utility, I have configured the followings.
+ On the Airport/Base Station tab, I have enabled "Allow configuration over Ethernet WAN port" and "Advertise configuration globally using Bonjour"
+ On the Disks/File Sharing tab, I have enabled "Enable file sharing" with accounts options (and I have created different user accounts). I also enabled "Share disks over Ethernet WAN port" and "Advertise disks globally using Bonjour"
+ On the Advanced/Bonjour tab, I have enabled "Use a wide-area hostname"
+ I also registered my dynamic IP address at home with DynDNS

My Observations:
+ At home (this means locally), I can access all the drives from all of my machines including, Windows XP, Windows Vista, Mac Mini, PowerBook.
+ Outside of home (this means over the (WAN), either at work or at my friend's house, I still can access all the drives from my PowerBook. However, I CANNOT access any of the drives from any Windows machines.

My Understanding:
+ On Mac, it uses AFP protocol for file sharing and this is working fine locally or over the WAN.
+ On PC, it uses CIFS protocol for file sharing and Airport Extreme seems to have issue with this over the WAN.

Help!!!
If anyone has found a working solution and has tried it yourself and you know it works, please post the solution with detail steps. Your help will be highly appriciated. I'm pretty sure that I'm not the only one who has this issue.

Thanks
  • tolthoff Level 1 Level 1 (30 points)
    I would love to know this too. I have tried to make this happen but for some reason it just won't work. Anyone got some step by step instructions out there? Or is this thing just broke?
  • ahansen Level 1 Level 1 (0 points)
    If you can get a static IP-address from your ISP, making this work is very easy. Where I sit (Denmark) all the ISP's provide static IP-addresses for about 2$ per month
  • Denny009 Level 1 Level 1 (70 points)
    Ahansen,

    I don't think this issue has anything to do with static IP address. For most of us in the US, although we have the dynamic IP address from our ISP (I have Comcast in my case), if the modem/router is always on 24/7, the IP address does not get renewed.

    Again, although, I have the dynamic IP address, I have the same IP address for many months. I have been using the same IP address to remote desktop back to my server at home when I'm away from home.

    I don't see how the static IP address is revelant here in this case unless I'm missing something.
    If it works for you, everyone will appreciate you very much if you can post the detail instruction here.
  • larsd Level 1 Level 1 (0 points)
    I see that you are menttioning an option called "Share disks over Ethernet WAN port". Where do you find this option? I can only find a bonjour option in my sharing options. I have tries both 7.2 and 7.2.1 firmware.

    Do you do anthing to enable this option?

    -LarsD
  • Denny009 Level 1 Level 1 (70 points)
    Hi Larsd,

    I used the AirPort Utility.
    + Launch Airport Utility to connect to the base station
    + You should see the buttons on top (Airport, Internet, Printers, Disks, Advanced). Click on the Disks button.
    + You should see 2 tabs (Disks and File Sharing). Click on File Sharing button.
    + You should see the option to "Enable file sharing". Once you have selected this option, you will be able to select/unselect the "Share disks over Ethernet WAN port.
  • LukasO Level 1 Level 1 (0 points)
    It is very likely that your ISP is blocking one or more of the ports used by CFIS to prevent exactly what you are trying to do on Windows computers (Most of their customers) They just have not yet found that the port that AFS uses to be a problem so they have not blocked them. Most ISP Service Agreements state that you cannot run a "server" from your home; whatever that means.
  • Erkki Pöytäniemi. Level 1 Level 1 (45 points)
    So how do you exactly do the settings? I am only interested of connecting to my Airport-connected hard drive from outside home with my MacBookPro. Following Denny009's advice I have similar settings and I have also registered with DynDNS. What then? I presume that in the Advanced/Bonjour tab I put the DynDNS-registered domain in Domain, but what else?
  • ColonelSmith Level 1 Level 1 (25 points)
    Ive been trying to figure this out myself. I think this is a great feature. It works amazingly well with my MacBook using AFP. I was at starbucks earlier today accing my AirPort disk away from home and it worked perfectly. However, I have two other windows laptops that I would like to use this on. Maybe there is some way to get AFP to work on windows? If anyone can figure this out I would be extremely happy.
  • idiogenicosmoles Level 1 Level 1 (0 points)
    I've been wrestling with this for awhile as well. I can't find anything published at Apple or on Google that just plain lays this out with instructions. That would be nice to see, Apple.
  • solito Level 1 Level 1 (0 points)
    I am having the same issue. Ideally I would like to see an AFP client for Windows. Alternatively the option to enable SMB sharing over the WAN, although I would prefer to not have to enable this.

    Another related request, it would be great if we could optionally specify a list of IPs that is able to access the disk from the Internet.
  • Alex_Caranci Level 1 Level 1 (0 points)
    This is for XP only. I don't know about Vista. Go to My Network Places, click on Add a Network Place under Network Tasks.
    When the wizard comes up click next, on the next page choose the folder icon that says choose another network location, and click next.
    At the next screen type in //(your WAN IP Address)/(the name of your volume) and click next.
    At the next screen make a name for your network place and click next.
    Then Click Finish
  • Alex_Caranci Level 1 Level 1 (0 points)
    This is for XP only. I don't know about Vista. Go to My Network Places, click on Add a Network Place under Network Tasks.
    When the wizard comes up click next, on the next page choose the folder icon that says choose another network location, and click next.
    At the next screen type in //(your WAN IP Address)/(the name of your volume) and click next.
    At the next screen make a name for your network place and click next.
    Then Click Finish
  • Nashdiesel Level 1 Level 1 (0 points)
    This worked but I just used my Router IP address (10.0.1.1). I could be mistaken but I don't think that's the same thing as a WAN IP Address is it?
  • ParticleMan Level 1 Level 1 (0 points)
Previous 1 2 Next