13 Replies Latest reply: Sep 22, 2007 1:46 AM by go-dons
Folklorist Level 1 Level 1 (5 points)
I've been using iWeb since 1.0 and updated about a week or so with no problems. I've published changes to my sites many times during the past week and have loved the increase in speed v. 2.0 offers.

Suddenly last night, iWeb doesn't publish changes to iDisk anymore. iWeb itself saves and retains my changes (after I quit and re-open, it reflects my changes; after I "publish" it changes the color of my changed pages from red to blue). Unfortunately, none of my changes of any kind actually make it to iDisk and therefore none of my changes make it to the web.

I've tried updating files' text, links, creating new pages, deleting pages . . . nothing. iWeb thinks the changes have been made but nothing is happening on iDisk.

Any ideas?

PowerBook G4, Mac OS X (10.4.10)
  • Tom Gewecke Level 9 Level 9 (74,450 points)
    Have your checked your page using another browser (and emptied your Safari browser cache)?

    If you provide your url, others can check whether your problem might only be local to your machine.
  • Folklorist Level 1 Level 1 (5 points)
    Yeah, I've checked in Safari and Firefox, deleted cache, etc. I've even copied the html files off my iDisk and loaded them locally--no changes made. Linked files don't upload either.

    It's very strange. As I say, it was working fine and then stopped uploading changes with no indication of a problem. iWeb itself is fooled.

    Below the link to one of my pages. I first noticed the problem when I linked reading #2. iWeb shows me that the reading is linked and the page is updated, but obviously the true published version shows reading #2 as unlinked.

    http://web.mac.com/chrisantonsen/FLK371/Readings.html
  • Tom Gewecke Level 9 Level 9 (74,450 points)
    Have you done a "Publish All" from the File menu?

    Are you by any chance using a local copy of your iDisk and relying on syncing? If so, you might try turning off syncing, trashing the local copy, and republishing.
  • Folklorist Level 1 Level 1 (5 points)
    Tom, I appreciate your effort here. While I was eagerly awaiting advice, it occurred to me to try a "publish all." It's underway right now but is going to take a while. I'll chime in again when that finishes, successfully or not.

    I'm using iWeb in the conventional way: just one domain file on this one computer (excluding strategic backup copies of the domain file). In case it becomes a question, I've confirmed that iWeb is using my primary copy of the domain file; dates modified show me it's not touching the copies.
  • Tom Gewecke Level 9 Level 9 (74,450 points)
    In system preferences/.Mac/iDisk, is iDisk syncing on or off?
  • Folklorist Level 1 Level 1 (5 points)
    "In system preferences/.Mac/iDisk, is iDisk syncing on or off?"

    Sorry, meant to mention that. iDisk syncing is off. I've never used it.

    It looks as if the "publish all" isn't making the changes appear either. Serious bummer.

    Looking ahead (not admitting defeat on this yet, but realizing I might not have your ear (or is it eye) all day, can I dump all my iweb files from iDisk and then publish from one of my recent backup domains? If not, how do I use a backup domain for a "do-over?"
  • liveon2wheels Level 1 Level 1 (0 points)
    I would just like to say that I am having the same problem. I have 3 pages with 3 different movies. My first publishing only contained one movie on one page. After I added the other pages, I also added the other movies. The text and additional pages did indeed publish, but the movies contained on each page each play only the first movie I published and not the additional new ones. I sure hope this is not an iWeb bug. Argh!
  • Folklorist Level 1 Level 1 (5 points)
    Okay, it's taken something like 15 hours--slow processes--but I got it fixed, with the help of an AppleCare technician. The call was free since I just purchased iLife 08 a week ago (90 days phone help free).

    Although I tried many different things, here's what ultimately did the trick:

    1. CLEAR OUT THE WEB FILES ON YOUR iDISK: On your iDisk, delete: (a) the index.html file in the main Web folder; (b) deleted all files in the Sites folder within the Web folder. This forces iWeb to reload all files. I had trepidations because I wasn't sure it was safe to do this, but the Apple guy confirmed that it's the proper thing to do.

    2. SAFELY BACKUP YOUR DOMAIN FILE: Create an "archive" copy of my Domain file by selecting the Domain file, going to the File menu, selectelecting "Create archive of [x]." This backs up the file while disguising it so it doesn't look like the primary domain file--apparently that can sometimes cause problems.

    3. DELETE HIDDEN DOMAIN PREFS FILE: Select the Domain file, ctrl-click to show contextual menu, select "Show package contents." In the window that comes up, look for the file with the name "assets.yourusername.plist" (this is an iWeb preferences list that somehow guides the publication process). MOVE THIS FILE TO YOUR DESKTOP (removing it from your iWeb Domain file but preserving it "just in case.")

    4. PUBLISH ALL TO .MAC: Under the File menu, select Publish All to .Mac. This should upload all your files and, more importantly, give your iWeb Doman file a fresh relationship with the published files on your iDisk. Note: It took me two tries but finally worked. First time I Published All at this stage I got an error message. Second time worked. Why? No idea.

    Message was edited by: Folklorist
  • Daniel Kiechle Level 1 Level 1 (90 points)
    It looks like my problems have just gotten worse...

    Anyway, I had the problem that I couldn't update my iWeb site any more. The program went through the motions, but the changes (such as correcting typos on photo captions) never made it to the web, and yes, I emptied caches, used different browsers on different machines, some of which I had never used to access my web site, and so on and so forth.

    I tried the solution you got from the Applecare techie; in short, I followed your 4 point instructions to the letter (and boy, manually deleting files from the iDisk took a LONG time!). The Publish All to Dot Mac took a little over an hour; everything seemed to work fine. I got the usual notice that things would continue in the background and that I could continue working (I didn't; I left the Mac alone and used my MacBook Pro while the desktop was uploading files).

    At the end, I got the error message to the effect that a problem had occurred. No sweat, I though, it happend to Folklorist as well, so I half expected to see the error. In my case, though, the error persists, and I am now totally unable to upload my site. I went from a web site with ~500 photos, a half a dozen of which had typos in the captions, to nothing, nada, zip, zilch, rien, niente, nichts. I'd love to know WHAT iWeb is doing when it seems to upload files to the iDisk. I mean, stuff IS being uploaded according to Menu Meters, but where to? No idea. Nothing ever shows up on the iDisk.

    I have a backup of my domain file, and I have a local copy of the web site (publishing to a folder works fine). Is it possible to simply copy the local folder to the appropriate place on the iDisk? Does anyone know what triggers the error at the end of the publishing operation? Or does anyone have a clue how I can start from scratch, meaning, how can I pretend that I have never used iWeb before and now want to publish it to my iDisk for the very first time? Surely that has to be possible?

    Just to be complete, let me say that I did not upgrade an existing site; I created one from scratch using the new version of iWeb that comes with iLife 8. I can't remember ever having been so frustrated with a computer that wasn't running Windows! What on Earth is going on here? And seeing the number of people who are complaining about iWeb issues and realizing that this forum is part of Apple's support, would it be too much to expect some Apple support people to actually take a look every once in a while and get back with some tips on how to solve these problems?

    In the meantime, I'm open to any and all suggestions; thanks in advance to any kind soul willing to help solve this issue. I really do want my iWebsite back.

    Sigh...

    Daniel
  • Daniel Kiechle Level 1 Level 1 (90 points)
    I still could not update my website, so I did a fresh "Publish to folder" and used FTP client Transmit (http://www.panic.com/transmit) to copy the result, i.e., one folder and an index.html file, into the Sites folder (located inside the Web folder) on my iDisk. Why use Transmit? Because for some reason, the Finder is excessively slow to copy files to and from the iDisk. Transmit is a bit speedier, though still takes a long time.

    When I was done, I opened iWeb, and after a pause of about 30 seconds, it opened with all the icons on the left in blue, i.e., up to date. I then launched Safari and accessed my site, and lo and behold, it was there. I still cannot change anything; as before, iWeb goes through all the motions, but no modifications end up on the iDisk. Unlike before, I am not getting an error message; instead, everything looks perfectly normal, as though the changes had made it to the iDisk.

    The procedure of using Transmit to make changes is a very poor workaround at best. I can use the Synchronize feature of Transmit to change only those files that have been modified, but the problem is that iWeb regenerates so much every single time one publishes (to folder or otherwise) that there are huge numbers of files that need to be transferred. In other words: it's good that the site is back up, but it's best not to update it until someone finds a solution to this problem or Apple publishes an iWeb update that fixes things.

    Now I have to see if I can do something similar to restore my Galleries which have suffered the same fate. That, however, is a topic for the iPhoto forum.

    Daniel
  • go-dons Level 1 Level 1 (10 points)
    Daniel, I have also tried to use Transmit but couldn't find the correct address to use for .Mac. I just assumed that it was impossible to use FTP to upload. Could you tell me how you set up Transmit to work. Thanks.
  • Daniel Kiechle Level 1 Level 1 (90 points)
    You're right: it's impossible to access iDisk with FTP as far as I know. You have to use WebDAV. To configure Transmit to access iDisk, create a new "Favorites" item and configure it as follows:

    Nickname: whatever you want it to read in the list, e.g., My iDisk
    Server: idisk.mac.com
    User name: yourusername (whatever you have before the @mac.com)
    Password: your dot mac account password

    Then, in "More Options"

    Port: 80
    Protocol: WebDAV
    Remote path: /yourusername

    I have the rest blank, except for the fact that "Use passive mode for data transfers" is checked.

    Cheers,

    Daniel
  • go-dons Level 1 Level 1 (10 points)
    Brilliant!

    Thank you very much. I got close to putting in the right information before but never close enough.

    Merci beaucoup!

    Gordon

    ps If you are a rugby fan. Congratulations to France!