Previous 1 2 3 Next 41 Replies Latest reply: Jan 7, 2009 3:07 PM by bokbok Go to original post
  • funrun_9602 Level 1 Level 1 (0 points)
    I have an iPod touch that just did exactly the same thing. It synced fine the first two days I had it, then a week later whenever I plugged it in I immediately got these "syncing cannot be enabled" errors. iSync would be frozen if I tried to open it. Since I was only trying to sync my calendar I did not realize (until I read this thread) that it was only the iApps in the Info tab that would not sync.

    I spent 2.5 hours on the phone with Apple tech support. I got passed from the iPhone/iPod touch support to iApps support to "Tier 2 Product Specialist" iPhone/iPod touch support. Along the way they mentioned something might be wrong with my Sync Services folder, but they never told me to do anything to it. They left me saying I needed to use my install disk to run Disk Utility repairs and that they had submitted a report to "Engineering". In other words, they were out of ideas.

    When I later realized I didn't have my install disk anymore, I went Googling for my own answer. This thread was the only answer I found, THANK YOU!

    I called back my tech support guys's direct number and left him a message that other people have the same problem and the answer is here on the Apple forums. Hopefully other people will not have to waste the time I did.

    *I have one additional tip on the saving instructions:* the "Home" directory I thought meant my user account folder with the house icon, but removing the Sync Services folder there did not help. I also found a Sync Service folder at my hard drive>Library>Application Support>Sync Service. I put this one in the trash too. Then it was fixed!
  • Dimbit Level 1 Level 1 (0 points)
    I am having the exact same problem. I have deleted both folders but it still does it
  • HP Praha Level 1 Level 1 (0 points)
    Great, thanks a lot! It worked for me perfecty! Just to be sure, after moving the folder, I restarted. Jan
  • j3rry Level 1 Level 1 (0 points)
    this worked for me too! after I logged out and back in
  • Kuyper Level 1 Level 1 (0 points)
    I trashed the iSync folders in my home library>application support and on my hard drive library as well. It didn't work.

    I noticed that iTunes does not show my recent address groups, but those of maybe one year ago. Wherefrom does iTunes draw these groups? the same thing is true for iCal. Some feeding file must go in between iTunes and the other iApps with the result, that iPhone is fooled with this message sync cannot be enabled ...

    Any answer out there?
  • unempldnow Level 1 Level 1 (15 points)
    Thanks for the advice. I spent the better part of the day with Apple reps (4). I still had problems syncing my contacts. Followed your suggestion and it worked.
  • BetsyEtsy Level 1 Level 1 (0 points)
    Hey!

    I was having the SAME problem with my MacBook Pro and brand new iPhone.

    This "moving the SyncServices folder and restarting" idea worked like a charm for me!

    I only did it last night, so I don't know how long it will last, BUT, it's safe to say that you SAVED my evening!!! I was getting extremely frustrated, and happened upon this info just in time.

    THANKS!!!
  • Laminar Level 1 Level 1 (0 points)
    After a two attempts Stephen Dunn2's procedure worked for me. I struggled about two week with this problem and my MBP was extremely slow from time to time. Not only because of SyncServer I think because sometimes SS was not active and still the Mac was very slow.
    I could neither sync with my iPhone nor with .Mac.

    In the old SyncingClients.plist was still my old cell-phone listed.
    I had a Folder SyncServices AND a folder SyncService. I removed both.
    Could one of those above be the cause?

    Gee, I'm so glad!!! Thanks to Stephen!
  • Laminar Level 1 Level 1 (0 points)
    I remember that removing all of a trial version of iSticky one of my last actions was before I carried out Stephen Dunn2's procedure.
    Does anybody use this app here?
  • London SE1 Level 1 Level 1 (0 points)
    Very helpful indeed -- that does the trick. Thanks.
  • ShatterdRose Level 1 Level 1 (10 points)
    Seriously, wow, worked like a CHARM! For only having 1 post, you were a life saver!!!!! Just remember to restart your computer, open iTunes, iCal, Address Book, and Mail, Quit iTunes and reopen it. Works beautifully!!!!!!
  • pioneerprodj Level 1 Level 1 (0 points)
    thank, worked for me =]
  • Westyle Level 1 Level 1 (0 points)
    This works!!! Its easy!!! I tried another solution from another post in this forum which was reapiring permissions and restart and that did NOT work. SO I was scared, but in typical mac fashion the bizarre quirk was easily fixed by removing the sync services folder.

    I moved it to the desk top
    reopened itunes
    selected the boxes I wanted to sync from the info page
    voila!w
    new sync services folder was automatically created and my sync worked fine after that!
  • Katie Floyd Level 2 Level 2 (325 points)
    For some reason with the MobileMe transition my sync services got all out of whack. The "sync" tab in MobileMe was grayed out and I couldn't sync ANYTHING on my computer. Though this same tip did the trick.

    Just for good measure, I also repaired my disk permissions and reinstalled iTunes 7.7. But I don't think any of that helped.

    Thanks!
  • Blueslover Level 1 Level 1 (0 points)
    I had the same problem, but thanks to your solution everything syncs again.
    Thank you!