Previous 1 2 3 Next 41 Replies Latest reply: Jan 7, 2009 3:07 PM by bokbok Go to original post
  • discussed Level 1 Level 1
    I was having the same problem today with 10.4.11 and an iPhone 3G. Followed these steps and everything is working great. Syncing with my MobileMe account is working now too. Thanks for the help!
  • vito parisi Level 1 Level 1
    I have the same problem.

    It doesn't sync address book and ical. It doesn't even recognize I have more than one calendar or group!!

    Instead it works fine with music. I

    I'm trying now the trick and it works!!!
  • tnuts&bolts Level 1 Level 1
    Go Head Steven Dunn2 ....... Thank God for people like you ..... it worked
  • Torben Seebach Level 1 Level 1
    I also deleted the folder "Sync Services" from ~/Library and restarted my comp. When rebooted I noticed my sync service going crazy and connecting to se how my dock should look like etc. In the system preference for MobileMe I had to remove this computer, because the old instance of it seemed to be screwed.

    Afterwards everything was fine again, and my computer is back to normal speed after being very slow for the last 14 days.
  • Jacob Weber Level 1 Level 1
    Just a warning: this Apple Knowledge Base document strongly warns you not to delete the SyncServices folder:

    http://support.apple.com/kb/HT1865

    In fact, it actually says, "As if it were a swarm of bees, you should stay away from the SyncServices folder in Mac OS X." No kidding.

    For what it's worth, I got the same error after installing OS 10.5.5 and syncing my iPhone. But it didn't happen again after I quit and re-launched iTunes.
  • Elizabeth2004 Level 1 Level 1
    It works for me too. Before moving the folder, I tried to open iSync and it would open (something about not being able to find sync server). Afterwards it opened up ok. Mobile me sync still looks a bit strange (when I search on-line in contacts that were updated with the most recent sync, I get a script error) - but I am sooo happy that iPhone syncs again. Thanks for sharing your solution!
    Anabel
  • acedtect1 Level 1 Level 1
    Worked like a charm for me too.

    I'll add that this error cropped up for me after I accidentally plugged in my wife's iPhone to my computer while iTunes was running.
  • Frederick Avolio Level 3 Level 3
    I think the correct and less drastic measure is to fire up iSync, go to Preferences, and under Advanced, click Reset Sync History.

    The next sync will take a bit longer, but no data will be lost.

    -fred
  • swillsmac Level 1 Level 1
    absolutely brilliant stephen .....why couldnt the yahoos at apple figure this out when i called them??

    THANKS AGAIN!!!
  • Webdaddy Level 1 Level 1
    WORKED PERFECT! Thanks alot. This was driving me NUTS. Nice work and thanks for the great solution.
  • NicoMonkey Level 1 Level 1
    I have had this problem ever since getting my iPhone three months ago (! - I have been a bit slow in getting round to curing it). I also had the 'Greyed Out' Sync tab in MobileMe prefs.

    For what its worth, I removed the SyncServices and followed other leads about repairing permissions, all to no avail. Having read Jacob's advice to '+stay away from the SyncServices folder in Mac OS X+' I used iSync (a long abandoned app..!) and pressed '*Reset Sync History*' in the iSync prefs.

    This worked perfectly, allowing me to sync all i apps to the iPhone and enabling the machine in question to sync with MobileMe after many months.

    All in all, I wish I'd tried that particular solution ages ago.

    Hope this helps.
  • bokbok Level 1 Level 1
    HI -
    i am having the exact same problem you are: syncing of calendar, address book etc does not work

    HOWEVER, I just tried your fix and there IS NO SUCH FOLDER in my Applications Support folder

    Any ideas what's going wrong??
Previous 1 2 3 Next