9 Replies Latest reply: Feb 24, 2008 1:56 PM by sperkins921
ukcatsrul Level 1 Level 1 (0 points)
Has anyone gotten email from mediacom to work on their iphone? Thank you.
  • prewitt83 Level 1 Level 1 (0 points)
    This is the problem I was having:
    I was able to receive mail, but was unable to send it. When attempting to send mail I got an error that said:

    Cannot Send Mail
    The connection to the outgoing server "mail.mchsi.com" failed.

    I found a solution here: http://docs.info.apple.com/article.html?artnum=305634

    Here is what I did in Windows XP (sorry I don't own a Mac):
    1. Set up the email account in Outlook Express.

    2. Connect the iPhone to the computer and open iTunes.

    3. Under the "Info" tabs Check the "Sync selected mail accounts from Outlook Express".

    4. Click the "Apply" button.

    Then after the sync my email works perfectly.
  • prewitt83 Level 1 Level 1 (0 points)
    ...perfectly over my home Wi-Fi newtwork connected to Mediacom. You cannot send emails if you are away from your Mediacom network (e.g. via EDGE or *other Wi-Fi networks not connected to Mediacom).

    *not tested

    Read this for more information: http://docs.info.apple.com/article.html?artnum=305634
  • clospjr Level 1 Level 1 (0 points)
    How did you get your I phone to work as this link you have did not help me.

    I still cannot send e-mails from my Mediacom account.

    I have tried SSl server port 995 and 465 and I have tried Non SSL 110 and 25 and they all fail. The error is the same error you wrote.

    Does anyone know how to send emails from a mediacom account as receiving e-mails are coming in fine?
  • clospjr Level 1 Level 1 (0 points)
    Yes, but only incoming.

    Set your incoming server port to 995
  • DLThompson Level 1 Level 1 (0 points)
    I think I have finally found a solution to this problem. At least, it works in my case. After monkeying around for literally two days adjusting the POP settings to try to get it to work with my Mediacom mail account (mchsi), I gave up and went another route. What I found is a very acceptable work around. Here's what you do:

    1) In Google (gMail): Sign up for a free gMail account with Google.
    Change the settings in gMail (go to Settings, Accounts) and change the "Send Mail as:" to your mediacom e-mail address. This is so that if someone replies to an e-mail you have sent with your iPhone, the reply will be sent to your regular e-mail address, not the gMail address. Also, instead of just typing in your name in the name field, I would suggest typing in "(your name)'s iPhone" This is purely cosmetic, but it cuts down on any confusion from people who will be getting e-mails from you on your iPhone and don't recognize the gMail e-mail address, because gMail will send the email with "From: Joe Cool's iPhone [mailto:joecool@gmail.com] On Behalf Of Joe Cool." After you have provided your Mediacom e-mail address and name, gMail will send you an e-mail to verify that you do own that account.

    2) In Mediacom:
    Set Mediacom to forward all incoming mail to your gMail account. I set mine to also retain a copy of the mail in the inbox, that way I can still retrieve e-mail from my home computer.

    3) On your iPhone:
    Set up a new eMail account, using the pre-programmed gMail settings. No advanced settings are necessary.

    Now give it a try, and see if you can't send and receive e-mail from your iPhone, OUTSIDE of the Mediacom network. It should work seamlessly with your e-mail account, just the way it was supposed to in the first place, and so far, knock on wood, I haven't gotten another of those annoying "was not downloaded from the server" messages. Hope this helps.

    Now go to the "Forwarding and POP/IMAP" settings and check the box next to "Enable POP for mail that arrives from now on." If you don't do this, your iPhone will not be able to access your gMail account. You also want to select "delete gMail's copy" when messages are accessed with POP. Otherwise, you'll have to worry about filling up your gMail inbox, unless you want to have to manage two e-mail accounts, which you don't. Under "Accounts" in the settings (still in Google's gMail) you might want to
  • DLThompson Level 1 Level 1 (0 points)
    Yikes...I was in a hurry to make that last post and didn't proof read before uploading. Obviously, that last paragraph that starts with "Now go to the "Forwarding and POP/IMAP" settings" should have been included with instructions for gMail. Here it is again in the correct order:

    1) In Google (gMail): Sign up for a free gMail account with Google.
    Change the settings in gMail (go to Settings, Accounts) and change the "Send Mail as:" to your mediacom e-mail address. This is so that if someone replies to an e-mail you have sent with your iPhone, the reply will be sent to your regular e-mail address, not the gMail address. Also, instead of just typing in your name in the name field, I would suggest typing in "(your name)'s iPhone" This is purely cosmetic, but it cuts down on any confusion from people who will be getting e-mails from you on your iPhone and don't recognize the gMail e-mail address, because gMail will send the email with "From: Joe Cool's iPhone mailto:joecool@gmail.com On Behalf Of Joe Cool." After you have provided your Mediacom e-mail address and name, gMail will send you an e-mail to verify that you do own that account.

    Now go to the "Forwarding and POP/IMAP" settings and check the box next to "Enable POP for mail that arrives from now on." If you don't do this, your iPhone will not be able to access your gMail account. You also want to select "delete gMail's copy" when messages are accessed with POP. Otherwise, you'll have to worry about filling up your gMail inbox, unless you want to have to manage two e-mail accounts, which you don't.

    2) In Mediacom:
    Set Mediacom to forward all incoming mail to your gMail account. I set mine to also retain a copy of the mail in the inbox (keep a local copy), that way I can still retrieve e-mail from my home computer.

    3) On your iPhone:
    Set up a new eMail account, using the pre-programmed gMail settings. No advanced settings are necessary.
  • DLThompson Level 1 Level 1 (0 points)
    Here's an update to my post of nearly 2 weeks ago. Since setting up my Gmail account, I decided to give IMAP a try. If you aren't familiar with IMAP, here's something I found on downloadsquad.com:

    "Why is IMAP integration a good thing for Gmail? POP was a stepping stone, but IMAP pushes Gmails benefits over the top. With IMAP, users can now access their email via a desktop application like Outlook or Thunderbird, read emails, make changes, delete, and have the changes made across platforms. So if you now log into your Gmail account, the message which you read in Thunderbird, will now be marked accordingly. No more wasting time trying to sift through emails that had already been answered."

    Sounded good to me. So I took the plunge and set my iPhone up with IMAP. Google even has complete instructions for setting up your Gmail IMAP account on your iPhone. Here's the link:

    https://mail.google.com/support/bin/answer.py?answer=77702

    Follow the instructions, and you'll be up in no time. I am SO glad I did this. I am e-mailing from my iPhone as I had always wished I could. It's a dream. All of my mediacom e-mails now go straight to my Gmail account, and when I reply to anything, it shows my mediacom e-mail address in the from field. It's completely seamless with my Mediacom account.

    As a side note, I finally decided to go back into my Mediacom settings and change it so that it would NOT keep a local copy. What that means is that all of my e-mail is going straight from Mediacom to Gmail. I don't get anything directly from Mediacom anymore. Why do I want to go through everything twice? The only thing I was having a little trouble with (not trouble really, just a hang up of mine) was that I like to keep a local copy of some of my e-mails on my PC. Many times over the years I've had to go searching through e-mails more than a few years old to find something for reference. I solved that hang-up tonight by finally switching my Outlook e-mail client (on my PC) over to IMAP as well. I need to point out that since my last post, I hadn't been using Outlook at all. I was using Gmail online for all of my e-mail needs. However, I just feel better being able to save certain e-mails on my PC for future reference. After I switched the account settings in Outlook over from POP3 to IMAP, it took a few times of sending/receiving (and even closing Outlook once and opening it back up) before all of my folders on Gmail appeared. But they are there. And when I move something to a particular folder, it also gets moved online. And vice versa, if you can believe it. Here's a link to setting up your Gmail IMAP account with different clients:

    http://mail.google.com/support/bin/answer.py?hl=en&ctx=mail&answer=75726

    If you have trouble with your Outlook slowing down while using the IMAP protocol, see this article:

    http://www.labnol.org/software/tutorials/solutions-for-slow-gmail-imap-with-micr osoft-outlook/1761/

    Don't forget, in order to be able to use IMAP with your Gmail account, you have to go into Google's Gmail settings, and click on Forwarding and POP/IMAP, then under IMAP Access, click Enable IMAP.

    So back to the original question again, maybe it's a round about way to get Mediacom's e-mail working with the iPhone, but in truth, it's a far better solution than "just getting mediacom to work." I hope you'll find this solution more than satisfactory.
  • sperkins921 Level 1 Level 1 (0 points)
    I was able to send emails over edge and other WIFI before the update but not since it. It's pretty frustrating.
  • sperkins921 Level 1 Level 1 (0 points)
    edit:

    it works again. outgoing server port changed to 587, from 465.