6 Replies Latest reply: Nov 7, 2007 7:31 AM by tdonald
keithlaurence Level 1 (0 points)
My USB mouse has suddenly stopped dragging & dropping files. It's ok within some applications, i.e. moving graphics around a document or audio files within Logic, but I can't drag documents from one folder to another, or off the desktop into folders etc.. I have to cut & paste. The track pad is the same. It seems to do everything else it's supposed to. Any ideas?? Have I accidentally deleted a driver file or something? Thank you in anticipation.

Powerbook G4, Mac OS X (10.2.x), 1Ghz Power PC
  • The Bohemian Level 3 (525 points)
    Hi, Welcome,

    Let's start here...
    In System Preferences under Keyboard/Mouse, look in Trackpad. There you should see Trackpad Gestures... Do you have Dragging and Drag Lock checked? All mine are checked except Ignore Trackpad when mouse is present.
    I have found if I remove an option from the trackpad, so goes the mouse. They mimic each other. So I have given full rights to both.
    If that is ok, post back and we will go from there.

  • keithlaurence Level 1 (0 points)
    Thanks for the response. Sadly I have tried these options previously with no luck. It's just a very strange thing.I can still move windows about and everything but neither the track pad or mouse will drag files. Problem is I have downloaded an software upgrade that requires me to drag the unzipped folder to the Apps directory and it just won't do it! Dare I say it I have tried most things in the Preferences to no avail.
  • theFireofGodsLove Level 1 (0 points)
    I'm having the exact same problem, with my trackpad and usb mouse, started this morning, so if you figure anything out, please let me know, I guess the easiest thing could be to just reinstal the OS, but I dont have a cd/dvd drive that works and no Apple store near me. Anyway, I'll let you know if I figure it too.

  • The Bohemian Level 3 (525 points)
    Hi again,

    Question? Do you have another USB port to try? Also, did you try pulling the mouse and using ONLY the trackpad? Did you try and reload the mouse software? Do you have another mouse you can try and see if it does it? Have you looked in Sys Pref under Universal Access, under Mouse... are the Mouse Keys turned OFF?

    A few more things to try...

    Good Luck
  • keithlaurence Level 1 (0 points)
    Sorry, I have run through these suggestions but they have not worked either. As the previous post suggested, I have downloaded and reinstalled the OS 10.2.8 combo upgrade but this has made no change. (Although I didn't actually erase the existing drive) I have a 'normal' 1 button Apple USB mouse which doesn't require software. That of course is the great thing about our great computers just plug it in and you know it will work!. Perhaps there is a small driver file hidden somewhere which I have inadvertently erased? Don't know how this might have occurred. Can't see anything on the Apple site for this type of problem. Are there drivers for normal mice.

  • tdonald Level 1 (0 points)
    I've been having the same problem.

    After a full restart, it goes away but seems to recur sometimes after going to sleep. I've been wracking my brain and looking for patterns of software used on the occasions when it seems to occur, but nothing yet.

    Have tried the kind help offered here - any more ideas?