6 Replies Latest reply: Jan 7, 2008 8:59 AM by Jan Anderson
KrayZ Level 1 Level 1 (0 points)
Not sure if this should go here or in user management, but I will start here.

I have one computer on my network (Network user accounts), and it doesn't matter what printer is added to Printer Setup Utility, when you go to print the dialog comes up that it is preparing, then immediately displays a dialog that says "Print, Error while printing.". Thats it, no codes no nothing.

I have tried resetting the print centre, as well as deleting prefs for printers and print central and removed everything from ~/Library/Printers but this error persists.

Has anybody seen this before?? Is there a solution for it?

Many, Mac OS X (10.4.8)
  • PAHU Level 6 Level 6 (15,335 points)
    Have a look at the cups error log for more details about why this error is occuring. You can find the log via the Console application. Expand /var/log and then expand cups to see error_log. You should see an entry starting with E (indicating an error) and the process ID for the plugin/filter that failed. Then browse back up the log to see which process it was.
  • knguyen Level 1 Level 1 (0 points)
    Have you tried this?
    http://docs.info.apple.com/article.html?artnum=107396

    I had the same problem with 10.2.8 and this document was my solution.

    Khang
  • Zacharias Beckman Level 1 Level 1 (100 points)
    I'm having exactly the same problem. I've tried the /tmp folder fix, and I've also run Disk Utility's repair permissions, and still no luck. I've deleted printers, added printers, checked the /var/log/cups/error_log, and found nothing -- absolutely nothing -- indicating there is a problem.

    However, any application that tries to print (either to a printer, or to a PDF file using Save As... PDF...) results in the Print: Error while printing alert.

    Please help!
  • bssackma Level 1 Level 1 (0 points)
    I have this exact same problem (unfortunately no solutions). The problem only appears to have affected 1 out of 5 identical iMacs? I cannot print (or save to .pdf) to any of the printers, reinstalling drivers did not help. I have reinstalled the 10.4.10 update with no improvement.
  • Bryan Bostrom Level 1 Level 1 (0 points)
    Have you been able to figure out this problem yet? I am having the same problem. I can print a test page but can't print out of any applications.
  • Jan Anderson Level 1 Level 1 (30 points)
    Same problem here, have tried DU and the Printerrepair utility at:
    http://www.fixamacsoftware.com/

    If I reset everything, I can make pdf:s If I then reinstall HP drivers and create a printer the problem reappears....

    Anyone with a fix?

    best
    Janne A.