2 Replies Latest reply: Sep 21, 2007 10:06 AM by ServerGeek
ServerGeek Level 1 Level 1 (0 points)
All,

I am in the process of replacing xftpd with vsftpd on 10.4.10 Server for preformance and stability reasons. However, I am having a heck of a time getting it to run via launchd. (too many years in xinetd i guess...) I was hoping that someone could give me a hand or atleast a point in the right direction.

Below is my config file (ftp.plist):
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Label</key>
<string>com.gnu.vsftpd</string>
<key>ProgramArguments</key>
<array>
<string>vsftpd</string>
</array>
<key>Sockets</key>
<dict>
<key>Listeners</key>
<dict>
<key>SockPassive</key>
<true/>
<key>SockServiceName</key>
<string>ftp</string>
<key>SockType</key>
<string>SOCK_STREAM</string>
</dict>
</dict>
<key>UserName</key>
<string>root</string>
<key>inetdCompatibility</key>
<dict>
<key>Wait</key>
<false/>
</dict>
</dict>
</plist>

And whenever I attemp to the ftp server i get the following error.
launchproxy[461]: execv(): No such file or directory

However cannot get past that point. Any help you can provide would be great.

<signature>
<name>J.M.</name>
<email>josh at moorej dot net</email>
</signature>

Xserve, Mac OS X (10.4.10)
  • Camelot Level 8 Level 8 (46,395 points)
    The most obvious problem is that you don't tell launchd what program to run.

    You do include a ProgramArguments tag, but the first entry is vsftp/

    If you're not including a <Progam> parameter then your ProgramArgument needs to specify the full path to the executable. As it stands, launchd has no idea where to look for vsftp and that's why it's failing.

    <key>ProgramArguments</key>
    <array>
    <string>/path/to/your/vsftpd</string>
    </array>
  • ServerGeek Level 1 Level 1 (0 points)
    Awesome, I knew I was missing something simple...