Previous 1 2 Next 23 Replies Latest reply: Apr 23, 2008 3:16 PM by Robert Ratcliff
sempersimul Level 1 Level 1 (0 points)
Hi! My speakers were working fine, then i plugged in headphones and the sound worked perfectly. I take out the headphones and there is a red glow where the jack is and all sound options for output are greyed out. Please help! I can't figure out how to get back my speaker sound

Macbook, Mac OS X (10.4.10)
  • Joel C. Level 6 Level 6 (15,915 points)
    Try inserting the headphones again. Give it a little wiggle back and forth (don't go nuts and really wiggle it enough to break it off). Might have to do it a couple of times. The MacBook uses an IR light to know when something is plugged into the jack and for whatever reason it still believes there's something plugged in. Might even try a different set of headphones if you have some.
  • Ray Wert Level 1 Level 1 (0 points)
    I'm having a similar problem -- the internal speakers are not working. It shows "No" sign (i.e. a circle with a slash through it) when I press the volume up or volume down buttons -- and there's no change in the level of sound graph on the screen.

    I can use my headphones just fine, but when I unplug them, it's like the MacBook can't find the sound card or speakers. Also, the red IR light is shining from the headphones jack.

    I tried wiggling the headphones in the jack -- no dice...
  • Grant Grueninger Level 1 Level 1 (120 points)
    I had the same problem. I believe the "IR" light is actually the digital optical output light (hint: you can't see InfraRed aka IR). I inserted a digital optical cable into the jack, waited a few seconds, and removed it. This solved the problem for me.
  • citoplasma Level 1 Level 1 (0 points)
    i had the same problem. well it happens once in a while. try to wiggle a toothpick softly (but at the same time don't be afraid to do it if you know what i mean) between the 3-5 o'clock position.
  • Julian W Level 1 Level 1 (0 points)
    I'm currently having the same problem. I tried to wiggle it around and it didn't work. Should I just bring it into an apple store?

    When I don't have the speakers plugged in, in the sound controls it says "Digital Audio". Last I remember that is not the same as it used to be.

    Please help!
  • bama78 Level 1 Level 1 (10 points)
    I have to say that plugging in a separate powerless speaker jack, my headphones, solved the issue. My theory/ASSUMPTION is that my external speaker power supply (pulling from a 220V wall plug and converting to 110V via transformer...Europe) or maybe even the computer power adapter (pulling straight from 220V) could have caused the issue.

    When my JBL Creature II speakers are plugged into the sound port and no music is playing, there is a wonderful hum that didn't exist in the states. Often a hum can signify arcs of electricity in a connection somewhere when only power source energy is passing through and nothing else. Still in theory, the arcs could be generated by the beefed up voltage/amperage over here (although I'd like to think the Cupertino girls and boys would have saw that one coming) and triggered the optical sensor.

    My Sound Preferences registered a only a Digital Output device with no volume control during the problem and would not permit a mute option. After inserting the powerless heaphones jack, they now register the Internal Speakers and eveything is back to normal.

    And, uh, easy on that toothpick advice. That red light is there for a reason.
  • Quimbisero Level 1 Level 1 (0 points)
    I have been having the same problem ever since I used a third party set of earplugs in my MacBook. While I have been able to get the light to go out, it hasn't helped. Every time I go to use an application that has sound output, whether iTunes or even just the sound control panel, the red light goes back on and the internal speakers will not work.

    When, oh when, will Apple fix this? Apple really needs to rethink it's support. With Kubuntu out there, there are fewer advantages to Apple. Real support (something Apple does not have) would keep me with them for a long time to come. I've used Macs since the MacPlus, but I'm getting tired.
  • Quimbisero Level 1 Level 1 (0 points)
    I assume the reason the red light is there is to say, "We gotcha!" It seems to me that this ought to be an easy software fix and don't understand why apple didn't make the selection between digital and analog user-designated like the selection for input. Of course, it may just be that that's another problem waiting to surprise me.
  • fabybaby Level 1 Level 1 (0 points)
    i had the same problem and i have tired all the suggestions above with no luck. i tried pluging in another speaker (a headset is what casued my problem) and powerd down the mac down, after power on the mac is off, i unplugged the speakers and turned the mac back on, still red light...i i hope this issue is resolved by apple soon - this is really a pain in the neck
    thanks all
  • shnugz Level 1 Level 1 (0 points)
    My Macbook just started doing this this morning and I've tried everything suggested on this page but with no luck. Has there been any word from apple on a fix?
  • jmcalister Level 1 Level 1 (0 points)
    Yeah my MBP is the same! I had a black screen earlier telling me to hold power button down (not sureif this is related). Turned off and back on again. A few hours later took my headphones out (basic iPod headphones) and wanted to play something over the speaker for others to hear only for it not too work and when I move the volume up and down it won't let me and all greyed out.

    I noticed the red light shining on the headphone jack, first time I've seen this at all, wasn't even aware it was digital output as well which is quite cool but not so cool that it seems to think there is a digital output on constantly.

    Tried wiggling headphone jack about as suggested here but each time I pull the jack out the red light comes on again.

    As soon as I pull the jack out I can momentarily adjust volume of main speakers then the red light appears again and options are greyed out!! Frustrating!

    Checked audio settings in System Settings with no joy it just shows options for output as 'Digital Out' no option for main speakers.

    Please help!
  • jmcalister Level 1 Level 1 (0 points)
    Ok a bit of research would have been good!

    I fixed the red light instantly by sticking a thin piece of plastic to the bottom of the jack. According to other posts who used a toothpick there is a switch which gets stuck. I didn't apply much pressure but the red light is off and internal speakers working again.

    Just incase anyone comes across this post first like I did try this out and hopefully works for you too!
  • TYMFTR Level 1 Level 1 (0 points)
    this has been happening with mine for about six months now. If I am using the speakers then the toothpick is the best option. otherwise it seems to sort itself after a couple of hours.
  • Floydius Level 1 Level 1 (0 points)
    I'm having the same issue here. Just thought I'd chime in with the hope that Apple will take notice. This issue has been reported on several threads here on the support forums and in several different forums on the net. Unfortunately, I've had no success with any of the suggested fixes. I've had my mac just over a year, so the warranty is out anyway. I took mine apart, in hopes that I would get a better look at the I/O port (mine is back together, and all is well, typing on it right now). Turns out the port is part of the logic board, so not sure if you could just replace the sound port itself. I've used toothpicks, compressed air, different jacks, and my optical sensor is still stuck. I've also reset the ram, etc, and as I said, even taken the thing apart. A simple solution to this would be an update in which the optical sensor can be ignored by the OS upon request. Unfortunately, Macs have no easily accessible BIOS in which to set the peripheral options. The only thing I haven't tried yet is using an optical cable in the slot first (I don't currently have one). I'll give it a shot and report back if it is successful. Apple, please take notice and consider a software update so that the optical sensor can be ignored. This is easily done in linux (and I assume xp from bootcamp, from other posts), so it should be an OS X option.

    Message was edited by: Floydius
Previous 1 2 Next