14 Replies Latest reply: Nov 18, 2007 11:57 PM by magichefx
chadhauze Level 1 Level 1 (0 points)
I am unable to install any updates with the Software update. The files appear to download but just as it finishes I get the error:
"A networking error has occured: Error NSURLErrorDomain -1005 (-1005). Make sure you can connect to the Internet, then try again."

My internet is working fine. the following error is in the console log:
2007-09-27 21:54:11.681 Software Update[2388] session:product:061-3914 didFailWithError:NSError "Error NSURLErrorDomain -1005" Domain=NSURLErrorDomain Code=-1005 UserInfo={
NSErrorFailingURLStringKey = "http://swcdn.apple.com/content/downloads/06/22/061-3914/qdhhMV4sk5bZP3DCVynRyp PwWk7snXrbCY/MacBookProFirmwareUpdate.tar";
}


How can this be fixed?

Chad

MacBook Pro, Mac OS X (10.4.10)
  • mine9 Level 1 Level 1 (0 points)
    I have been having the same problem, I never did figure out what it was. I deleted prefs and caches, I replaced the Software Update application, nothing worked. It fails with the same error whether you just click the install button or if you try to download only or install and keep. After other issues appeared, I did a fresh install of Tiger and the problem was gone for a while. Now when I tried to download the firmware update, the problem is back. The update is reported as being 3.2MB in size, but after the download starts the total size is no longer listed and it only reports how much has been downloaded so far. I never noticed a problem like this before 10.4.10, but I'm not sure what else is there that could be causing problems. Disk Utility isn't reporting any problems and I don't see any other odd behavior at this time. As I mentioned earlier in the post, I had other problems the first time before I reinstalled. I don't know if it was related to this problem, but the system was acting very strangely. Random crashes, and windows and dialogs with incorrect text or strange graphics like a corrupted image where the normal error or status dialogs would be.

    !http://www.kd7bcy.com/images/apple/downloading.png!

    !http://www.kd7bcy.com/images/apple/error.png!
  • baltwo Level 9 Level 9 (61,995 points)
    Are you connecting directly to the Internet or trying via wireless? Have you tried to download the updates via the Downloads link, above?
  • chadhauze Level 1 Level 1 (0 points)
    I was able to download the MacBookPro firmware update from the support download site. I am using a wired connection to my Internet gateway, which is a Sprint wireless connection.

    Chad
  • baltwo Level 9 Level 9 (61,995 points)
    Then, I suggest you bypass the wireless portion (if possible) and see if SU works. I don't do any wireless, but recall seeing problems when attempting to do software updates through wireless connections.
  • FIshOutaaWater Level 1 Level 1 (0 points)
    That's wild, because I'm using a Sprint wireless connection (EVDO) also, trying to update my iMac, and I'm getting this exact same error. I don't have access to a wired connection as I'm in-between places at the moment. Surely there's a work-around for this.
  • jjsmith_OH Level 1 Level 1 (0 points)
    Another *Sprint Wireless* customer - same exact error & issues. It's my only connection available. Please update this thread if anyone comes across the fix.
  • jjsmith_OH Level 1 Level 1 (0 points)
    I should add that in my case the files do actually download, but fail on installation. Software update doesn't seem to recognize they are coming down successfully though (status reads "downloading 3.2 MB of ----").

    I ran softwareupdate -d -a and verified with lsof that the files are actually being written in /Library/Caches/com.apple.SoftwareUpdate/content/downloads

    I've run diskutil repair permissions already. Any other ideas welcomed.


    $ softwareupdate -d -a
    Software Update Tool
    Copyright 2002-2005 Apple


    Downloading Front Row Update
    Downloading Front Row Update 0
    Package failed: Error NSURLErrorDomain -1005

    Downloading iMac EFI Firmware Update
    Downloading iMac EFI Firmware Update 0
    Package failed: Error NSURLErrorDomain -1005

    Done.
  • baltwo Level 9 Level 9 (61,995 points)
    Search these forums for *"NSURLERRORDOMAIN -1005"* and review the earlier posts. According to the NSURLError.h file, that error is:

    NSURLErrorNetworkConnectionLost = -1005

    As noted earlier, the problem's with the wireless connection. For those who can't hook up otherwise, find a friend, visit an Apple Store, or other Apple dealer with a direct connection.
  • ctmurray Level 1 Level 1 (80 points)
    I am having this same problem with iMAC G4 which is wired directly to internet. I can surf fine. Apparently I have not had an automatic update since August if I read the update log file correctly. I used network assistant and it says everything is fine. I rebooted and even got a new DHCP from the wireless router (but I am hard wired to this).
  • ctmurray Level 1 Level 1 (80 points)
    I forgot to mention I am not even getting to the download part. I get the error when it goes to check on the database at Apple.
  • ctmurray Level 1 Level 1 (80 points)
    I get a slightly different message: NSURLErrorDomain -1100 (-1100). Make sure you can connect to the Internet then try again.

    How do I include photos in this post? I have a picture if needed.
  • FIshOutaaWater Level 1 Level 1 (0 points)
    I was able to download the latest iTunes to my MacBook Pro using the same Sprint connection, copy it to a usb flash drive, then install it on the iMac G5 from there. It was successful. Strange but it was a work-around.
  • jjsmith_OH Level 1 Level 1 (0 points)
    SUCCESS!!!
    I am now able to download updates without the NSURLERRORDOMAIN -1005 error by UNchecking the box "Download important updates in the background."
  • magichefx Level 1 Level 1 (0 points)
    I have a Sierra Wireless AC595U Device from Sprint running on Intel Mac Pro OS 10.4.7, but the problem has happened on 10.4.8 and 10.4.9. So the issue is with Sprint wireless, because I continue to get the NSURLErrorDomain - 1005 messages when trying to update software. I too have no other way to be online, since I live in the woods/country. We should find a solution for this problem. I'm able to search the internet, watch videos and have no problems with the connection except for the message which occurs while I am connected and continue to be connected. If anyone finds or knows how to work around this problem will you please email me.

    Brendon Thompson
    Allways Creative
    Tulsa, Oklahoma US
    918 289 8470
    brendon@allwayscreative.com