11 Replies Latest reply: Jan 23, 2008 2:54 PM by bsnyder
SinclairZX81 Level 1 Level 1 (65 points)
My iPhone is now permanently stuck in 'recovery mode.' Retore fails with unknown error (9). Help.

PowerMac G5, MacBook Pro (Vista/OS X), Mac OS X (10.4.9), Sinclair ZX81, Dell Dual Xeon Tower
  • DavTravels Level 1 Level 1 (5 points)
    I'm having the exact same problem. I don't know what to do, as this is my only phone. iTunes is telling me that I'm required to click 'restore' and then it gives me the message:

    The iPhone "iPhone" could not be restored. An unknown error occurred (9).

    Does anyone know what this is or how to fix it? This is my only phone and therefore need the problem fixed. Thanks so much for your help!
  • Coyotesweat Level 1 Level 1 (0 points)
    We had this happen with one of our iphones, we disconnected it, rebooted, reconnected the phone, relaunched iTunes and were able to do a successful restore. It's worth a try. We did the update on an older iBook elsewhere, as our Internet is down at home. Not sure if that caused the problem or not.
  • SFS1169 Level 1 Level 1 (0 points)
    i was having the same problem with my phone, tried to restore over 30 times. Nope nothing worked, but i did change my usb connection from the two secondary ports in the front of my pc to a primary usb port in the back of my tower and the update took, not sure if this will help but its worth a try.
  • DavTravels Level 1 Level 1 (5 points)
    I tried both of those things and it didn't work. I guess I'll have to take it into the store on Monday? This stinks!
  • SinclairZX81 Level 1 Level 1 (65 points)
    Well I still don't know what "Unknown error (9)" is and neither did the Apple Store "genius", but I do now have a brand new iPhone! Thanks Apple Store Genius!
  • Shastde Level 1 Level 1 (0 points)
    My Iphone is stuck in error 9, too. It also say's, I need to activate my phone; as if I just bought it. This happened after I plugged it into my computer to charge up my battery, from there I decided it would be a good idea to update the phone since Itunes provided the option... apparently not.
  • Shastde Level 1 Level 1 (0 points)
    I fixed the problem. After ejecting the phone from the Itunes, then plugging it back in to restore it... my phone went through this process and activated as new with out a problem.
  • gdudek Level 1 Level 1 (0 points)
    In my case this was caused by bad disk permissions, specifically in the folder ~/Library/iTunes/iPhone\ Software\ Updates/

    At least after fixing the permissions on my Mac the problem went away for me.

    It appeared that iTunes was unable to verify the software after downloading it.
  • MrKa Level 1 Level 1 (0 points)
    Hi, I am also having the same error when trying to restore.

    My phone went on a black permanent screen, and iTunes does not detect the phone unless I use the sleep + home button 10 sec. and then only home another 10 sec. to restore.

    When trying to restore, itunes says Unable to restore iphone. Unknown error (9).

    Please help me!

    My email: chavakalifa@gmail.com
  • Brian Zaugg Level 1 Level 1 (0 points)
    I encountered the same "Unknown" error during my update to 1.1.3.
    The iPhone does not have enough free space to perform the update.

    For those encountering this error during a sync that is not related to an update, you'll have to check and see if your issue is related to free space.

    For me, the solution was:

    1) Choose to NOT sync content on the Music, Photos, Podcasts, and Video tabs. Click Apply.
    2) The iPhone should sync to a mostly empty state
    3) Click the Update button on the Summary tab
    4) At the conclusion of the update, re-select content on the Music, Photos, Podcasts, and Video tabs. Click Sync.

    -Brian
  • bsnyder Level 1 Level 1 (0 points)
    Got mine working….after 5 days.
    I was getting the Unknown Error (9). The restore attempt would never finish. I tried everything under the sun. Tried two different XP computers with the same result. Finally I got the bright idea to try it on my Mac. The restore took just fine. Then I went back to my XP computer and synced everything back. Might have something to do with Windows and the latest updates for iTunes. The iTunes on the Mac is not the most recent version but it did restore the latest firmware 1.3.