9 Replies Latest reply: Oct 16, 2007 10:44 AM by Mack90038
ksteryous Level 1 Level 1 (30 points)
After I updated to 1.1.1, I noticed my email wasn't working quite right, so I did a complete restore, and in the process of setting everything back up, I can not get my personal pop email account to work. After creating a new account with the "Other" option, I enter all the correct information, and when I hit "save", I get this message: Secure Connection Failed, Certificate for "Personal" may be invalid.

It then gives me the option to Cancel or Continue, but hitting continue just hangs. Any thoughts? It was working properly before the update, and my desktop client is still connecting and receiving emails, so nothing has changed on my ISP's end.

Thanks,
Kenton

PowerBook G4 | iMac Intel Core Duo | iPhone |, Mac OS X (10.4.10)
  • C Weems Level 1 Level 1 (0 points)
    Im having a similar problem after a restore too.

    During the upgrade to 1.1.1, my phone said the upgrade was unsuccessful and needed to be restored, so I did that. After recovery, I as then able to get mail. But once I started to send a message, I was not able to (sending out thru authenticated Earthlink account settings). I still cannot send, and recieveing (thru different mail account) is very spotty. Takes forever if it successfully checks at all. This is on edge and Wifi.

    Desktop mail with same settings works fine.
  • Eric Sartoris Level 1 Level 1 (5 points)
    Just wanted to add a "ditto" to the above posts. I cannot get any of my email accounts to work. I get this exact error message:

    "Secure Connection Failed - the certificate for name@domain.com may be invalid".
    I've tried three different email addresses through three different ISP's.

    Any ideas?
  • ksteryous Level 1 Level 1 (30 points)
    Ok...I finally got mine to work.

    First, I did a complete restore, even deleting the backup file in iTunes Preferences just to make sure that none of my old settings were copied back to the iPhone.

    However, I actually think that step was not necessary because I still got the same "Secure Connection Failed..." message when trying to create my POP account.

    But this time, I decided to tap "Continue" and just wait, and wait, and wait. I had always just given up before thinking it had stalled. But finally (after a really long time), I got a second message saying something to the effect that "SSL connection failed, would you like to try without it?" Tapped Yes, and again waited, and waited, but finally it worked.

    After researching some of the security updates in 1.1.1, I think it is defaulted to set up initially using SSL, and it just takes an incredibly long time to come back and give you the option to try without SSL.

    Whew!! This has been an adventure!

    PS...be sure to not let your iPhone turn off while your waiting, or it has to start all over. Just occasionally move your finger over the screen to reset the auto turnoff timer.

    Message was edited by: ksteryous
  • Eric Sartoris Level 1 Level 1 (5 points)
    Hi!

    I just came back to post the same thing.

    You just have to wait forever and then hit "continue" whenever prompted, making sure that the phone doesn't go to sleep in the meantime. Even the Geniuses at the local Apple Store didn't figure that one out.

    Seems to work fine now!
  • ScottRiggins Level 1 Level 1 (5 points)
    My phone is doing the same thing after the 1.1.1 update. This workaround doesn't work for me because I WANT/REQUIRE SSL encryption when I'm checking my email. I don't want to disable it as a workaround.

    Apple needs to figure this out ASAP as it has effectively removed secure email functionality from the iPhone!

    The SSL certificate hasn't changed...it was nicely sync'd to the phone when I originally activated it. Not sure what the 1.1.1 update has done to break it.
  • ScottRiggins Level 1 Level 1 (5 points)
    Given that other posts mention two prompts: first that "certificate may be invalid" and second "would you like to connect without SSL?" (paraphrase), I decided to hit "continue" on the first dialog and see what happened in my case. After doing so, I was NOT prompted a second time, so it would SEEM that my SSL connection completed normally after all. For others in this circumstance who require/demand SSL, you may want to try continue on the first prompt to see if it just works.

    By all appearances, I still have a secure pipe to my email. It's a shame that this prompt and the results of "continue" aren't better at indicating what the actual issue is.

    Note that in my case, I'm probably prompted about the certificate because I don't have a globally-signed SSL cert. I am just using one that I created myself and imported into the Mac OS X keychain. This cert was sync'd beautifully (thank you Apple!) to my phone originally, and appears to still be working. A check of the mail prefs on the iphone still show both inbound/outbound mail to have SSL "on" so it doesn't appear to have been disabled by 1.1.1 or by my pressing "Continue".

    I believe that this 1.1.1 update was a deep enough update of the OS that it is merely warning me again (in an unfortunately cryptic way) that the certificate is not signed by global cert authorities. I think it did the same thing when I first set up the iPhone (1.0) but hasn't prompted me again like this on any updates since.
  • jbihun Level 1 Level 1 (0 points)
    I still cannot use my corporate email. I did most of what everyone here has done. I reset it, I erased everything and reset it, I recreated the account. It worked for the first time after doing that but then stopped and complained that it is unable to verify SSL server. Even though I turned SSL off for inbound and outbound. If I reboot it, the phone will then take the SSL settings (off) and then complain that it just cannot connect to my (IMAP) mail server.

    WHAT GIVES? This is killing me.

    Jason
  • inco9nito Level 1 Level 1 (0 points)
    I am having the same issues.
  • Mack90038 Level 1 Level 1 (0 points)
    All - I was having exactly this issue with my private domain.com since the 1.1.1 update.

    I followed the suggestions of others which was to let it just sit there (it felt like it was hung) but it finally seemed to "go through" and connect. I think it even gave me the certificate error twice.

    I didn't change any settings or do anything special just sit there and wait. It took so long (maybe 5 minutes) that I had to keep touching the screen to stop it going into standby.

    Bizarre behaviour and you'd think Apple would have it set to NOT use the Secure setting by default.

    Oh well - at least its working for me now - I hope you get yours up and running soon!