Previous 1 2 3 4 Next 50 Replies Latest reply: Aug 13, 2008 1:04 PM by Ikester Go to original post
  • Eddie Strauss Level 3 Level 3
    To add to my comment above, I have two Macs. I try to keep their contents pretty much identical. This missing Helvetica font error message (even though the font is listed as being there) only occurs on one of the Macs.

    I replaced the Helvetica.dfont of the error computer with the font file from the non-error computer. No difference.
  • Robert Saecker Level 2 Level 2
    What is the current suggestion?


    See Lukas' post at the beginning of this topic.
  • Pat Gilmour Level 2 Level 2
    No fix for this in today's 1.0.2 Numbers release.
  • Pat Gilmour Level 2 Level 2
    However this might be interesting:

    Open TextEdit and take a look at your font list (press Apple+T)
    -I see only one version of Helvetica Neue

    Open Numbers and look at your font list
    -I see two versions of the font: Helvetica Neue and HelveticaNeue

    Any ideas?
  • Robert Saecker Level 2 Level 2
    You know, I hate to be repetitious, but: go read Lukas' post at the beginning of this topic. Do what he says; if that doesn't work, come back and let us know.
  • morph21 Level 1 Level 1
    Hi,

    Well, I tried to remove, reinstall, search my original Leopard DVD and so on, but the problem persisted. The solution? I googled a little and downloaded the missing Helvetica Narrow fonts.

    I don't know if there is any policy against external URLs on the forum, so if there, I'm sorry and I'll remove them, otherwise, just grab these fonts and install them:
    http://www.fontsitez.com/font_view/28334/Helvetica-Narrow.html
    http://www.fontsitez.com/font_view/28349/Helvetica-Narrow-Bold.html
    http://www.fontsitez.com/font_view/28353/Helvetica-Narrow-Bold-Oblique.html
    http://www.fontsitez.com/font_view/28338/Helvetica-Narrow-Oblique.html

    Hope it helps.

    []'s
  • Ifor Phillips Level 1 Level 1
    expertise.wireless
    Wireless
    Same problem - Helvetica subsitituted with Helvetica narrow when opening all iWork '08 applications.

    I read all the solutions in this thread and all seemed either too complicated or too dangerous for ignorant me. In the end have absorbed all the wise words I tried something really simple and it worked.

    Open the Font Book application and have a look at the Helveticas available in All and in User. I found that Helvetica was in all but not in User. I exported the Helvetica from All to my desktop and then added it to User.

    Problem solved.
  • Bill Fant1 Level 1 Level 1
    FINALLY!!!!

    Finally I was was able to resolve the font problem stated above.

    It seems iWork was locating and automatically opening a conflicting HelveticaNeue font that I had not added to Font Book nor any of the designated font folders. I found that it was even locating and opening a version that was located on a connected external drive. Once I deleted the font from my local drive and then ejected the external drive the error message went away.

    Lesson learned: Even though a font has not been added to Font Book nor installed into any system or user font folders, OS X and/or iWork may find and activate a font residing on any available drive.

    Why it opened HelveticaNeue elsewhere when it already had the one it needed within the system I do not know. I'm just glad I finally resolved the issue.
  • Bill Fant1 Level 1 Level 1
    Just to be clear (since this didn't post directly below my original message)...

    I was getting the following error message almost every time I opened an iWork template or file (specifically Numbers templates & files):

    +The font “HelveticaNeue-Roman” was substituted for the missing font “HelveticaNeue.”+

    I had even performed a clean install of Leopard and iWork, so I knew I had all the latest fonts needed by the system and apps.
  • Federico Reinfeld Level 1 Level 1
    I was having the same problem with Numbers (and Pages), getting the font substitution error when opening any file. Tried moving around fonts from-to Library/Fonts to no avail.

    Found on a Google search that Leopard loads any Helvetica font files present *ON YOUR COMPUTER & ATTACHED DRIVES*, even if they are not inside any active Font folder. I checked my backup Firewire drive and found some old Helveticas. Disconnected the drive and opened Numbers again, PROBLEM SOLVED!

    I made a CD backup of all those fonts and made sure the Helvetica provided by Apple was the only one on any of my hard drives.

    It has been working fine ever since.

    I hope these info helps you, it was driving me insane.
  • OrenR Level 1 Level 1
    That was easy enough. I tried to do all the cockamamie stuff suggested above and that dion't work. Simply deactivating n helvetica narrow in fontexplorer worked and I don't get the message when opening pages or numbers 08.

    Thanks!
  • Stephen Petit1 Level 1 Level 1
    You're God-sent. I had the same problem. Thanks to your suggestion, I found fonts from way back archived on my backup drive, including the offending Helveticas. Thank you for posting your solution here -- it certainly did help me.
  • Patrizia Franchini Level 1 Level 1
    *Didn't work:*
    I unmounted my external disks with the backups without any success

    *Did work*:
    Then I decided to throw away the font "N Helvetica Narrow" (found in Library/Fonts) and now I don't have error messages anymore. I couldn't move it from its location using the font book.

    -The error message was: "Helvetica missing and replaced by Helvetica Narrow"
    -My Hardware and OS: iMac Intel 24", 2.8 Ghz + Leopard 10.5.2, Keynote 08- 4.0.2 (demo).

    Message was edited by: Patrizia Franchini
  • turgemanster Level 1 Level 1
    NO ONE SEEMED TO NOTICE BUT...

    Bill Fant1 (look for posts above) SOLVED THE REAL ISSUE here, and i'm not sure how he did it, but he is 100% spot on.

    for some reason which i can not explain, iworks finds and 'accesses' (?!) fonts which are not activated and NOT EVEN STORED IN FONT FOLDERS of the user library, HD library, or system library. these can be anywhere on your computer... Bill Fant1 says it can even be on an external drive.

    THANKS Bill Fant1!!

    i can verify that removing these 'passive' fonts has instantly resolved the issue, showing there is a direct connection. why this happens is beyond me, it seems that it is like an auto font activation feature of iworks.

    does anyone have any suggestions? where do you store 'passive' fonts if they are going to get in the way of font seeking apple apps? or maybe it's a bug... can anyone confirm?
  • turgemanster Level 1 Level 1
    one more thing...

    if this is auto activation, it's likely not a bad thing except when it auto activates fonts like helvetica or gill sans which then conflict with the system fonts already activated.