Previous 1 2 Next 23 Replies Latest reply: Dec 5, 2008 10:14 PM by Saerain Go to original post
  • ffpsx Level 1 Level 1 (0 points)
    I figured out a solution to this problem. I am running the latest versions of iTunes on Windows Vista and iTunes keeps poping up and taking focus. I solved this problem by right clicking on the icon for itunes and telling it to "Run as administrator". After runnung it in administrator mode, the pop up problem went away. If you right click on any shortcut to iTunes and then click properties. You can go to the "Compatibility" tab and at the bottom there is an option to always run this application in administrator mode.
  • Minty95 Level 1 Level 1 (0 points)
    If i set mine on admin as it give me a error message saying that it has been configurer to run on an older version of windows ........ for best results the compabilité mode .... (sorry reading from a French system)

    If I run it in non admin mode all is well untill I start trillian and then it pops up every couple of minutes, No trillian and non admin mode all is fine or Trillian + admin mode with error message and all is fine

    I tunes with Vista is still pretty crap (Itunes I mean)
  • vfranklyn Level 1 Level 1 (0 points)
    I definitely think this has something to do with IM. I had my MSN messenger set to show song information and after I upgraded iTunes I had the same problem mentioned above. I removed the 'Show song information' from MSN messenger (Tools/Options) and I'm no longer experiencing that problem.

    This problem didn't start until I upgraded iTunes to v7.6.1.9. Bummer.
  • garlav Level 1 Level 1 (0 points)
    hey i run windows vista premium on my laptop and man this problem is so annoying.

    I got the exact same thing happening, I tried removing that musiclink program from AIM to see if it would stop, because I thought it could have been calling it up every 30 seconds....nope.

    Ran as admin...still nothing.

    Anyone got an idea?
  • Plethora Level 1 Level 1 (0 points)
    It's definitely because of Windows Messenger. I've been having the same ridiculously frustrating problem, and I tried turning off the "what I'm listening to" feature, and it stopped popping up all the time.

    Hope it works for you!
  • apglee Level 1 Level 1 (0 points)
    "It's definitely because of Windows Messenger."

    Except Winamp doesnt do it, Windows Media doesnt do it, nothing else does it, its an apple issue, frankly if I could use ANYTHING else to handle my ipod I would, adding tracks alone is a total pain, why cant itunes just monitor my music server like everything else does and not try to manage it ffs
  • JoeRip2 Level 1 Level 1 (0 points)
    I can tell you exactly why this occurs.

    Many applications that communicate with iTunes for Windows (like Messenger, and various other "add-ons" that control or display iTunes data) communicate with iTunes through the COM API.

    One of the iTunes settings you can control through the COM API is called ForceToForegroundOnDialog. This tells iTunes that if iTunes needs to get the user's attention, it should force itself to the foreground.

    For one or more reasons, iTunes thinks this value is true, and it will force itself to the foreground whenever it updates the status UI (the rectangular area in the middle of the top of the window).

    Either the "add-on" you are using has set this value to true, or iTunes has mistakenly read a corrupted settings file and thinks this value is true.

    What you need to do is either (a) get rid of the software that's forcing this value to true or (b) run a piece of code which can turn the value to false.

    I'm sure one of the wiz kids on this forum can come up with a little vbscript that does it.
  • chelsiia Level 1 Level 1 (0 points)
    I've had this problem too. but i figured it out.
    i installed a patch for my msn 7.5 & for some reason the
    "Turn on "What I'm Listening to" wasn't working ? but
    ever since i checked that & forgot about it, itunes would popup
    for no reason every 20 seconds. i thought it had to do with updates
    or something or uninstalling it but i was scared of losing my songs.
    then i unchecked the "What I'm Listening To" tab on msn & itunes
    has stopped popping up.
    so if your having this problem too, i suggest you click that off
  • Saerain Level 1 Level 1 (0 points)
    There are two ways to stop this without ceasing to use iTunes or Messenger.

    Either A: Disable Messenger's +'Show song information'+ feature. This will prevent Messenger from showing your iTunes song information and thereby stop making iTunes so nervous.

    Or B: Run iTunes with administrator privileges by right-clicking the EXE, selecting Properties, Compatability, and +'Run this program as an administrator'+. This will allow you to continue showing your iTunes song information in Messenger while satisfying iTunes' histrionic need for attention; but, annoyingly, iTunes mistakes administrator privileges for a compatability mode, so it will throw a compatability alert at you every time you start it. Nod, smile, click OK, and it runs fine.
Previous 1 2 Next