1 2 Previous Next 21 Replies Latest reply: Nov 28, 2007 6:51 AM by Angolan
Angolan Level 1 Level 1 (0 points)
Does anyone know how to rollback a firmware update for the MBP?
Apple did a terrible job on the EFI firmware 1.4 for the MBP and I want to get back to the 1.3 Firmware. Is it possible?
The 1.4 firmware messes with the Windows XP/Vista BootCamp installation: the screen is with”blue fuzz" and it happens with all MBP.
Any help would be much appreciated.

MBP Pro 17" ATI X1600, Windows Vista
  • 1. Re: Rollback Firmware Update on MPB
    umparrothead Level 3 Level 3 (535 points)
    I do not believe there is any standard way of reverting firmware updates. Just as a sidenote, though, you mention "it happens with all MBP", which simply is not true. Many of us on here had no problems with both the OS X and Vista partitions of our computers. There are other threads dealing with similar issues as you describe and you may want to peruse them to see if there is a fix (or even temporary workaround) for your problem.
    As a last resort, you could always call AppleCare or bring your MBP in to an Apple Store and have a Genius look at it.
  • 2. Re: Rollback Firmware Update on MPB
    gfsdcc Level 1 Level 1 (0 points)
    Sorry, but Angolan may be right. umparrothead, I see you have a last generation MBP, for which the 1.4 EFI update is not even applicable. There is a great number of messages on this forum that complain about the issue. As a side note, for many of us, Europeans, Apple is really a disappointment, both regarding quality and customer support. As another side note I believe that the impossibility to undo the EFI and other software updates it's plain stupid, and it doesn't happen in the PC world.
  • 3. Re: Rollback Firmware Update on MPB
    umparrothead Level 3 Level 3 (535 points)
    Again, I'm sorry for the problems you're having, but all I was trying to say was that even if a bunch of users on these forums are expressing discontent, it still represents only a small percentage of all the MBP users worldwide. Most people come here to talk about what doesn't work right, not what does. Hopefully you find some resolution to these issues, and I completely agree with you about the inability to remove updates.
  • 4. Re: Rollback Firmware Update on MPB
    Angolan Level 1 Level 1 (0 points)
    umparrothead, this is not a problem of a bunch of users. This is a problem of all MBP that had the EFI 1.4 firmware update, at least all that I know. If this not so, more reason I have to tell that this is not a Microsoft problem…
    Your MBP doest have this update because is a new version of the MBP. I agree that only a fraction of the MBP users has Windows XP/Vista installed with BootCamp. Many users do not complain in the forums, just because they don’t use them. The main problem is that Apple says that this is not their problem. Why they don’t cover this? If you were in my situation, what would you do?
  • 5. Re: Rollback Firmware Update on MPB
    neuroanatomist Level 7 Level 7 (31,690 points)
    And you, of course, have looked at Apple's list of build release dates, are aware that this firmware update applies to MBPs sold from 10/06 - 5/07, and have looked at Apple's sales figures and are aware that this update applies to perhaps 1.2 million MBPs. And your math skills are undoubtedly sufficient to calculate that if that "+fraction of the MBP users has Windows XP/Vista installed with BootCamp+" is a mere 5%, that's 60,000 users. I'm curious - how many of those ~60,000 users are in the group of "+all that I know.+"?

    If Apple releases an update intended specifically to fix issues with BootCamp (as EFI 1.4 is), they've tested it on MBPs with BootCamp. It *does not* affect all MBPs. But they can't test every possible user configuration, every haxie, and whatnot. So, as a result, there will always be some users with specific configurations that are negatively impacted by any update. Perhaps even "+a bunch of users+". Unfortunately, you seem to be one of them, and you do have my sympathy.
  • 6. Re: Rollback Firmware Update on MPB
    Angolan Level 1 Level 1 (0 points)
    neuroanatomist, you made your point about the numbers, but I must say that I know 6 persons with MPB, 5 of them applied the 1.4 Firmware and all of them have this problem. The other one has a new MBP. Statistically, it is small group, but 100% has problems. Just check the forum and you’ll find many messages about this. Not all of them address the problem correctly, because most of them think this a driver/bootcamp/windows problem. Maybe, just maybe, in Portugal we don’t have luck with the batch of MBP...
    Of course, I believe this does not affect all the MBP. When I said that, was of course a figure of speech, but I believe that if there are 60.000 users using Windows with this version of the MBP, a significant percentage has this problem. Of course that’s my feeling, I don’t have the numbers…
    You said that “Users with specific configurations that are negatively impacted by any update”. Well I must say that this problem doesn’t depend of any configuration. The problem happens with all BootCamp versions (yes I tried with 1.1 to 1.4) and it happens with a fresh install of OSX and Windows (I’ve tried with Windows XP Professional and Windows Vista Ultimate). The problem happens with the Windows and Linux Boot DVD, and at this point there are no drivers installed. The problem doesn’t happen with an external LCD. That’s why I think this is firmware related, and the new firmware messes with the Windows ACPI control. I can’t find a solution, even with PowerStripe software.
    The problem is that Apple support keep telling to call Microsoft, because this is not their problem. Terrible service, if you were in my position, what would you think about Apple support?
    Here in Portugal, if you say the magic word “BootCamp” in the support phone center you’ll hear this line: “Call Microsoft”, they just don’t care about it…
    I decide to call to Apple US support, and after 2 minutes they said the same thing, but I insist and them they put someone on the phone that really listen my problem. He made a search and he told me that they have many complains about this issue, and that Apple is going to fix it with Leopard and a new version of BootCamp, witch by the way will be not beta and have Apple support (good news). But how long do I have to wait? And I believe that only a new EFI firmware will solve the problem, because this happens with Windows Boot CD/DVD.
    They don’t know when Leopard is released and the new BootCamp (not beta). In the mean time I cannot work properly in Windows.
  • 7. Re: Rollback Firmware Update on MPB
    umparrothead Level 3 Level 3 (535 points)
    As you mentioned, BootCamp is still in beta, and will not be a full release version until Leopard. I do not believe forum rules allow me to speculate on release dates, but if you do a Google search for it, you'll find many rumors. Also, the Leopard website says that it's coming in October.
  • 8. Re: Rollback Firmware Update on MPB
    Angolan Level 1 Level 1 (0 points)
    Well, it seems that BootCamp (supported version) will be in Leopard (released on 26th).
    So, my problem is going to the solved if I paid for the Leopard.
    To solve a problem create by Apple I must paid... This is getting better.
  • 9. Re: Rollback Firmware Update on MPB
    mbpjunkie Level 1 Level 1 (35 points)
    Dont think there is a rollback patch for firmware.


    And although I haven't had any problems with 1.4, I have seen a bunch of discontent for it.


    And please take into account that this is a support forum. Most, if not all, are probably here for help or support. This forum does not represent most MBP users. This place represents the small percentage of people who have issues.
  • 10. Re: Rollback Firmware Update on MPB
    umparrothead Level 3 Level 3 (535 points)
    Apple made every effort to inform people using Bootcamp on Tiger that it was an unsupported beta product, which may have any number of issues. For me, I've only got two minor issues with Bootcamp (pre-Leopard), and they aren't showstoppers, but if it suddenly broke, sure, I wouldn't be very happy, but I also wouldn't expect Apple to fix it for me. They aren't the only company to offer free betas and charge for the full version.
  • 11. Re: Rollback Firmware Update on MPB
    Angolan Level 1 Level 1 (0 points)
    umparrothead, once again this is not a BootCamp problem. This is an update firmware problem, and Apple should support it. Before the update, my MBP was working without major problems.
    Well, at least for me, Apple is the first company that charges a new version that I only need to solve a problem created by their firmware update.
    What are your minor issues?
    For me it’s the battery that sometimes is not recognized by Windows, and to solve I must boot from OS X. After that, Windows recognizes the battery again. It happens maybe once a week, but I can’t reproduce.
    Another problem is the Wireless Network Adapter driver that comes with BootCamp 1.4: I can’t connect to my D-Link router. I solve it, using a driver downloaded from Atheros website (Wireless Network Adapter = Atheros AR5008X).
  • 12. Re: Rollback Firmware Update on MPB
    umparrothead Level 3 Level 3 (535 points)
    I agree about the firmware, don't get me wrong...it's the software I wouldn't expect support to be that stellar for. The two issues I mentioned are that when I boot into Vista, it always assumes I'm on battery. To resolve, I just pop out the Magsafe and plug it back in, then it switches to electric properly. My other issue is that the Bootcamp drivers don't yet support tap-clicking, but that affects everyone, and not just me. Do you notice that driver getting better signal than the standard one? My Airport works much better under Tiger than in Vista (mainly signal strength).
  • 13. Re: Rollback Firmware Update on MPB
    KonradC Level 1 Level 1 (0 points)
    from all of the posts I have read, this seems to be localized to 17" MBP's. Ours sufferes from the same problem and was running perfectly before the firmware update. If this is a move to force a leopard upgrade, it's very underhanded. I for one cannot move to leopard because of softare incompatibilities with the new OS, however this EFI update pretty much trashed our machine. The only reason we even installed the update is because it seemed iWork 08' seemed to require it.
  • 14. Re: Rollback Firmware Update on MPB
    umparrothead Level 3 Level 3 (535 points)
    I don't know how successful it would be, but maybe try calling AppleCare and explain your problem, but imply you're running Leopard (therefore, a non-beta and supported version of BootCamp).
1 2 Previous Next