7 Replies Latest reply: Dec 30, 2007 10:44 AM by Curtis McMichael
keeniphone Level 1 Level 1 (0 points)
I've had my iPhone for a couple of weeks now, so I've had some time to observe this problem. I'm not getting all of my Comcast email. If I get 50 emails a week, I miss about 10, or so. When I check my email on my home PC, there are a few that never came through to my phone.

Any ideas?
  • neilrabin Level 1 Level 1 (25 points)
    Do you have your mail client on your computer set to delete messages from server when they are downloaded or within a few days of download or when they are deleted from the inbox?
  • graphics-guru Level 2 Level 2 (200 points)
    Following on the previous post, setting your emal server to maintain the messages for 2-3 days before deleting works best for me. This ensures that the iPhone has time to download the message before the computer "pops" it from the email server.
  • svaughn Level 1 Level 1 (10 points)
    I have my phone set up to receive my Comcast email and it was working flawlessly with the original firmware that was installed on the phone however lately I have begun to receive all kinds of junk email on it. It filters on my computer. Also before any updates I was able to send out emails from any location, now if I am away from home I get a Cannot Send Mail error message stating "the connection to the outgoing server "smtp.comcast.net" failed"
  • Nathan C Level 5 Level 5 (6,260 points)
    keeniphone,

    I am going to try and address the issue you have raised in your post, as well as some of the issues that others have mentioned in this thread.

    First, what is your desktop computer set for when in regards to removing messages from the server? Comcast uses POP3 which essentially means your mailbox acts like a Post Office Box, if one mail client removes messages from the mailbox, it won't be available to the other mail client.

    Many email clients default to removing messages from the server immediately for POP3 accounts. If you are going to be checking your Comcast email from your home computer and iPhone both, make sure your home computer is set to leave messages on the server for at least a little while. If I recall correctly Comcast allows 250 MB of storage per email account. You may want to check with Comcast to confirm that.

    The iPhone also doesn't keep the full contents of messages, especially long ones and attachments, and will go back to the server to download them again. If the messages have been removed you may get errors about the message hasn't been downloaded or isn't available.

    When you are not connected to Comcast directly with your iPhone, i.e. using WiFi from a router connected to Comcast, you will have to authenticate and use SSL in order to use smtp.comcast.net. The iPhone should change the outgoing port to 465 when you turn on SSL.

    This is a direct result of Comcast's efforts to keep their servers from being exploited by spammers. If they didn't require authentication, anybody could send whatever through them with no accountability. This is often referred to as an "smtp open relay", doing a web search for the term will provide more information on why its not a good thing.

    Using port 465, and SSL should work at home, as well as while on EDGE. However, some WiFi networks may filter port 465 and prevent you from sending email.

    Hope this helps,

    Nathan C.
  • keeniphone Level 1 Level 1 (0 points)
    Nathan,

    Thanks for the detailed reply. I will admit right now I don't completely understand all the specifics of this discussion, but I'm trying!

    I looked at my email properties in Outlook Express and found that the box for "Leave copy on server" was unchecked. I checked the box and set it to leave a copy for 5 days. Does this sound right?

    As far as my iPhone settings go, SSL is on for both incoming and outgoing, and the server port is on 995 incoming, and 587 outgoing.

    Honestly, I'm not sure what that means, but from what I've read, it doesn't sound right. Should I change those?

    Also, I have read about several people who have had problems sending email with the Comcast account. That has not been my experience...I have always been able to send fine...my problem is with receiving only.

    Thanks again for the help.
  • Nathan C Level 5 Level 5 (6,260 points)
    keeniphone,

    Per the kbase article I linked above, outgoing should probably be Port 465.

    Ports are often a hard concept to explain. One analogy I have used before is they are like the drop off mail slots inside a post office. You will have one for local mail, one for other locations, and maybe one for presorted mail.

    If you don't send your mail through the right slot it may be delayed, or not delivered.

    Yes, leaving the mail on the server for 5 days is correct. Going back to regular mail analogies. A POP3 mailbox, like what Comcast offers, acts like a Post Office Box. Each mail program, in your case Outlook Express, and the iPhone, are like couriers you send to check your Post Office box. If Outlook Express is not leaving the messages in the box, they won't be available for the iPhone to get a copy of them.

    Hope this helps,

    Nathan C.
  • Curtis McMichael Level 1 Level 1 (5 points)
    I posted this in another thread, but: Just in case that doesn't work. On my iPhone using comcast as the outgoing mail server I had to do these things:

    *STEP ONE*
    In the Settings>Mail>Accounts +(Name of the Email you are using)+

    In "Outgoing Mail Server (SMTP)"

    +Type in the available fields:+
    *Host Name:* smtp.comcast.net
    *User Name:* (your user name for comcast mail - check your home computer settings if you do not know this)
    Password: (your user password - check your home computer is you do not know this)

    *STEP TWO*
    In the Settings>Mail>Accounts +(Name of the Email you are using)+ >Advanced

    In "Outgoing Settings"

    Use SSL: ON
    Authentication: Password
    Server Port: 587

    ---
    After I set my iPhone like this then outgoing mail worked perfectly.