1 Reply Latest reply: Oct 15, 2007 6:57 AM by Dah•veed
Pim Versteeg Level 1 Level 1 (15 points)
Hi,

I have updated all mac's in the house with the exception of my daughters 24" iMac-Intel.
There were 3 updates; 1 for Quicktime, 1 for iTunes and the last one the EFI firmware updater.

First pass installed the Quicktime update and refused the other 2 with "there was an error"
Rebooted the machine, tried twice again, the downloads seem to be complete, but when the actual updating starts I keep getting the same error.

My wifes 20" iMac-intel updated like a dream

Any thoughts?

Pim

PB, iMac, G5, MacBookPro, Mac Pro, Mac OS X (10.4.8), 2*23" Cinema's
  • Dah•veed Level 7 Level 7 (32,120 points)
    Be very careful with firmware updates. They install differently and usually have specific instructions to follow to install correctly. At this point I would ignore Software Update (SU) and do it manually. First go to Apps/Utilities and see if SU has placed the installer there. If so, it may be corrupted so drag & drop it in the trash and flush it away. Then go to Apps/Utilities/Disk Utility/First Aid and select your startup disk and Repair Disk Permissions.

    Next download the update from this link; iMac EFI Firmware Update 1.2.

    Stop all other processes, disconnect any external FW/USB devices and devote the Mac to just installing this update; stop airport and bluetooth and just use a wired keyboard & mouse. Now read and know the directions for the install, including any restart instructions that may be required. When you are ready, do it.

    After it is finished reconnect externals and restart any other processes and run SU for the iTunes update. I Repair Disk Permissions before and after all Apple updates and 3rd party updates that use an installer.

    Good luck.