Previous 1 21 22 23 24 25 Next 408 Replies Latest reply: Jan 14, 2008 8:35 PM by CyberMac Go to original post
  • blin22 Level 1 Level 1 (0 points)
    I recommend deleting the aforementioned APE files by navigating to each folder and confirming the delete. I tried to remove the files by just typing in the lines mentioned here and it did not work. I then tried to confirm if they got deleted and they and they did not.

    After deleting them manually in each directory tree, Leopard booted up right away. This was aggravating...I didn't even know I had APE.
  • cjpotter Level 1 Level 1 (0 points)
    Check the following thread for the answer. Summary: there's a conflict with DivxNetworks.
    Search for EricShapiro on the page to find the answer.

    <http://discussions.apple.com/thread.jspa?messageID=5666569#5666569>
  • plugsandpixels Level 1 Level 1 (10 points)
    OK folks, I have good news about a painless Leopard experience, so let me tell my tale.

    I went to the Apple Store too early Friday to get Leopard and I didn't wish to join the mob scene that night, so I went back today (Saturday) and was in and out in 10 minutes.

    I had already read every post in this thread before purchasing Leopard and you had me scared to death!--even though I've worked in higher ed IT for nine years and am pretty good at keeping entire labs running despite students' best efforts. Even though we already have lab-size maintenance on OS-X, I like to have a hard copy, since Apple never seems to send the disks.

    I was planning on trying to install Leopard on my G4 533DP at home over the weekend to get familiar with Leopard, so I Carbon Copy Cloned my main drive to an extra internal drive to be safe. Well, I met every one of Leopard's requirements except for the 867 mhz processor--even though 533x2 = more. Oh well, no biggie. I wonder if an install on a supported iMac G5 would clone over to a G4?

    So I next turned to my MacBook 1.8/2gigs RAM. Fearing the worst, I CCC'd it to an external FW drive which I then disconnected. I booted up from the Leopard DVD, after which I let my 12 year-old daughter (who tinkers with her own G4 450DP) click the various buttons during the install. We chose to skip printers and languages, but kept X11 during an Archive and Install.

    The install went rather quickly--maybe a half hour? Upon reboot, the DVD ejected immediately. We bluescreened for maybe a minute, during which time I had a knowing smirk on my face, thinking I had joined the rest of you in the blues. But suddenly the desktop picture appeared, along with the pinwheel. Another minute later, we were in the user environment, where she had great fun exploring Spaces, etc.!

    I had installed no hacks on the MacBook aside from Little Snitch; I did have all sorts of other stuff installed (Adobe PS CS2 and the entire CS3 suite, 3D apps, Office, other graphics and audio apps, etc. I think I had originally cloned the MacBook from an Intel desktop, FWIW.

    The only problems I can report are Snapz Pro's registration is broken (not a big surprise), and GIMP 2.2 (outdated) crashes. Oh, and Parallels 3 can't comminucate with its drivers, but I expect a reinstall to fix that easily.

    So I don't know what many of you did to your original systems, but based on my smooth experience this evening with nary a trip to the Terminal, I'm leaning toward not blaming Apple for your woes.

    (I hope I'll be singing the same tune once I upgrade my Mac Pro in the office--and eventually the labs!)
  • plugsandpixels Level 1 Level 1 (10 points)
    Additional details:

    •I had Flip4Mac WMV installed to no ill effect.

    •I've already deleted my Previous System folder, emptied the Trash, restarted and logged out/in successfully.

    •After mounting the FW drive with the MacBook's backup to check something and later ejecting it, the name of the drive remained in the sidebar until I logged out/in, while the FW partition icons did remove properly.
  • R C-R Level 6 Level 6 (15,220 points)
    Rosyna wrote:
    So far, no one here is actually removing it. The commands given here to "remove" APE have severe typos that prevent them from working (and may result in unexpected data loss if the HD is mounted read/write).


    And yet nobody is reporting data loss but many are reporting success by using the commands. Some report removing the files not with terminal commands but with Target Disk Mode ... & it works for them, too.

    I think your explanation doesn't hold water.

    Edit: oh, & look: Apple now has a kbase article mentioning those same commands: Mac OS X 10.5: "Blue screen" appears after installing Leopard and restarting.

    So I guess you think Apple is making typos, too? Give me a break!
  • nobody loopback Level 4 Level 4 (2,570 points)
    R C-R wrote:
    nobody loopback wrote:


    I would say that different:


    The functionality which APE uses is removed from Leopard. Since it is removed by Apple, they must have known that this can happen.




    The "functionality" APE uses is a method of modifying the OS's behavior that Apple explicitly tells developers it reserves for its own use, & has for years. It isn't that something has been removed, it is that APE's author knowingly ignores the warning in Apple's developer guidelines not to use something that is there that is not designed to support third party development.




    IOW, both Apple & conscientious developers know this can happen.




    Even if APE uses features not officially supported by previos OS versions, Apple should check the installer against the most popular utilities.




    That isn't practical. These things are hacks, not utilities. They often go by the name "Haxies" to distinguish them from software that does not modify the OS in unauthorized ways. Apple has no way of knowing what their authors will dream up next or if some revisions are safe & others are not -- their authors can't very well work with Apple since they are intentionally doing things Apple says are not safe to do.




    If Apple were to take responsibility for testing all these things, they would never be able to release updates to the OS, much less upgrades, because the testing cycle would never end. Instead, it warns users to remove these things before updating or upgrading and it provides two installation methods that are safe to use if users don't want to do that.




    The responsibility here is obvious: developers of these things should make it clear to users what they are & their potential for interfering with official changes to the OS. Unfortunately, some developers don't do this & a few even insist they are perfectly safe when it is clear they are not.




    APE does not "modify" the OS. Modifying means for me, that code is changed. I also cannot see, that code someone writes, must be "authorized" by apple. If someone writes code, which does not modify the Apple supplied binaries, this cannot be illegal.
    The changes to the look and feel to the OS which APE & FruitMenu implemented, did never interfere with any other function os the OS from my knowledge. They simply enhanced the functionality.
    I can understand, that apple did not like other things which could be done through APE. However this code has unlikely been written by the unsanity people (do a search for "thebadape").
    If Apple now disables these possibilities, this is ok for me. I will miss FruitMenu and hope there will be another way to get this functionality back in the future.

    But given the popularity of the unsanity haxies, I would have thought that it is rather practical for apple to take care of possible problems in advance by either checking for the presence of APE and then refusing to install or better, give a warning that installation cannot continue without removal of APE.
    What happend now, was not practical, because it produced a big thread in the discussions forum where people wrote rants and and busy phone lines at apple support.
  • Michael K Murray Level 1 Level 1 (130 points)
    My experience so far with Leopard

    (1) MacBook -- upgrade went fine although it blue screened for a few minutes which was scary enough for me (1 install needed)

    (2) Old 12" Powerbook -- upgrade went fine (1 install needed)

    (3) Intel iMac -- BSoD -- went back and did Archive and Install with save User settings selected and it was fine. (2 installs needed)

    (4) pre intel iMac -- got to user login but wouldn't launch Finder. Tried Archive and Install but no room. Then things got messy. I plugged in an external firewire drive and installed to that. Booted from the external and then made some space. You could also go in with Terminal when booted from the Install DVD and do some `rm -r'' if you don't mind that kind of thing! Then I did Archive and Install -- all went fine until the very end when it failed to transfer user settings. It forced me to install again and it worked but the user directory was in the Previous Systems Folder as was the old Applications directory. The permissions on it make it a `drag' in more ways than one but you can get things out and set them up. This machine has a lot of junk on it from many years and applications in the user directory etc. Seems to be OK now. (4 installs needed)

    I would recommend:

    (a) before you do anything make a clone with Super Duper or Carbon Copy Cloner. Reboot with the clone and check it works
    (b) copy things you can't replace onto DVD's
    (c) have enough room to do an Archive and Install in case you have to.
    (d) if this is a mission critical machine and you don't have a spare day to fix it if things go wrong don't install.
    (e) if you need to sync your Palm with Missing Sync for Palm OS don't upgrade until you read the Mark Space website

    Michael

    Message was edited by: Michael K Murray
  • Rick Saphire Level 1 Level 1 (0 points)
    Hello Friends,

    I had the "Blue Screen Blues" on my first few tries. The solution is quite simple. Back up your hard drive first (I use Carbon Copy Cloner - GET IT!). Then, so a clean install, and when you boot up 10.5, use the Migration program (built into 10.5) and it will bring over all of your files and associated programs to the new system.

    Good luck - and good luck to the programmers at Apple who will be looking for new jobs.

    Rick
  • JudieR Level 1 Level 1 (0 points)
    The problem I have with all these solutions (and I've been using a mac since 2000, so I'm not a TOTAL technotard, but I'm certainly not as good as a lot of you folks telling your tales) is what about the poor schmoes who bought an new Intel iMac, like I did in August, and installed a few basic things, like a couple of printers, a scanner, have an iPod Shuffle (which created its own problems for a while) and a few other programs other than Apple software - and we try to install Leopard and get all this stuff going on. That's VERY bad news for trying to convert people to a Mac. Mind you, if they buy one now it will come with Leopard, but STILL. My computer is only 2.5 months old!

    Judie
  • Randal Guymer Level 1 Level 1 (0 points)
    I have two Intel Macs.

    On the Mac Mini I did the straight Leopard upgrade as this machine is only 5 days old, and it hung up after installation. I had to do a forced shutdown (I gave it 30 minutes to restart on it's own), but afterwards it started up as normal and everything seems to be OK.

    On my MacBook I did the archive and install, that method worked exactly as it should... no problems.

    From everything I'm reading online from other users experience's at several different forums, definitely do an archive and install.
  • Mathias Roehn Level 1 Level 1 (15 points)
    Exactly that way which worked for me.
    Carbon Copy Cloner is the best 3rd party tool for the Mac.
    Please donate some bucks to ensure it can be developed further.

    In general a clean erase install is truly the safe way to upgrade an OS.
    I am not a friend of upgrade installations at all, which failed for me mostly.
    Also from 10.3 to 10.4 I tried, but then also used erase install and my backup to import the files.
  • bangzoom2 Level 1 Level 1 (0 points)
    Mez Hopking wrote:
    Do not chose the Case Sensitive option when you do a clean install... All the Adobe programs DO NOT support it!

    Right back to square one, off to do another clean install on a Journaled ONLY file system.


    I discovered this after a recent hard drive crash. My solution was a little less drastic, as I didn't want to spend the time to reformat+reinstall the entire system: Create an HFS+ sparse disk image using Disk Utility, and install the Adobe apps to it.

    So I must have the disk image mounted to use Photoshop, but it works fine, and I really prefer dumping case-insensitivity.

    As a software developer, I'm curious as to how one is able to write a program that breaks when case sensitivity is turned on!
  • Carlos A. Level 1 Level 1 (0 points)
    Hi,

    I'm planning to upgrade my PowerBook G4 from 10.3.9 to Leopard.
    I only have left 1.9GB of free space in my internal Boot Drive.

    I tried to call Apple to double check the requirements to perform a successful upgrade and they were helpless.

    Any ideas, comments and suggestions are welcome.

    Thanks.
  • thestobbster Level 1 Level 1 (0 points)
    I have upgraded 4 Mac's to Leopard. My wife's 15" Power Book G4 had this issue with rebooting after the upgrade. You are not out of luck. What fixed my problem was to reboot off the Leopard install DVD and reinstall, but select the Archive option and re-install OS X. for additional information look here...

    http://docs.info.apple.com/article.html?artnum=107120

    Cheers,

    THe SToBBSTeR
  • Stephanie Craxford Level 1 Level 1 (0 points)
    FWIW.

    I just did an upgrade on my iMac 24".

    1. Booting from Tiger I first repaired my disc.
    2. Then I cloned my system to my new vantec ext drive.
    3. Checked that I could boot from the ext drive
    4. Booted to Leopard and selected the default install which was Upgrade.
    5. The upgrade took 1 hour and 9 minutes.
    6. The system restarted with out any problems.

    Now I installed using the Family Pack DVD, so I'm not sure if that makes a difference. Have all the installation failures been with the Single User DVD?

    Steph
Previous 1 21 22 23 24 25 Next