8 Replies Latest reply: Feb 21, 2008 2:22 PM by Rex Oppenheimer
Billbr Level 1 (0 points)
A web page I use continually has suddenly stopped allowing links to open unless I either refresh the page each time or hold down the command key so that a new page is opened. I have tried re-setting Safari, deleting cookies, emptying cache files, trashing Safari plist file and restarting machine. But nothing works. My version of Safari is the latest I can use on Panther (1.3.2) so can't upgrade to later Safari. Up until recently all worked fine and the webmaster tells me that nothing fundamental has been changed on the web page.

Fire fox opens the links OK.

So any ideas on Safari's strange behaviour of late?

Emac G4, Mac OS X (10.3.9)
  • John Armbruster Level 1 (50 points)
    Sorry I can't help, but I have the same problem. Looks like Apple has broken something again in coming out with a "new and improved" version.
  • iBod Level 7 (29,340 points)
    Since you're on a different operating system it's unlikely you have the same problem.

    The majority of problems with Safari 3 have been due to third party 'Safari helper' applications. Go to these 2 locations and move anything present in them onto your Desktop to deactivate them:

    /Users/YourUsername/Library/Input Managers/
    /Library/Input Managers/

    Restart Safari to pick up the change. If it works now, you can try moving the items back one by one until you find the culprit.
  • John Armbruster Level 1 (50 points)
    Thanks for the advice, but it didn't help. It's almost like it follows the link and opens a new tab or page depending on how I have the preferences set, and then instantly closes the link before anything displays.
  • scapesuiter Level 7 (27,660 points)
    Do you have the problem universally or just with some sites? What is the URL of the troublesome page? Any potential helpers would need to know what the site is to test.
  • John Armbruster Level 1 (50 points)
    Actually, this is the site that seems to be giving me problems. This page for example used to work perfectly. When I clicked on the "See Additional Pictures" it would bring up a page with more photos. Now when I click on it, the Safari window completely disappears but the menu bar remains active. If I open a new window and then quit Safari it indicates that I have two windows open...as if the original window were still there. The site works correctly in Firefox and Netscape except that when the linked page opens, it is shrunken down to the minimum size - that also is something new.

    http://maris.rapmls.com/scripts/mgrqispi.dll?APPNAME=Gstl&PRGNAME=MLSLogin&ARGUM ENT=mor8OBAJTEbRGV7ukbtWDtA5ZO2mU0/Z9pC21d8Eejc=&KeyRID=1
  • Photo 1 Level 1 (0 points)
    I am having the same problem on my Dual G5 running Leopard. Safari opens, the highlight shadow beneath the icon is om, the name Safari is in the finder bar at the top of my screen, but no window opens. If I close the program it tells me I have several tabs open, and asks if I want to close. Photoshop CS3 and Bridge CS3 are doing exactly the same thing. If I click on an image file, the programs open, but with no window. If I close them, they indicate that an image is open and ask idf I want to save it. They are running in the background but I can't get a window up. If I reboot the G5 Safari will launch normally, then promptly quit, when I relaunch it, I get the running but no window scenario again. None of this occurred prior to Leopard.
  • Photo 1 Level 1 (0 points)
    After four days of everything from AppleCare, to the Genius Bar, to my Apple specialist, we all gave up. I've done a clean install of Tiger and all my issues are gone. I don't know why I fooled myself into thinking I had to have the latest OS and that it would be trouble free. I could see it if the problem was with some third party software that no one could anticipate, but Safari and Adobe? It'll be a long time before I take that Leopard disk out of the box again for anything but a frisbee game!

    Jim Wilson
  • Rex Oppenheimer Level 1 (140 points)
    Help, please! I'm running Safari 3.0.4 when I'm on a Web page, for example a real estate listing where there is a link for additional pictures, and I click on the link, it opens for a flash and then disappears. If I look under window it's listed there but clicking on it does nothing.

    If I use Firefox on the same sites, it opens the links without any problem.

    Also, I wanted to post a new topic on Discussions but there is no "post new topic" button at the top of the page as there used to be. I looked everywhere and cannot see a way to post a new topic. What's going on?