Previous 1 2 Next 29 Replies Latest reply: Jul 13, 2008 11:27 AM by merlgirl Go to original post
  • Quentin Stafford-Fraser Level 1 Level 1 (50 points)
    Mmm. Some suggestion here:

    http://tinyurl.com/2hr9sw

    that one cause of the PubSubAgent problem may be something to do with having RSS feeds in Safari or Mail that require a password. I had a quick look through mine, and found one that didn't seem to have its password saved in the keychain. Have fixed that... let's see what happens.
  • Quentin Stafford-Fraser Level 1 Level 1 (50 points)
    It's looking good so far - I think this has fixed it for me.

    There are obviously several kinds of hiccup that can cause PubSubAgent to do nasty things...
  • moonw Level 1 Level 1 (0 points)
    How about this? My wife's iMac, Leopard, 10.5.1, NO .mac account at all, I don't know what a proxy server is to turn it on or off, (home machine) and she is getting the "pubsubagent" crash.

    Any help?

    Thanks, David
  • Quentin Stafford-Fraser Level 1 Level 1 (50 points)
    Does she use any RSS feeds which might need a password, either in Mail or Safari?
  • Conal Ho Level 2 Level 2 (495 points)
    PubSubAgent kept crashing today and I finally decided to delete all my RSS feeds. I have been using RSS feeds in Mail since day one of installing Leopard which is about 2 months now. While it crashed once in a while, it did not go crazy like it did today. Finally, today I gave up and just deleted all the feeds.
  • Brett Patterson1 Level 1 Level 1 (15 points)
    I'm getting this error, and I'm not using a proxy server.
  • Jay Gischer Level 1 Level 1 (0 points)
    I'm getting this problem for the first time today. I don't use .mac and I don't use mail.app. I use Firefox and Google Reader. I have no idea why that would give me a problem that is local to my own machine. This happens at home. My modem/firewall does ip translation, does that make it a proxy server? I've had many other crashes today, but I think that was due to a corrupted upgrade to Firefox, which I reinstalled, and that fixed the other problems.
  • BillyBreen Level 1 Level 1 (0 points)
    Did you update to 10.5.2 today? Ever since, I've been seeing the same thing. Also, iPhoto and iTunes both crash on startup, ever time. Wheeee.
  • go-dons Level 1 Level 1 (10 points)
    At school I'm the only Mac attached to a Windows network. I have similar problems to many that have been mentioned here.

    My "solution" is that each day I launch Internet Explorer and let it negotiate access to the internet. It succeeds because in IE Preferences I can not only enter my school user name and password, I can also supply a Domain name. My school server seems to require this and my Network Administrator (computing teacher) was able to tell me what it is.

    After that, Safari & Firefox and other applications such as Software Update work as expected.

    In Network I can only provide my user name and password - there is nowhere (as far as I can see) where I can input the name of the school domain.

    PubSubAgent seems, like Safari,Software Update etc, to be an application that can't get through my server without Internet Explorer going first.
  • WillisWasabi Level 1 Level 1 (0 points)
    I've used both Safari and Firefox through an MS ISA proxy at work that uses NTLM authentication based on an ActiveDirectory. I've been able to use it just using my username and password, the domain has always been not needed.

    There are a couple of ways to encode the domain into the username, either the old method domain\username or using UPN which would be username@domain.company.net or whatever your FQDN style domain name is (it would be the DNS domain name all the servers are located in).
  • Trevor Harley Level 2 Level 2 (365 points)
    I'm getting it now.

    I don't use a proxy server or have RSS feeds that require a password.

    I do have some RSS feeds and have .mac synchronization turned on.

    Perhaps 10.5.3 will sort it out ...
  • ibarhbar Level 1 Level 1 (0 points)
    I was having same problem, read all posts - no help....messed around and finally was able to stop the "PubSub" popup AND the lockups by going into Sys Prefs -> Universal Access -> Mouse [Tab] and turning the Mouse Keys OFF.

    I was new to the mac and was messing around with settings and had set this on for some reason...what had made things worse was that I had loaded some updates around the same time.

    Anyway....worked for me.

    barhbar
  • Bartleby66 Level 1 Level 1 (0 points)
    I have the annoying pop-up " PubSubAgent " that has rendered Mail unusable. It will not let me " Deny " and move on. Have tried everything here that seems applicable, and I don't even have any RSS Feeds, nothing works... Apple , can I get a partial refund for not being able to use Mail ??? I recently switched from Windows but something like this alone is enough to make me switch back ...
  • zipdrive Level 1 Level 1 (0 points)
    I had been occasionally having the same problems. Recently I installed the new virus and firewall package from Intego and of course set it up for antispyware. When "PubSubAgent" came up with a warning for outgoing suspicious activity. I went ahead and told it to "Deny" which now blocks "PubSubAgent". I still have the warning set to alert me whenever it detects activity from "PubSubAgent"; this happens extremely frequently and seems to revolve around nearly every significant activity I perform on my computer (in other words spyware). I have checked the log file in NetbarrierX5 several times when I get the alert and it shows about a dozen or more attempts to go out on different IP addresses before giving up each time. I hate to be blunt, but either Apple is using this as spyware or "PubSubAgent" has been hijacked by spyware. Oddly enough I did a clean install less than a month ago when I installed OSX 10.5.
  • merlgirl Level 1 Level 1 (0 points)
    I had the same issues. Just called AppleCare and they walked me through an easy fix in about
    five minutes. Went to Finder/Library/Mail. Dragged my .mac email folder to the desktop to save it.
    Then went to Finder/Library/com.apple.mail.plist and dragged it to the desktop.
    Then completely set up Mail as a new app.
    No more problem.
Previous 1 2 Next