Previous 1 2 Next 28 Replies Latest reply: Nov 4, 2007 4:06 PM by nepmol Go to original post
  • infobhan Level 1 Level 1 (15 points)
    I successfully updated a single-drive backup, recreated my RAID with the newer Disk Utility, and restored onto the RAID using Carbon Copy Cloner. Looks like the old version RAID is the problem.
  • Sonny Lykos Level 1 Level 1 (10 points)
    Installed it on my tower and Imac, but I get the same "cannot install on this computer" when trying to install it on a Pismo I had upgraded to a G4.

    Any ideas about my problem?
  • Dr. Euphoria Level 1 Level 1 (10 points)
    I have had a SATURDAY FROM ****. Installed on my boss' boyfriends' MBP 2.16GHz machine and Leopard gave me that message, and when I tried to get out of the install taking out the Leopard DVD, I got a restarted mac that wouldnt even show an Apple logo---i got a file with a question mark.

    (NOW I know that this means I should reinstall Tiger here)

    Then I tried restarting the Leopard install, ran disk check (saw everything was fine) but I got the message again and stupidly clicked "erase and install" thinking it would erase a partion of the disk that contains the Tiger OS.

    So now the install went ok but then once it started acting like a macbook pro that is fresh from the market (i.e. Welcome movie), I knew I just erased EVERYTHING on my boss' computer.

    Thank God for Boomerang Data Recovery, I was able to restore pdfs, but not Microsoft Word docs or Excel docs----these are all jibberish. I called my boss to let him know and was of course returning my message with utter shock.

    Thank you Apple for letting us clearly know that in order to install Leopard correctly and safely YOU MUST remove non-apple ram from the computer!
  • Stevearoo Level 1 Level 1 (0 points)
    That's because disk format is not a system requirement - i.e. you don't have to buy hardware to fix it.
  • inderweltsein Level 1 Level 1 (0 points)
    About the *yellow exclamation mark* problem ...

    I have succeeded in solving this problem without having to do any backup.

    But this involves correcting hexadecimal values in the GPT (first deleting other entries than EFI and the HFS+ partition of Tiger, then calculating two checksums, in order these changes are not replaced by the GPT backup).

    And after installation of Leopard, rewriting the original GPT (to get access back to all your partitions)

    Basically, the installer seems to support GUID partition tables with :
    + either just one HFS+ partition, with any size, it does not matter if it does not fit on 100% of the disk
    + or two partitions, a HFS+ one and a "Basic Data" one (that can be FAT32/NTFS for Windows or ext3/reiserfs/jfs/whatever for Linux) but in this case, the installer absolutely wants that the sum of both equals 100% of the disk.

    I came to these conclusions because in my case, I had three partitions :
    + the HFS+ one
    + an ext3 one (described as "Basic data" by the GPT)
    + a Linux swap one
    = 100% of the disk

    First I tried to make something that is not data-destructive : delete the Linux swap. I was thinking it would work because the installer would see an HFS+ one and a "Basic Data" one (and would think I have a Boot Camp/Windows installation)
    But it did not worked, because HFS+ plus Basic Data does not fit the whole disk (Bootcamp partitioner partitions disks like this)

    I could have chosen to resize, extend the ext3 one in order that all the disk but I did not think about it.

    So my solution was finally what I have said earlier : to edit the GPT to make the installer believe there is just a HFS+ partition (and empty space instead of Linux/Linux swap partitions) then after the installation, to restore the GPT to its full extent.

    I may post a page with a HOW TO of my method in the coming few hours or few days (I made my hack under Linux, but it is doable under Mac OS X)

    But in all cases, this is the presence of another partition, that the installer doesn't like, that is causing you the yellow exclamation mark problem. So if you can delete it, you can solve it without my method or the "obligatory" backup.

    Message was edited by: inderweltsein
  • nepmol Level 1 Level 1 (0 points)
    I have the same problem with the yellow exclamation mark and the "You cannot install Mac OS X on this volume".

    I've checked some things:
    - GUID Partition Table: ok
    - Partition scheme: just one single partition Macintosh HD, Mac OS Extended (Journaled) 111,5 GB, 55,4 GB available

    I bought this macbook pro from a apple store and did not alter any of the settings.

    I do have Parallels installed with two virtual machines: Windows XP and Ubuntu 7.10

    Any help?
  • tombec Level 1 Level 1 (0 points)
    I have the same exact problem and setup as above, please help!
  • mpelle Level 1 Level 1 (0 points)
    i'm having the same problem as well.
  • dawnrazor Level 1 Level 1 (15 points)
    any of you guys running Tech tools pro 4 or have the HD partitioned with an e-drive, 'cus that'll cause this problem!!!!!
  • dawnrazor Level 1 Level 1 (15 points)
    Sorry I should mention, that you need to remove the e-drive using the original TTP4 disc before you can go any further unless you want to erase and install.
  • nepmol Level 1 Level 1 (0 points)
    I noticed a strange this with this.

    When I verify my disk using the disk utility on the Leopard dvd it gave some errors:

    * Incorrect number of Extended Attributes (it should be 0 in stead of 2347)
    * Volume header needs minor repair
    * The volumen Macintosh HD nees to be repaired
    * ERROR: filesystem verify or repair failed

    So, I could not repair this with the Leopard DVD

    When I used my Tiger 10.4.10 CD and ran verify disk, it gave no errors at all!
    Also running verify disk after normal boot gave no errors.

    Weird, isn't it?

    Anybody a clue?
  • digger8 Level 1 Level 1 (0 points)
    This is precisely the issue I have encountered - you're not alone in this.

    Running the 10.4 Disk Utility repair found zero errors.
    Running the Disk Utility on the Leopard install disk it produces this same message you note.

    I have not been successful using any of the standard tools to make the necessary repairs. Reformatting the drive seems like overkill.

    Worth noting that I have two other Macs - iMac and MacBook - both of which were upgraded without issue.
  • Gary Noe Level 1 Level 1 (25 points)
    Thankx Tony,
    You solved my problem installing Leopard! I had to repartition etc.
    Thx again, gary
  • nepmol Level 1 Level 1 (0 points)
    What eventually worked for me was running DiskWarrior!

    hope you are succesful as well
Previous 1 2 Next