Previous 1 2 3 4 Next 52 Replies Latest reply: May 7, 2008 4:34 PM by VoxBoston
SuperDupe453 Level 1 Level 1 (0 points)
After upgrading to Leopard I keep getting "AirPort has a self-assigned IP address and may not be able to connect to the Internet." when I try to connect to the wireless network. Thus, wifi does not work at all. I've researched it best I can and it seems to be a problem with the router assigning an IP address to the mac, but why didn't this happen in Tiger? However if I play around with it for awhile it will randomly start working, but the same method doesn't fix it everytime. It also works fine in bootcamp. If I physically plug into the router, it works fine. This problem didn't exist in Tiger at all.

Message was edited by: SuperDupe453

MacBook Pro 3gb 2.33ghz C2D, Mac OS X (10.5)
  • Alex Hammer Level 1 Level 1 (30 points)
    Not sure about Leopard but in Tiger one could sometimes fix this problem by moving the System Configuration folder at Macintosh HD --> Library --> Preferences to the trash, emptying the trash and rebooting the Mac. You do loose some settings but in Tiger I've seen this work twice to fix the self assigned IP address in Airport problem.
  • SuperDupe453 Level 1 Level 1 (0 points)
    Thanks for the suggestion, I tried it but it didn't fix it
  • SuperDupe453 Level 1 Level 1 (0 points)
    Just a little more info. I can set up the wireless manually inside of network preferences and it still won't work. Every other non leopard and non mac computer in the house can connect. I have tried deleting the SystemConfiguration folder and that didn't help. It has to be something inside of leopard causing this.
  • Corey Weiner Level 1 Level 1 (0 points)
    I had a similar problem I fixed using the "Diagnostics"
  • SuperDupe453 Level 1 Level 1 (0 points)
    The bottom 3 lights in diagnostics stay red for me. Unless I restart the router like it says, and that only works about 1 time out of 5. Even when that does fix it once I turn off the computer and turn it back on the airport won't know how to connect again. I'm not fond of the idea of having to restart my router 6 times every time I want to use the wireless. What I can't seem to figure out is why physically plugging into the router it will work with 0 problems, but connecting wirelessly with airport it won't work practically at all even though other computers can connect to the wireless and I can use bootcamp to get into windows and then the wireless connects fine also. Possibly a bad driver in leopard?

    Message was edited by: SuperDupe453
  • Jeffrey Lee Level 4 Level 4 (2,500 points)
    I think it's software related....

    I just bought a new MacBook Pro early this month, upgraded to the latest version of 10.4, and then couldn't work with Wi-Fi reliably. Now, with 10.5, it works fine when I start up, but once I put it to sleep, it wakes up with the self assigned IP address..

    I have not found a way to make it to get a valid IP address, except by restarting.
  • James Harlin Level 1 Level 1 (0 points)
    I have the same problem with my MacBook which I purchased a month ago. It does not matter what wifi I connect to as the problem always occurs when "waking up". I did a fresh install of Leopard Friday and then another on Saturday to no avail. I also booted with Option-Command-P-R and nothing fixed it.

    This did not happen on Tiger for the 5 weeks I was running it on my MacBook before upgrading on the 26th.
  • rohan611 Level 1 Level 1 (0 points)
    I have the same problem although it doesn't just malfunction after waking up...My wireless has not worked once after I upgraded to leopard, even after I installed the update that was released today. Every time I try to connect, it tells me that there is a self-assigned IP. I'm trying to connect to a 802.1X network and I am getting more and more frustrated. When I select the network I want, it considers it a WEP network even though it is a 802.1X network. As a result, I can only type in a password when it is necessary for me to input a user name as well. Anyone have any ideas how to fix this issue?!
  • Michael Lafferty Level 6 Level 6 (16,080 points)
    Even if you have installed the latest Keychain update, you may be facing an issue similar to that which you describe.

    Some users have determined that an artifact left over from Mac OS X 10.4.x interferes with wireless connections after Mac OS X 10.5 is installed. As explained in this thread, the issue can be dealt with by finding and removing the AppleAirPort2.kext file from your Extensions folder, located here:

    Macintosh HD:System:Library:Extensions

    It's a simple fix, but one that you would never find on your own. And, it's pathetic that the installation or migrations scripts fail to remove this troublesome component.
  • SuperDupe453 Level 1 Level 1 (0 points)
    Wow, deleting airport2.kext seems to have fixed my problems, even though I haven't installed the keychain update. I'll give it a couple days and if its still working I'll mark as solved. Thanks!
  • vewright Level 1 Level 1 (0 points)
    I have five Intel Macs--MacPro, MacBook Pro, MacBook, Mac-Mini, and iMac. I purchased a Leopard Family Pack to upgrade all five. I first installed Leopard on the iMac, and everything worked just as well as one should have the right to expect after suffering through months of hype. I then installed Leopard on the two MacBooks. In both cases, I could not connect to the internet. Both the built-in ethernet and wireless connections obtained self-assigned addresses and would not connect. Obviously, they could not connect because the self-assigned ip address is not in the same subnet as my network. I tried setting the address manually, using an ip address not in use in my private network. No joy! I was not surprised, because the manual settings page does not allow me to enter the correct subnet mask. Entering a DNS server address didn't work either. And, of course, I don't have the option of entering the router's address.

    Removing the AppleAirport2.kext file didn't make any difference.

    I tried one more computer, the Mac-Mini. Same problem-self-assigned ip addresses on both airport and built-in ethernet.

    Now, I know the problem is not in my network, because I have a half-dozen windows computers with internet access via the same AT&T modem/router/dhcp server. Not only that, each one of these computers had internet access immediately before I upgraded from 10.4 to Leopard.

    One thing occurs to me. One is that Leopard's DHCP client software is unreliable, if not broken. After all the hype, this is pitiful.
  • vewright Level 1 Level 1 (0 points)
    Follow-up:

    On the two laptops, I finally managed to get on line by switching to a different wireless access point, on a different modem. I surmise that the communication between the Macbook DHCP client and the modem/router's DHCP server is less than 100% effective. Looking at the modem/router, I could see that all of the Macs had active connections. But, instead of showing the names of the Macs, the page showed a star (*) for each Mac. I had to compare Mac addresses to verify the connections. The MAC address, of course, is hard-wired into the computer's network interface. It appears that either the DHCP client didn't know what question to ask when it broadcast for an IP address, or it couldn't interpret the answer. Except in the case of the iMac, which worked perfectly.

    I upgraded the MacPro last, since it is my primary machine. Same story--connection with self-assigned address, which is useless. However, this time, having nothing left to lose, I restarted the modem/router, which presumably dumped any inactive connections and issued new DHCP leases.

    However, I do have a few words for the Apple GENIUSES! The Leopard network preferences page puts me in mind of a maintenance free battery. A few of the older folks will remember when you bought a car battery that had to be filled with distilled water to reconstitute the electrolyte. Then, periodically, you check the level of the liquid in the battery, and added distilled water when required. Adding water was required on occasion because some of the water would boil off under certain conditions. Then, we got the maintenance free battery, which is virtually identical to the older battery design, except that you don't have to perform the maintenance of replenishing the water. It turns out, however, that maintenance free batteries do vent on occasion, and should have water added. But, you can't add water because the battery is sealed. So, the difference between conventional and maintenance free is not that the maintenance free battery doesn't need maintenance, it is that you can't perform the maintenance without voiding the warranty.

    The Leopard network preference page won't let you set the parameters that could restore a connection. If the DHCP client doesn't work automatically, you're stuck.
  • Stephen Epstein Level 1 Level 1 (10 points)
    Not solved at all. Same problem exists without the Airport2.kext file as well. I think the only people that still have that file did a simple "Upgrade" instead of an "Archive and Install"
  • Bugfixer Level 1 Level 1 (125 points)
    As I wrote in a similar thread:

    "Same problem with iMac G5: after the problems described here, last night the authentication (WPA) failed forever.

    Apple please fix it ASAP, or I will ask you the money back and reinstall Tiger. Apple can't sell an operating system with this kind of problems."
Previous 1 2 3 4 Next