1 2 3 Previous Next 38 Replies Latest reply: Dec 23, 2007 2:07 PM by Mr Moto Go to original post
  • 30. Re: Disappearing keychain? Leopard you evil magician you!
    Norm Goodger Level 1 Level 1 (5 points)
    This is the real me wrote:

    (Final Cut Studio also wants serial numbers, Motion won't launch, and pretty much all the shine has gone off Leopard.)


    If you did an archive and install, some of those settings are probably in the System Library and may as you noted, need to re-enter your serial #, I would not expect a program to fail unless it was incompatible or not properly installed somehow to begin with and a re-install should fix it.
  • 31. Re: Tentative Solutions For Disappearing Keychains
    jeffmckenna Level 1 Level 1 (0 points)
    This suggestion was most helpful and worked for me.
    I did get useful help from apple since I lost access to my root account. Then I fixed the password problem. I got the S/W update but I think the damage had already been done.
    Recommendation for folks installing. Update the software before you go to .Mac!
    Jeff
  • 32. Re: Disappearing keychain? Leopard you magician you!
    Otis Maxwell1 Level 1 Level 1 (0 points)
    I installed Leopard on Tuesday 10/30 and spent much of the next 2 days grappling with Keychain problems, most of which are addressed in this thread. Wish I'd come here first! But here are a couple others that hadn't been mentioned:
    * After I got my original keychain restored most of my passwords worked but there was one that didn't. Apparently Keychain had converted lower case to upper case letters and the password was case sensitive of course.
    * I couldn't connect with a network I regularly use and found there were multiple passwords in keychain and Airport (using a saved location from a couple years back) was connecting with an obsolete one. Solution: a/delete all but the current password from Keychain b/have Internet Assistant make an "automatic" connection instead of using a saved one.
  • 33. Re: Disappearing keychain? Leopard you magician you!
    Robert Tannehill Level 1 Level 1 (0 points)
    I installed Leopard on a dual G5 and a G4 Powerbook. WAIT!!!! It's a mess. No problems on the dual G5 but the powerbook was a disaster. Finally had to do a clean install with Tiger and then do a clean install with Leopard. Lost everything in the computer.
  • 34. Re: Tentative Solutions For Disappearing Keychains
    Burkey Level 2 Level 2 (205 points)
    I have similar keychain problem, but I have found only one keychain in my library folder:
    "login. keychain" Is there supposed to be two keychain items in that folder?

    I have installed the update from software update and run keychain first aid. Neither of these fixed my keychain problem.

    I am administrator but cannot get into any other keychain programs, mail, .Mac, safari, etc.

    Any suggestions as to what I could do?
  • 35. Re: Disappearing keychain? Leopard you magician you!
    washingtonsy2k Level 1 Level 1 (0 points)
    I'm having a huge problem with this since upgrading to Leaopard last week and nothing seems to be working. First I noticed that every time I was logging on to websites it would ask me if i wanted to save the password again and whenever I quit safari and reopened it, it would do the same thing. So I started looking around this forum.

    From here I learned to check my Users/Library/Keychains and there were only two files there: login.keychain and MicrosoftIntermediateCertificates. So first I changed the login.keychain to username.keychain. Also at this time (before I changed the name and logged out) in keychain access there was "login" in keychains but no "username" and it was in bold and so couldn't make it default. When I logged out after renaming the file there was a new file in the keychains folder, so one was username.keychain and one was login.keychain. When I went back to Keychain access there was a new one "username" but login was still in bold. I tried making username the default, that didn't work, then changed it back to login as default (i used Keychain First aid inbetween each time and logging out). Also one final note, I couldn't download the keychain update. for some reason when i try to it tells me that Macintosh HD doesn't meet the requirements even though i have over 20 gigs of free space.

    So after all this, i was kind of feeling desperate so what I did was to drag the login.keychain file to the desktop renamed it username.keychain then dragged it back to the keychain folder, overwriting the other file. Well that really messed everything up as I lost all my passwords. I ran Keychain Firstaid and logged in and out and there are the two files in the keychain folder again login and username and the same in keychain access. So now i have no more passwords (if anyone would know how to get them back if at all possible, without time machine, would be great) and still keychain doesn't work! Can anyone help?
  • 36. Re: Disappearing keychain? Leopard you magician you!
    washingtonsy2k Level 1 Level 1 (0 points)
    well a bit of an update, passwords in finder are saving, but it seems like it's just the safari passwords aren't saving...
  • 37. Re: Disappearing keychain? Leopard you magician you!
    bigj6360 Level 1 Level 1 (15 points)
    Washingtonsy2k...

    Same thing here. It seems to be Safari for me. All my other apps including finder work fine.

    10.5.1 + keychain update.
  • 38. Re: Disappearing keychain? Leopard you magician you!
    Mr Moto Level 1 Level 1 (140 points)
    I am having the same problems, even opened a thread about it (http://discussions.apple.com/thread.jspa?threadID=1302865&tstart=0), but I see this is a better place. Anyway - it is still a mess. I have to fill in passwords all day long.
    Does anyone have any good news by now?
1 2 3 Previous Next