Previous 1 2 Next 15 Replies Latest reply: Apr 25, 2008 6:18 AM by Christian Theussl
Poonaka Level 1 Level 1
Every time I open Firefox I get this message:

"Firefox" is an application which was downloaded from the internet. Are you sure you want to open it? Safari downloaded this file today at....


How do I turn this off?

MacBook, Mac OS X (10.5)
Solved by Neil R Roberts on Oct 27, 2007 5:02 AM Solved
You are right, it OSX.5 should remember and it does. I am replying via Firefox right now and I did get the message albeit one time only. Did you upgrade or archive and install fresh?
THis is important with regards to your write access.

Find and check the access properties on the firefox profile. (What you say?!) Close Firefox - Click on your main hd, users/your name/ library/application support and remove the firefox folder from under the Application Support directory. Restart firefox.. that should do it.
  • iVmichael Level 6 Level 6
    It sounds like you're launching it from the original disc image (dmg file in Downloads folder) and haven't dragged the application to the Applications folder yet ...
  • Poonaka Level 1 Level 1
    sounds like it but I did drag it out of the dmg that I downloaded.
  • FromOZ Level 3 Level 3
    This is new security feature (done properly compared to Vista) which will warn you about programs downloaded from Internet. Once you have expanded it (out of the .dmg as iVmichael says) and moved to your applications folder you should not get message anymore.
  • Poonaka Level 1 Level 1
    That's exactly what I've done but it still does it. It would be really nice if it would remember that you allowed the program to run before and not ask you each time.
  • FromOZ Level 3 Level 3
    I haven't personally tried it - yet - will give it a shot.
  • Neil R Roberts Level 2 Level 2
    You are right, it OSX.5 should remember and it does. I am replying via Firefox right now and I did get the message albeit one time only. Did you upgrade or archive and install fresh?
    THis is important with regards to your write access.

    Find and check the access properties on the firefox profile. (What you say?!) Close Firefox - Click on your main hd, users/your name/ library/application support and remove the firefox folder from under the Application Support directory. Restart firefox.. that should do it.
  • Poonaka Level 1 Level 1
    Thanks Neil, that did the trick.

    For those interested, this was a fresh install and firefox was originally installed by another account first.
  • simpleton42 Level 1 Level 1
    to Neil: did NOT do the trick for me

    to all who try the trick: mind you that removing "userX/Library/Application Support/Firefox" you loose all your firefox settings

    to all the others: this is NOT firefox specific, in fact, I get it constantly for all sorts of applications.

    big frustrating, unsolved problem.
  • Frank van Meurs Level 1 Level 1
    Ok, so... After found **** all on the Apple support site, in the developer documentation, etc, I turned to google and the man pages and came up with the following...

    The warnings are due to an extended attribute on the application directories, most likely set by Safari upon downloading the disc image. Usually, when a machine is a single-user machine or when the main user has admin rights, clicking away the warning would result in the extended attribute being unset (or something like that). However, when a user does not have sufficient rights to do so, the extended attribute can't be unset, resulting in the warning appearing over and over and over and over and ... (you get my idea).

    How to solve this:

    Option 1: *Give each user write permission in /Application*

    1. "Get info" on "Applications"
    2. Unlock the permissions panel (click the lock and type an admin user/pass)
    3. Grant "Everyone" "read & write"

    This, of course, is stupid. The obvious reason is that now anybody can write anything in /Applications. One way to circumvent this, is by granting individual users read & write permission. This, also, isn't very smart, but at the very least cumbersome when dealing with a few users. Furthermore, now you'll have defined an ACL an /Applications, which Disk Utility, when verifying permissions at some point will start nagging about, saying: "ACL found but not expected on 'Applications'."

    Option 2: *Remove the extended attributes and possible ACL's*

    1. Open the Terminal
    2. Switch to admin if not logged in as one (eg: "su admin")
    3. Change directory to /Applications (cd /Applications)
    4. Check which files have extended attributes (ls -lsa)

    The entries marked with an "@" have extended attributes (and ones with ACL's defined will be marked with a "+").

    5. List the attributes (xattr -l <FileOrDirectoryName>)
    6. Remove the "com.apple.quatantine" attribute if it is defined (xattr -d com.apple.quarantine <FileOrDirectoryName>)
    7. Recheck the attributes (see step 5)
    8. Rinse and repeat for all "downloaded applications" giving errors

    Should there be ACL's defined which were not supposed to be defined and which you want to remove:

    9. Check which ACL's are defined (ls -lsae)

    Each entry with an ACL defined will have them listed below the entry, arranged by number

    10. Remove ACL's, referring to each by number (sudo chmod -a# <ACL Number> <FileOrDirectoryName>)
    11. Recheck which ACL's are defined (see step 9)
    12. Rinse and repeat for each unwanted ACL
    13. Exit

    This should about fix all errors in Disk Utility and with quarantine warnings.
  • simpleton42 Level 1 Level 1
    Frank: you totally rock!
    Option 1: find it a little scary (btw. when starting firefox I do so as a user with sysadmin rights and still have the problem)
    Option 2: GREAT!! that did it for me!
    THANKS.
  • Dale Weisshaar Level 6 Level 6
    Good call Frank!
     DALE
  • Trejkaz Level 1 Level 1
    What I find laughable about this warning is that programs from "the Internet" are not actually any more dangerous than programs from anywhere else. The message should say "this program came from somewhere other than Apple", if it wants to be serious.

    Incidentally I've also seen this message appear on applications which were not downloaded from the Internet.
  • Lawrence C Paulson Level 1 Level 1
    I was getting this problem because I install applications using a dedicated admin account. There is a really simple solution.

    Every time you install a new version of an application, like FireFox, launch it immediately in your admin account, then click away the warning. Then you won't get the warning in user accounts.
  • ianinIT Level 1 Level 1
    Here is the solution I found. Put a copy of Firefox you have already installed successfully on another machine on a Flash drive. Overwrite the problem install of Firefox with the copy on the flash drive. Done. Worked great for me. I am guessing this works because that copy of Firefox was not downloaded on that machine.
Previous 1 2 Next