14 Replies Latest reply: Aug 14, 2008 4:09 PM by BrianD8562
applefun Level 1 Level 1 (0 points)
Anyone getting this error? "an unexpected error occured" (error code-43)

imac, Mac OS X (10.4.10)
  • raederle Level 1 Level 1 (0 points)
    Yes! I've reinstalled Leopard 3 times to no avail.

    I read elsewhere in this forum that someone suggested a clean reinstall (wipe out the harddrive first, then install Leopard onto the clean drive). I'll try this to see if it helps and report back. The annoying thing, of course, is that I'll have to back up my stuff first, then reinstall Leopard just so I can back stuff up with Time Machine! Ah well. Here goes everything...
  • cwolf Level 1 Level 1 (35 points)
    When are you getting this error? In the middle of performing a backup or when you click on the Time Machine icon in the dock to try to browse back in time? If you control-click on the Time Machine dock icon and click "Backup Now" do you also get an error? When you do that are there any messages in your system.log?
  • raederle Level 1 Level 1 (0 points)
    cwolf, you saved me hours and hours! Thank you!

    I was getting the -43 error message as soon as I clicked on the TM icon in the dock. I took your advice and control-clicked on the icon to get to the TM prefs, which I never thought to do. From there, it was clear that I couldn't make any changes to TM because the padlock icon was showing I was locked out, and wouldn't let me make changes to the TM settings without a sysadmin password, which I didn't have. So I followed the instructions for resetting the sysadmin password that came up when I clicked on the 'help' question mark in the login window. (This involves restarting with the Leopard install disk and using the system installer to reset the sysadmin password, then restarting again.) Voila! I was able to log in as the sysadmin, change the settings in TM to help it find the backup drive, and it's now merrily (if slowly!) chugging away to save all my stuff to the external drive.

    Thank you thank you thank you! Hope this helps applefun, too!
  • cwolf Level 1 Level 1 (35 points)
    Glad it helped. How were you able to configure Time Machine in the first place though if you did not have an admin password?
  • raederle Level 1 Level 1 (0 points)
    No idea, honestly. I think I screwed something up when I first started TM. TM opened itself when I first turned on the external drive and asked if this was the drive I wanted to use for back-ups. I said yes, but then TM seemed to do nothing. I figured, uh-oh, something's not right-- better shut off the drive and restart the Mac. But after I did, TM wouldn't open at all (so it seemed), giving me the -43 error. -43 probably means "Stupid User Error."
  • drummerkid33 Level 1 Level 1 (0 points)
    I had the same problem, what i did is this:
    1. go to system preferences
    2. go to time machine
    3. click change disk
    4. select none
    5. turn time machine off
    6. click change disk again
    7. select your external HD
    8. turn it back on

    this worked for me. hope that helps!
    -austin
  • Eric Cabot Steed Level 1 Level 1 (5 points)
    I lost my document folder. Went to the time machine, which was installed and on the desktop for two days. When I attempted to open the time machine I got error -43. When I followed the suggestions below, the drive vanished. When I restarted the machine the Time machine backup was there, empty, I mean completely empty but my other external drive was now gone and also needs to be initialized or rejected- However, You guessed it all my priceless & irreplaceable files from my G4 running the previous version of OS X are on it, or at least were. 114,800 files. Four or Five days of backup in preparation for this upgrade eaten by time machine?

    Help !!
  • AndrewC1970 Level 1 Level 1 (15 points)
    Drummerkid33, you are a legend!

    I was experiencing this problem, and could not work out what was going wrong.

    I re-installed Leopard, but still had the problem. I spent over 1 hour with Apple Support and they could not solve my problem either!

    I did your fix, and it all works fine now!

    Thanks heaps (you should work for Apple!).

    I am also experiencing some problems with my iMac seeing my external Western Digital My Book when connected with Firewire. There are no problems when connecting via USB. My drive connects via firewire and USB with my Macbook so it is not a problem with my external drive, and I can connect other firewire items to my iMac (so not a faulty firewire port).

    Apple Support were also not able to resolve this problem either. Any suggestions?

    Message was edited by: AndrewC1970
  • Brett Jolly Level 1 Level 1 (15 points)
    Guys, I just want to say thank you for sitting and doing what you're doing, you just saved me about 10 hours of work Re: error 43, I don't know why you do it and if you get anything for it, but you are a constant source of inspiration and knowledge, that goes far beyond what Apple themselves deliver (all that too is world class) Thanks
  • emberglance Level 1 Level 1 (0 points)
    Just wanted to echo those thanks. drummerkid33, you can't know how relieved I am to get that fixed.
  • RJToronto Level 1 Level 1 (10 points)
    Thanks, Austin!

    I was browsing through my Console & I also kept seeing all the Error -43 messages, but your fix sorted it out.

    Respect.

    RJ
  • mliving Level 1 Level 1 (0 points)
    Amen for the Apple support forums!

    Thanks to all.
  • Applebean Level 1 Level 1 (0 points)
    Hi folks. New iMac user. I'm experimenting this error... why? I don't have an external "back up" drive... do I need one? I started to follow the instructions from Drumm... and I don't get any more the error, the problem now is that Time Machine doesn't run and now is asking me for a Storage Location for Time Machine back ups.. I click Set Up Time Machine and it opens it up, but when I choose Backup Disk, it doesn't offer any alternatives (so, again, does TM only work with an external Back up Drive?)
  • BrianD8562 Level 1 Level 1 (0 points)
    I fought a generic "Time Machine Error" with error: (-43), (-36) and error: 11 being reported in the log at the point of failure, for two weeks. I tried everything posted to these forums and any other thing I could think of. In the end, the only way to resolve the problem was to delete the .sparsebundle file on the backup drive. The primary backup drive is a Time Capsule which does not seem to be the problem. This is the second time I've needed to delete the backups on my backup drive. This time, I managed to get 2.5 months worth of backups before I had to trash everything.