Skip navigation
This discussion is archived

Secure empty trash

2706 Views 15 Replies Latest reply: Jan 21, 2008 3:50 PM by Lithmac RSS
1 2 Previous Next
SteveSJS Calculating status...
Currently Being Moderated
Oct 27, 2007 7:11 AM
I've managed to select secure empty trash to empty my trash can after the upgrade. Doh!
It's now taking for ever to empty and there doesn't seem to be any way of stopping and just emptying it.
so far tried stopping and starting the machine - trash can then shows as empty.
dropping something in and emptying works just fine.
Dropping something small in and then doing a secure empty goes back to the problem again.
Any ideas folks?
iMac G5, Mac OS X (10.4.10), Power PC
  • EZ Jim Level 7 Level 7 (21,260 points)
    Currently Being Moderated
    Oct 31, 2007 4:33 PM (in response to SteveSJS)
    Welcome to Apple Discussions, Steve,

    It is working that way for me and many others, too:

    http://discussions.apple.com/search.jspa?objID=c235&search=Go&q=secureemptytrash

    I have not found a fix yet.

    EZ Jim

    PowerBook 1.67 GHz w/Mac OS X (10.4.10) G5 DP 1.8 w/Mac OS X (10.5)  External iSight
  • whatsinitforme Level 1 Level 1 (40 points)
    Currently Being Moderated
    Oct 31, 2007 5:18 PM (in response to SteveSJS)
    only way at this point in time is to force quit finder to exit the secure empty trash "freeze"

    its just another stuff up from Apple. and i hope they can fix all the issues very very quickly for loyal users who bought this terrible OS Leopard in good faith.
    G5 Imac, Mac OS X (10.5)
  • Roger Rodrigues Level 1 Level 1 (70 points)
    Currently Being Moderated
    Nov 15, 2007 5:51 PM (in response to whatsinitforme)
    Not fixed in 10.5.1
    MacPro, Mac OS X (10.4.8)
  • Joe Gramm Level 5 Level 5 (6,315 points)
    Currently Being Moderated
    Nov 18, 2007 10:44 PM (in response to Roger Rodrigues)
    Same here. Not fixed in 10.5.1
    iMac G5 PPC 20" 2GHz, 2GB Ram/400GB HD, iMac G4 15" 800MHz, Mac OS X (10.5), Airport Extreme/Express, OWC 320GB FWHD, iLife 08, QT7 Pro, JBL Encounters
  • glb Level 2 Level 2 (310 points)
    Currently Being Moderated
    Nov 20, 2007 5:32 AM (in response to SteveSJS)
    I'm having the same problem. I've never used Secure Empty Trash before using Time Machine (it's the only way to delete items forever) and it takes a long time. At first I thought that was normal, but it takes so long I usually end up just canceling it and then just deleting stuff.

    The problem is, I just deleted a BUNCH of games that have numerous files all over my system and I wanted to delete that stuff forever.

    FWIW, if you click "Secure Empty Trash" under the Finder preferences, it seems to empty normally. If you click Secure Empty Trash in the Finder menu, it appears to take forever, as indicated.

    Glad to see I'm not the only one.

    Message was edited by: glb
    iMac 24" C2D. G5 1.6, Mac OS X (10.5.1)
  • Joe Gramm Level 5 Level 5 (6,315 points)
    Currently Being Moderated
    Nov 20, 2007 5:33 AM (in response to glb)

    The problem is, I just deleted a BUNCH of games that have numerous files all over my system and I wanted to delete that stuff forever.

    Keep in mind that there still is no forever with Secure Empty.
    Read about Secure Empty
    iMac G5 PPC 20" 2GHz, 2GB Ram/400GB HD, iMac G4 15" 800MHz, Mac OS X (10.5.1), Airport Extreme/Express, OWC 320GB FWHD, iLife 08, QT7 Pro, JBL Encounters
  • glb Level 2 Level 2 (310 points)
    Currently Being Moderated
    Nov 20, 2007 3:51 PM (in response to Joe Gramm)
    Joe Gramm wrote:
    Keep in mind that there still is no forever with Secure Empty.


    It would seem that Secure Empty is deleted forever if it's done right.

    Either way, not only do I not want this on my system, but I want to delete it from the Time Machine backups. I deleted a LOT of stuff off my system, and I need to get it off of TM, and now it seems like I'll have to do that manually.

    Not really the best option, since we all know apps leave a lot of crap behind. That's why I used AppZapper, then wanted to securely delete everything, even from TM just to save on room.

    It seems that Apple hasn't really thought this through.

    Message was edited by: glb
    iMac 24" C2D. G5 1.6, Mac OS X (10.4.7)
  • Swish17 Calculating status...
    Currently Being Moderated
    Dec 14, 2007 6:09 PM (in response to SteveSJS)
    Have you recently turned OFF Time Machine.
    I had items in the trash which had been stored in time machine backups.
    Then I turned Time Machine off.
    Then later I added items to the trash.
    When I then tried to secure delete - and got the hang you describe.
    Turning Time Machine back on, then secure deleting succeeded in deleting all files without the hang.
    G5, Mac OS X (10.4.8)
  • mbmgibson Level 1 Level 1 (25 points)
    Currently Being Moderated
    Dec 16, 2007 2:11 AM (in response to Swish17)
    I've seen Leopard randomly succeed/fail to empty the trash at different times -- including it working for me yesterday and not today, which is what brought me here -- and I've never run Time Machine on this Mac.
    Intel iMac/MacBook/iPod nano/, Mac OS X (10.5)
  • Alan Gabrielli Calculating status...
    Currently Being Moderated
    Dec 22, 2007 11:45 AM (in response to SteveSJS)
    Relaunching the Finder kills the process and restores control of the trash. Do a Force Quit... and select Finder.
    Mac OS X (10.4.7)
  • JongawOlya Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 15, 2008 11:32 PM (in response to SteveSJS)
    Hello all,

    It is happening to me too.
    Not all the time - but most of the time. Out of 10 times, 9 failed and perhaps only 1 time succeeded.

    The same as most of the post that I have read - the Trash icon will appears to be empty but somehow the Secure Empty Trash process bar seems to be in the processing status forever when it comes to show that there's only 5 items left. Although by performing a Force Quit to the finder solve everything. But a bug is a bug. It should be fix and we shouldn't be living like this.

    Some say that - after they Secure Empty Trash, got stuck, and Force Quit finder - they found out that there's still some hidden files remain in the Trash. Although I am not sure how to they saw the hidden files. But it seems that - it happens to me too. As I was trying to Secure Empty Trash a halfway downloaded file (just one file and not folder), the Secure Empty Trash process bar stated there's 20 items to be trash. ~ Weird ~ That cycle was successfully completed though.

    Anyway, I was wondering - Does this happen to ALL Mac OS X Leopard user? Or does this only happen to those who performed an upgrade installation? and it doesn't happen to those with clean installation? Or the chances was just 50 - 50 percent? Some got lucky and some don't?

    Do we by any chance know someone out there who doesn't seems to have this problem? Could it be just a single string/script that was mess-up?

    Best Regards,

    Jon Gan
    Macbook Pro, Mac OS X (10.5.1)
  • stankay Calculating status...
    Currently Being Moderated
    Jan 16, 2008 8:50 AM (in response to SteveSJS)
    It's happening to me too. Just upgraded to 10.5.1. Secure emptying on 10.3.9 was breeze; now it takes forever.

    I hope that someone at Apple is paying attention to this problem, and that we can look forward to a prompt fix. I work with documents that have sensitive information, and I consider this to be an essential feature.
    Power Mac G4, Mac OS X (10.5.1)
  • YodaSoda Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 20, 2008 9:23 PM (in response to SteveSJS)
    I have the sme problem... only it says I have 844 items to delete?!?! I only have like 50 items in the trash. I'm willing to except that there are other files I may be over looking but that still feels like a lot to me. Its froze up before when It told me I had fewer items too. Yup still sitting there. HELP!
    Mac Pro, Mac OS X (10.4.10), 4GB MHz, 2x3 Dual-Core Intel Xeon
  • Dan Peterka Level 1 Level 1 (65 points)
    Currently Being Moderated
    Jan 21, 2008 1:22 PM (in response to SteveSJS)
    I've been cleaning up my HD and had this issue. Seems that I can delete hundreds of files (in a lengthy, but not unreasonable time), but when the countdown gets to 4 or 5, it hangs up. While making progress against the list of files, there is a process call Locum that is consuming processor time. When the hang occurs, Locum is still running, but no longer using much CPU. Using Terminal, I can see that the ~/.Trash folder is empty (no hidden files either), but since Secure Empty is supposed to be overwriting the files in place, I'm not sure anything of significance would be shown in ~/.Trash anyway except for links to the actual files.

    As mentioned above, a relaunch of Finder restores things, but I always reboot after a relaunch just in case the gremlins are still running. After the restart, a normal Empty Trash works fine.
    Powerbook G4, Mac OS X (10.5.1)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.