14 Replies Latest reply: Nov 5, 2007 7:35 PM by garfoon
garfoon Level 1 Level 1 (0 points)
Since installing 10.5 the Mac asks me for my password to delete files. I have seen ths happen on my TM volume and my FAT32 XP volume.

iMac 24", Mac OS X (10.5)
  • andyirwin Level 1 Level 1 (0 points)
    I'm having the same problem. I can't move or delete files without being asked for the password. I'm at a loss as to what else to try. I tried repairing permissions in case that would work but it didn't...
  • Dion Rodrigues Level 2 Level 2 (155 points)
    Sounds like the upgrade to Leopard converted your account to a non-admin user. This has happened to other people, you need to boot from the Leopard install DVD and repair permissions. Hopefully this fixes things for you.
  • showme Level 1 Level 1 (30 points)
    Have you done the newest Leopard update? It should fix your problem.
  • garfoon Level 1 Level 1 (0 points)
    I just did the update and repair of the permissions. I have not seen the problem, yet.

    I don't know if this is related but programs cannot create files on the Time Machine drive. If the files existed before the 10.5 install they can be written to but new files cannot be created. iMovie (new and old) state that they cannot create a new files.

    I use a 1TB FW800 drive for the Time Machine drive and cannot dedicate it only to TM.
  • andyirwin Level 1 Level 1 (0 points)
    Hmm, didn't seem to work for me... I booted from the install dvd, used password reset to reset "home dir permissions and ACLs" and used disk utility to repair permissions, but to no avail. To move or delete any file on Macintosh HD I still need to enter the password! My account is displayed as an admin one under system pref/accounts...
  • garfoon Level 1 Level 1 (0 points)
    Now that I have been using the system for a while it is not fixed. When I try to delete a file on the FAT32 drive it asks for the password, gives me the trash sound but leaves the file on the drive.
  • vamp08 Level 1 Level 1 (0 points)
    I'm seeing the same thing. I notice that all the problem files have a custom acl for "everyone" besides the normal one which is set to allow rw. I have no idea what is going on given that owner has the necessary persmissions to delete. Very frustrating since it is not allowing me to run my chronosync job.
  • andyirwin Level 1 Level 1 (0 points)
    Yeah, same here on my Macintosh HD but it's changed a bit - I can now delete/rename files after running "repair permissions" again but any folder to be deleted makes the trash sound but it's left there. It won't let me rename a folder either - says i don't have sufficient access priveleges.
  • vamp08 Level 1 Level 1 (0 points)
    Has anybody found other threads on this subject? It's got to be pretty common.
  • garfoon Level 1 Level 1 (0 points)
    This is getting weirder....

    On my FAT32 drive I can read and write anything NOT in a folder, only in the root directory.

    I can only read FAT32 folders/subfolders. I am asked for a password and get the trash sound but the file does not delete.

    Applications that need to write to the folders/subfolders all fail.

    On my "Mac" drives.....

    Everything works ok on the Macintosh HD, other drives require passwords to remove folders/data. Applications also fail that write/create files on other drives.

    Files dragged to the trash do the trash sound, after asking for the password, but do not delete. If I right click and select move to trash they do get deleted, again after asking for the password.

    MacFixIt posted a fix for a problem that the user account was demoted from admin and that sounded like what is happening here but I could not get the commands they listed to work.

    My account shows as an admin but is not working like one.

    I created a root user and signed on to it and that ID works correctly. Clearly this is account related but I'm not about to delete and recreate my account! (At least not yet!)
  • vamp08 Level 1 Level 1 (0 points)
    I just tried demoting my account to non admin and the back to admin. after a login/logout. This did not help. If recreating the account is what I must do I'll do it but I'm not looking forward to it. If I do it, Can I just bring over the entire user tree to the new account or am I asking for a world of trouble by doing that? I just finished reinstalling most of my apps and registering etc.
  • garfoon Level 1 Level 1 (0 points)
    I need to update this....

    I re-signed on as ROOT and noticed that I several folders or drives have a little lock icon on them and I have read only access to them.

    On my normal account I also now notice the little lock and have entire volumes as read only but when I look at "get info" it shows read + write for everybody. Even though I have read only programs seem to be able to write to them.

    These privileges are really messed up.
  • vamp08 Level 1 Level 1 (0 points)
    Is there a good web page out there that explains how apple uses acls? When I am logged in normally even though I can admin the machine, I am not running as a member of the admin group till I am requested to authenticate right? I agree that if it says everyone can at least read an item you should be able to view it no matter who you are.
  • garfoon Level 1 Level 1 (0 points)
    After a long call with Apple the fix is below....


    Open Terminal (/Applications/Utilities).
    Type this, followed by a space: sudo chflags -R nouchg
    Drag the folder you would like to unlock into the Terminal window.
    Press Return.
    Enter your password and press Return.

    It did not work on my Time Machine drive because the name of the drive had a space in it. I could not rename the drive since I could not modify it. In the end I had to boot the install disk and reformat the drive and reissue the above command.