Skip navigation
This discussion is archived

Leopard is setting RWIN too large!!!

19918 Views 68 Replies Latest reply: Apr 17, 2008 2:51 PM by mbpjunkie RSS
  • Scott Micciche Level 1 Level 1 (130 points)
    Currently Being Moderated
    Oct 29, 2007 9:38 AM (in response to kingbloobie)
    I would try a setting of:

    net.inet.tcp.sendspace=64240
    net.inet.tcp.recvspace=64240

    You can do this in the terminal:

    sudo sysctl -w net.inet.tcp.sendspace=64240
    sudo sysctl -w net.inet.tcp.recvspace=64240

    You may also add this to your /etc/sysctl.conf and it will be read at boot time.

    64240 is what I have used on almost all my Checkpoing Firewall-1 boxen running on Solaris 9/10, it seems to work very well.
    MBP 2.24/PMG5 2.0/iBook G4, Mac OS X (10.4.10)
  • kingbloobie Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2007 1:44 PM (in response to Scott Micciche)
    I was able to accomplish these changes:

    sudo sysctl -w net.inet.tcp.sendspace=64240
    sudo sysctl -w net.inet.tcp.recvspace=64240

    and the TCP analyzer reads not much differently to my untrained eyes:

    « SpeedGuide.net TCP Analyzer Results »
    Tested on: 10.29.2007 16:37
    IP address: 70.181.xxx.xxx

    TCP options string: 020405b4010303000101080a2b9d12a20000000004020000
    MSS: 1460
    MTU: 1500
    TCP Window: 65160 (NOT multiple of MSS)
    RWIN Scaling: 0
    Unscaled RWIN : 65160
    Reccomended RWINs: 64240, 128480, 256960, 513920
    BDP limit (200ms): 2606kbps (326KBytes/s)
    BDP limit (500ms): 1043kbps (130KBytes/s)
    MTU Discovery: ON
    TTL: 50
    Timestamps: ON
    SACKs: ON
    IP ToS: 00000000 (0)

    When trying to access </etc/sysctl.conf> to make the change permanent in Terminal, I get this response:

    /etc/sysctl.conf
    -bash: /etc/sysctl.conf: Permission denied

    Whattaya think?
    15" PB G4 1.67 GHz, Mac OS X (10.5)
  • kingbloobie Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2007 1:47 PM (in response to kingbloobie)
    Correction: I see now that the Unscaled RWIN has doubled to 65160, as desired. I guess I just need help now making the alteration permanent. Thanks in advance, Scott! You've been tremendously helpful.
    15" PB G4 1.67 GHz, Mac OS X (10.5)
  • kingbloobie Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2007 1:52 PM (in response to kingbloobie)
    By the way, under the new settings, testmy.net indicates a screaming improvement in my internet download speed:

    Your connection is: 8386 Kbps or 8.4 Mbps
    You downloaded at: 1024 kB/s

    Thanks again...
    15" PB G4 1.67 GHz, Mac OS X (10.5)
  • Scott Micciche Level 1 Level 1 (130 points)
    Currently Being Moderated
    Oct 29, 2007 2:00 PM (in response to kingbloobie)
    You can use the procedure in my previous post:

    open the terminal
    cd /etc
    sudo pico sysctl.conf

    <make your changes>

    ctrl x (enter "Y" to "yes" to save the pic)
    return when prompted for the filename: sysctl.conf

    you should be out of the file
    MBP 2.24/PMG5 2.0/iBook G4, Mac OS X (10.4.10)
  • Scott Micciche Level 1 Level 1 (130 points)
    Currently Being Moderated
    Oct 29, 2007 2:01 PM (in response to kingbloobie)
    You need superuser privs to edit files in /etc

    try using sudo
    MBP 2.24/PMG5 2.0/iBook G4, Mac OS X (10.4.10)
  • Lord Brian Level 1 Level 1 (25 points)
    Currently Being Moderated
    Oct 29, 2007 2:20 PM (in response to Elliot Roth)
    Fantastic, now I can use VPN from home and connect to all my windows shares.

    Thanks
    iMac 24" 2.4Ghz, Mac OS X (10.5)
  • computechrx Level 1 Level 1 (20 points)
    Currently Being Moderated
    Oct 29, 2007 2:38 PM (in response to Scott Micciche)
    Scott,

    Scott Micciche wrote:
    I've been a Unix sysadmin for 19 years, editing files isn't as scary as some think.


    Easy for you to say!!!!

    Thank you so much for that fix. Although I am new to the Mac, I have been around computers for a long time, an old DOS junkie. Unix is completely new to me, but the process seems similar. I just don't know all the commands yet.

    I followed your excellent post and my internet speed is right back where it was before the Leopard install. RWIN at 66608 with DSL connection. I am going to check our iMac next.


    Thanks again

    null
    MacPro, Mac OS X (10.5)
  • kingbloobie Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2007 2:38 PM (in response to Scott Micciche)
    Scott: I was able to modify the file in sudo as per your direction. Here's what speedguide.net reports now:

    « SpeedGuide.net TCP Analyzer Results »
    Tested on: 10.29.2007 17:34
    IP address: 70.181.xxx.xxx

    TCP options string: 020405b4010303030101080a078e3a690000000004020000
    MSS: 1460
    MTU: 1500
    TCP Window: 524280 (NOT multiple of MSS)
    RWIN Scaling: 3
    Unscaled RWIN : 65535
    Reccomended RWINs: 64240, 128480, 256960, 513920
    BDP limit (200ms): 20971kbps (2621KBytes/s)
    BDP limit (500ms): 8388kbps (1049KBytes/s)
    MTU Discovery: ON
    TTL: 50
    Timestamps: ON
    SACKs: ON
    IP ToS: 00000000 (0)

    Is this the expected result? Thanks...
    15" PB G4 1.67 GHz, Mac OS X (10.5)
  • Scott Micciche Level 1 Level 1 (130 points)
    Currently Being Moderated
    Oct 29, 2007 2:53 PM (in response to kingbloobie)
    Looks quite right, I usually use the dslreports.com tweak test, but it accomplishes the same thing you have here.
    MBP 2.24/PMG5 2.0/iBook G4, Mac OS X (10.4.10)
  • kingbloobie Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2007 3:07 PM (in response to Scott Micciche)
    Well, it certainly feels right; my connection is even faster now:

    Your connection is: 12481 Kbps or 12.5 Mbps
    You downloaded at: 1524 kB/s

    You rock!
    15" PB G4 1.67 GHz, Mac OS X (10.5)
  • Scott Micciche Level 1 Level 1 (130 points)
    Currently Being Moderated
    Oct 29, 2007 3:09 PM (in response to kingbloobie)
    Glad that worked out, I guess the purported "network auto-tuning" in Leopard isn't always the most efficient for some networks.
    MBP 2.24/PMG5 2.0/iBook G4, Mac OS X (10.4.10)
  • Rod Ernouf Calculating status...
    Currently Being Moderated
    Oct 31, 2007 7:35 PM (in response to Elliot Roth)
    Hi All,
    Testing all the fixes now. You can use TextWrangler to edit a sysctl.conf file. Make sure you set the text option to "Unix."
    Rod
    PowerBook G4, Mac OS X (10.5), 867mhz 1gb SDRAM
  • PeteNET Calculating status...
    Currently Being Moderated
    Oct 31, 2007 8:37 PM (in response to Elliot Roth)
    Any ideas on how to change the MTU? It won't stay at 1500.

    I do the sudo ifconfig en1 mtu 1500

    but obviously, that doesn't keep after reload.

    thx!
    MacBook 2.16, Mac OS X (10.4.10)
  • Apple a day Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 31, 2007 10:46 PM (in response to Scott Micciche)
    on tiger:

    kern.exec: unknown type returned
    net.inet.tcp.sockthreshold: 256
    charlie-schloss-computer:~ charlieschloss$
    Mac OS X (10.4.10)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.