1 2 3 4 5 Previous Next 70 Replies Latest reply: Jun 22, 2008 7:18 AM by archigos Go to original post
  • 60. Re: iCal Server error
    std_micha Level 1 Level 1 (0 points)
    hello @ all,
    please go to your router & setup port extern & intern tcp 8008!!!

    micha
  • 61. Re: iCal Server error
    ClarkDV Level 2 Level 2 (175 points)
    Did that, still broke. Just installed the 10.5.2 update, still broke.
  • 62. Re: iCal Server error
    rediguana Level 1 Level 1 (0 points)
    I've just managed to resolve the 210 error issue I was having with the help of these threads.

    It appears it was the permissions for me.

    su chown calendars:calendars /Library/CalendarServer
    su chmod 774 /Library/CalendarServer
    su chown calendars:calendars /Library/CalendarServer/Documents
    su chmod 770 /Library/CalendarServer/Documents

    It didn't appear to be fixed straight away, but after a proper restart it worked fine...

    1. Stop iCal and Web servers.
    2. Start Web server
    3. Start iCal server (once Web server is green)

    I tested the hostname issue but that didn't appear to impact my installation.

    Cheers Gav
  • 63. Re: iCal Server error
    Cyrus Daboo Level 2 Level 2 (230 points)
    Do you know what the permissions were on those directories before you changed them?
  • 64. Re: iCal Server error
    rediguana Level 1 Level 1 (0 points)
    I didn't note it down at the time (silly me) but I am fairly certain that CalendarServer was admin:root.
  • 65. Re: iCal Server error
    Cyrus Daboo Level 2 Level 2 (230 points)
    This is the correct permissions for /Library/CalendarServer:

    cyrusdaboo$ ls -la /Library/CalendarServer/
    total 0
    drwxrwxr-x 3 root admin 102 Dec 15 17:41 .
    drwxrwxr-t+ 59 root admin 2006 Feb 14 10:12 ..
    drwxr-x--- 2 _calendar _calendar 68 Dec 15 17:41 Documents
  • 66. Re: iCal Server error
    TalonG0LD Level 1 Level 1 (0 points)
    So i've tried many combinations of the above resolutions to no avail! I still get the 210 error. I was trying to do the "su" (substitute user) command mentioned above, and my terminal literally told me "sorry".

    Anything I might be doing wrong? when i tried running the command
    su chown calendars:calendars /Library/CalendarServer
    it asked me for my admin password, i entered it and all i got was
    su: Sorry

    The permissions seem wrong, it is not pointed to my '_calendars' user.

    Any quick hints to give this one a try? Needless to say this has gone far beyond Apple's reputation for "Just one click" I figure the moment that I have to go into terminal to make an "On the box" feature work properly, something has gone terribly wrong.

    Hope you can help,
    Cheers,
    Michael
  • 67. Re: iCal Server error
    Frank Pajonk Level 1 Level 1 (40 points)
    Just to add another layer of complexity:

    I have the server up and running and currently 6 groups with wikis ad calendars. 5 out of 6 calendars work - most of the time.

    One calendar was working until we imported events from NowUpdtoDate (several hundred events). Result: Error 210. And yes, I checked everthing that was suggested in the multiple threads on error 210.

    Today, I created another group and reimported. Same thing. So, the bottom line is, certain event types may compromise the iCal server function.

    Side note: It's sad to see that Apple does not actively participate here to solve this problem
  • 68. Re: iCal Server error
    Cyrus Daboo Level 2 Level 2 (230 points)
    Can you post both the iCalServer and wiki server error logs that cover your attempt to access one of the group calendars with the imported events.
  • 69. Re: iCal Server error
    Cerniuk Level 1 Level 1 (10 points)
    Badda boom, badda bing! Key was to restart the web server after adjusting the domain reference in iCal server.

    Problem with normal DNS is that in a corporate environment, we don't necessarily get a domain name.
  • 70. Re: iCal Server error
    archigos Level 1 Level 1 (0 points)
    I tried your solution and it worked perfectly!!
1 2 3 4 5 Previous Next